FreeBSD 13: cannot start X (Gnome)?

Discussion in 'Other Guest OS Types Discussion' started by salvomic, Nov 5, 2021.

  1. salvomic

    salvomic Kilo Poster

    Messages:
    172
    hi,
    I installed the FreeBSD 13 distribution from scratch on Parallels 17 for Mac. The installation apparently went well, but Gnome doesn't start. I followed this guide.
    There seems to be problems with GDM or DBUS and the error "Cannot rum in framebuffer mode. Please, specify busIDs."
    I put the useful information in /etc/rc.conf and /etc/fstab...
    The rest works (text mode).

    Are there any things to know or settings to put in the Parallels configuration?

    Instead, if I upgrade from a VM with FreeBSD 12 the update works, Gnome also works but when you click on "Settings" and then choose "Users" you can no longer use Settings again: gnome-settings no longer opens.

    Any help?
     
  2. salvomic

    salvomic Kilo Poster

    Messages:
    172
    sorry for wrong indication in the last sentence, and, please, read:
    gnome-control-center no longer opens
     
  3. salvomic

    salvomic Kilo Poster

    Messages:
    172
    Same problems with KDE 5. Then it will perhaps be a conflict with the X server.
    Any help?
     
  4. salvomic

    salvomic Kilo Poster

    Messages:
    172
    Two precisations:
    1. new installation with AMD-64 DVD iso distribution
    2. upgrading from the old 32bit AMD (12 already upgraded from 11)
     
  5. salvomic

    salvomic Kilo Poster

    Messages:
    172
    the issue is also with other GUI (KDE, XFCE), so the problem is here: "cannot open display" (127.0.0.1).
    I've installed also sshd daemon and few other things.
    How to set the X Display?
    I've tried many things: export DISPLAY=localhost:0 :)1 :10) and so on... no luck.
    Why with the upgrade 12->13 Gnome (and the X server) works (apart of the issue of "Settings -> Users") and in the fresh installation not?
     
  6. salvomic

    salvomic Kilo Poster

    Messages:
    172
    ...in /etc/rc.conf there is
    Code:
    hald_enable="YES"
    but with
    Code:
    service hald enable
    I get errors:
    hald does not exist in /etc/rc.d or the local startup directories (/usr/local/etc/rc.d), or is not executable.
    Could be a problem?
    How can I install and test hald?
     
  7. salvomic

    salvomic Kilo Poster

    Messages:
    172
    Sorry for the many messages above: if you could edit the posts it would be easier, and I could avoid it...

    Dunque, ho fatto molte prove e credo che il problema stia nel server X: non ci si può collegare (come X) a 127.0.0.1 (localhost) e non serve provare con
    Code:
    export DISPLAY=:0
    The answer is always: "could not connect to 127.0.0.1 ... connection refused" and "cannot open X server"...
    It should be noted that SSH works well and I can connect (but not with X) from my Mac with
    Code:
    ssh -Y -p 22 myname@10.211.55.28 (ip of the freeBSD machine)
    So, the problem is with X server here. Instead, in the old i386 32 machine (now with freeBSD 13) there is no this problem, in the same computer...

    Help, please.
     
  8. salvomic

    salvomic Kilo Poster

    Messages:
    172
  9. salvomic

    salvomic Kilo Poster

    Messages:
    172
    The configuration lacks the video card (Parallels), as it appears here
    Code:
    salvo@freeBSD:~ $ pciconf -lv | grep -A4 vga
    vgapci0@pci0:1:0:0:    class=0x030000 rev=0x00 hdr=0x00 vendor=0x1ab8 device=0x4005 subvendor=0x1ab8 subdevice=0x0400
        vendor     = 'Parallels, Inc.'
        device     = 'Accelerated Virtual Video Adapter'
        class      = display
        subclass   = VGA
    Please, how can I configure it (inside FreeBSD)?
     
  10. salvomic

    salvomic Kilo Poster

    Messages:
    172
    SOLVED:
    The solution is to install x11-drivers/xf86-video-scfb drivers, then to set a file /usr/local/etc/X11/xorg.conf.d/driver.scfb.conf configured as:
    Code:
    Section "Device"
      Identifier "Card 0"
      Driver "scfb"
    EndSection
    However, so the resolution in X is always 1024x768. How can to set 1440x1050?
     

Share This Page