FreeBSD 6.2 and mouse under X11 after X -configure

Discussion in 'Other Virtual machines' started by calyth, Dec 13, 2007.

  1. calyth

    calyth Bit poster


    FreeBSD 6.2 installed under Parallels 3 with little difficulty, and I was going to bring GNOME up.

    However, if I do run X without a /etc/X11/xorg.conf, the mouse works, but the resolution's way too big. If I run X -configure, restrict the resolution, then the mouse doesn't work.

    Does anyone have the same problem? Anyone with solutions?
  2. DouglasO

    DouglasO Bit poster

    FreeBSD X11 and Parallels Desktop 4

    Getting the mouse to work required a change to the standard configuration file. X11 worked when built from the ports, but the Xorg -configure auto-generated file needed a minor alternation for the mouse to work.

    Within Section "InputDevice"
    Identifier "Mouse0"

    The Option "Device" "/dev/psm0" was used.

    For some reason, exiting X11 required sending Ctl+Alt+F1 rather than Ctl+Alt+Backspace.

Share This Page