Fullscreen - non-distracting menubar

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by ChristophR7, Feb 2, 2023.

  1. ChristophR7

    ChristophR7 Bit poster

    Messages:
    5
    Hi
    I'm using Parallels running Windows 11 on a MacBook Pro M1 Pro with an external widescreen display. If I run the VM in normal fullscreen mode, then you can see the normal MacOS menubar with the VM controls, but additionally, if you hover over the top edge of the screen, a grey "window" bar pops up that has a row of icons on the right side.
    In my opinion this grey bar is super distracting if you want to interact with a Windows system, because a lot of controls actually reside at the top of the screen when using Windows (it very often happens, that this bar shows up, when I for example want to close a window using "X" on the top right.... and so on). Also, I think that the controls in this grey bar are mostly a duplicate of the items in the MacOS menubar.
    One thing I tried was using the VM in "Optimize full screen for games" mode in order to get rid of menus at the top of the screen that I mostly never use. However, this feature seems to not work correctly for me. The MacOS menubar is not shown (win!), however, the grey control bar in my case is cut off in half (see screenshot in attachment). So this in my opinion is certainly a bug in Parallels.

    Therefore, I suggest the following:
    1. In normal full screen mode, the grey bar with the controls on the right side should not be shown anymore and all the interaction with the VM is done from the MacOS menubar (less extent version would be to only show it while pressing some keyboard modifier and hovering with the mouse)
    2. In "optimize full screen for games" mode, the normal MacOS menubar should be shown while approaching the top edge of the screen while pressing a keyboard modifier key. The grey top bar should not be shown at all.
    If these features are not pursued, I kindly ask to fix the half cut off grey bar problem when running the VM in "optimize full screen for games" mode.

    Feel free to ask questions should you need further information on my suggestion/problem.
    Cheers, Chris
     

    Attached Files:

  2. GaborR

    GaborR Bit poster

    Messages:
    2
    Unfortunately same for me. Makes it working full screen Win11 almost unusable!!!!! This is a bug clearly!
     
  3. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    81
    Hello.

    Please check if the performing the following would alleviate the grey menu bar appearing in full screen mode:

    1. Shut down the Virtual Machine. Make sure that the virtual machine is shut down. If it is in a suspended state, please run it and then shut down (Actions > Shut Down).
    2. Go to Apple logo.
    3. Select "System Settings".
    4. Find "Desktop & Dock".
    5. Find "Automatically hide and show the menu bar" option.
    6. Choose "In Full Screen Only".
    7. Start your virtual machine and check if it displays correctly.
    Note: For macOS Monterey, the option would be under Dock & Menu Bar -> Automatically Hide and Show Menu Bar in Full Screen.

    Additionally, while "Optimized for Games" mode is designed to avoid having input devices leave the virtual machine space by accident, by default, if you press "Ctrl+Option" and approach the top bar with a mouse cursor(it is not necessary to hold the combination, just press it once and move the mouse cursor) macOS menu bar should appear in "Optimized for Games".

    Let us know the results.

    Have a great day!
     
    GaborR likes this.
  4. GaborR

    GaborR Bit poster

    Messages:
    2
     
  5. Michael105

    Michael105 Bit poster

    Messages:
    3
    Maxim, thanks!

    Changing the preference is a workaround, not a solution. Doing so allows Parallels to behave correctly, but then you're forced to auto-hide the menu when other apps are run in full-screen mode.

    Can we expect a fix in a Parallels update to respect the "Automatically hide and show the menu bar" preference while in "Optimize full screen for games" mode, even when it is set to "Never"?
     

Share This Page