Fusion Drive?

Discussion in 'Windows Guest OS Discussion' started by MarcelV4, Oct 18, 2018.

  1. MarcelV4

    MarcelV4 Bit Poster

    Messages:
    2
    So is Parallels 14 totally unusable with a newer Fusion Drive or what gives?

    Ran an older 2013 iMac with Fusion Drive for 5 years without any issues. I quit updating Parallels at version 11 and on that particular iMac in comibation with El Capitan that has always worked flawlessly.

    Now recently I decided to get a brand new iMac (again with a Fusion Drive) 16GB Ram, i5, etc. Whilst at that point unaware the modern day 1TB Fusion Drive is a piece of junk compared to the old one I wasn't expecting this kind of poor performance from Parallels. Because the machine shipped with High Sierra I was forced to buy Parallels again so I figured why not go with 14 instead of 13 and pay full price. That way when I update this iMac to Mojave there won't be any issues with Parallels.

    I copied over the VM from the old machine and set in awe as initially nothing worked, blank screens that took minutes to refresh, Parallels Tools trying to update itself but staying at 3% for over an hour. Once I decided I had enough and force quit the VM, I rebooted it and managed to (after clicking 4 times and waiting about an hour) uninstall and reinstall Parallels Tools. Rebooted, but to the same issue. VM performance is absolutely abysmal. Updated to Mojave, again to no avail.

    Now the disk usage indicator is permanently flashing on the VM and in Taskmanager it's showing near 100% usage even when the total amount of use does not really exceed 3 or 4 MB/s. That's strange I figured, even for a poor 5400RPM hard drive that's odd behavior. So I went and checked disk performance on both OSX as well as Windows and oh my.. Whilst the Fusion Drive (at least the HDD portion) is not fast (100-ish MB/s read and write seq. plus 20-ish MB/s on the 4kQD32) the performance in Windows is extremely poor at best. 40-ish MB/s read and write seq. is acceptable but the 0.7 MB/s 4kQD32 just isn't.

    I've tested this numerous times, including rebooting the VM, rebooting the host, etc. but the performance remains the same. Why is Parallels having such difficulty to make regular HDD's work in v14?

    Heck for the hell of it I copied the VM over to a network drive (RAID 10 array non-SSD) and it's miles faster.

    Why?..
     
  2. MarcelV4

    MarcelV4 Bit Poster

    Messages:
    2
    Just to add, I have tried splitting the virtual HDD to perhaps have the 32GB SSD pick up some parts of it but that doesn't seem to have helped much.
     
  3. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @MarcelV4 , please follow the steps suggested in the article and check if that works.
     

Share This Page