Garmin GPS USB Support

Discussion in 'Feature Suggestions' started by xray, May 2, 2006.

  1. mikeconte


    garmin extrex vista cx does not work with parallels

    actually, that understates it... i have not been able to upload maps to the device - it gets almost to the end then blue-screens and reboots the windows VM. I thought updating the firmware from 2.6 to 2.7 would help...bad idea. Crashed and rendered my CX completely useless and had to ship it back to Garmin.

    I then successfully updated a second CX using the mac updater but still can't upload maps to it. I am on build 4128, the latest, of parallels.

    Extremely frustrating to have spend $600 or so on GPS and I can't use it.
  2. mikeconte


    garmin extrex vista cx does not work with parallels - update

    I RMA'd my Garmin eTrex Vista CX. The new one has the 2.70 firmware in it. In the meantime, I also upgraded to build 4560 of Parallels Desktop 3.0. So i have the latest code for both.

    I tried again to upload maps to the garmin...and it worked! Woo hoo!

    I am going to try again with a larger map set.
  3. Ronayres


    Parallels just won't work with my Garmin 276C

    I tried everything to get Parallels to work with my Garmin 276C but finally decided it just isn't going to work. I dumped Parallels and went to Boot Camp (free from Apple) and everything works fine. It's easier to switch back and forth between OS and Windows with Parallels, but since the only reason I bought Paarallels was to use my Garmin GPS software, I can live with that. Too bad Parallels can't figure out how to recognize the Garmin 276C.

  4. Nodawurri


    Can anyone PLEASE help me ... PLEASE ... PLEASE ...
    I have a MacBook Pro 2.16Ghz and have been trying to load my Garmin GPS software "Mapsource Trip and Waypoint Manager" (PC software) onto it using this latest Parallels Desktop 3.0 for Mac.
    Part way through the Installshield Wizard, I receive a message that:
    "Setup has detected an Existing MapSource installation.
    All Mapsource products share the same application environment. Your existing MapSource installation will be modified to incorporate this product.
    You may switch between products by selecting them from the Product Selection Box on the MapSource toolbar."
    Then, as the Wizard prepares to install, I receive the following error message:
    "Same version of detailed maps already installed.
    Setup will now exit."
    When I click on the Mapsource icon on the Parallels desktop, I get an error message:
    "There is a problem with the MapSource registry.
    Please re-install MapSource and start it again."
    I have tried removing all Garmin and MapSource software using the Add or Remove Programs to 'clear' the Parallels environment of any "already installed" MapSource bits and pieces, but still I get the same messages eveytime I try and re-instal the software from the CD.
    Last week, I successfully got this same MapSource software to run on my friends G4 Mac using "Virtual PC" (up till then, I had only ever used it on my PC) - but there seems to be a glitch with Parallels and Garmin's MapSource ... ?
    I noticed that users on this forum have successfully loaded Trip & Waypoint Manager, so hopefully someone can help me (the Parallels Support Team told me to get the answer from the forum ... ?!)
    Can anyone PLEASE suggest what I could try so that I can run this software ?

Share This Page