Google Chrome performance in Parallels 8

Discussion in 'Windows Guest OS Discussion' started by Leif ArneB, Sep 5, 2012.

  1. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    633
    Hi everyone,

    All the problem reports you posted here have been passed to the development team for further analysis. I will share the results soon.

    Special thanks to @Contradel for finding the workaround (post #75). Does it solve the issues for everyone? Or it only works for some of you?
     
  2. WickIndy

    WickIndy

    Messages:
    4
    That workaround seemed to help quite a bit, but there have been a few instances where I click a link that opens a new tab in Chrome, and the link never loads or times out.
     
  3. micdenny

    micdenny

    Messages:
    1
    The workaround post #75 has worked also for me, now it is better than before, avoiding that some tabs stuck in a blank page, for the moment it seems to work really well.
     
  4. Baldy_

    Baldy_

    Messages:
    6
    Workaround in post #75 has worked for me, pleased to be using chrome again.
     
  5. DarrenN

    DarrenN

    Messages:
    1
    Is there any update on this? I'm still having the same problem with my Macbook Pro Retina and I'm almost ready to switch over to VMWare.

     
  6. Baldy_

    Baldy_

    Messages:
    6
    Check the workaround in post 75 - i havent had the problem since i configured the fix weeks ago on my mbp retina.
     
  7. SamSelikoff

    SamSelikoff

    Messages:
    1
    Using Parallels 9 with the latest high-end MacBook Pro Retina and I'm experiencing the same problem.

    The fix in #75 helped tremendously - thanks!
     
  8. JoelRubio

    JoelRubio Bit Poster

    Messages:
    53
    This "fix" is not present in my Chrome on both my Win 8 and 7 guests. I am running P9, and have ALL THE VERY LATEST UPDATES to P9, Win 8, Win 7, Mavericks, Chrome. Have also gone to 1GB memory settings.

    And yes. Chrome still "blacks out" in Win 8 and Win 7. Mostly Win 8 is stable, but Win 7 not at all. Totally annoying stuff w/ Parallels on this one issue.
     
  9. JoelRubio

    JoelRubio Bit Poster

    Messages:
    53
    Finally got this working by doing the following to my Win 7 VM -- upgraded memory from 3GB to 4GB, then from 1 CPU to 2 CPU's. Left video setting at 512MB. Hope this helps those who still have this issue.
     
  10. chris.com

    chris.com

    Messages:
    1
    I just get a completely white browser screen in Chrome. I can copy and paste text out of it, but nothing in the browser window is visible. So, when I go to chrome://flags/, I can't even see what's there in order to make the necessary modifications. Very frustrating.
     
  11. L-Dog

    L-Dog Bit Poster

    Messages:
    20
    Would you (or anyone) give an updated fix? It looks like Google has changed the verbiage of the option listed as the fix on post 75. I'm not sure what the new option is called now.

    Parallels is unusable to me without Chrome, and I'll be forced to return the product if I cant get Chrome working. This is really frustrating. Thanks.
     
  12. Danny_Scheelings

    Danny_Scheelings Bit Poster

    Messages:
    9
    I have the latest 21" iMac with i7 CPU; Fusion drive; Yosemite 10.10.1; latest Parallels Desktop; Windows 8.1 installed.
    I have the same problem! The option "GPU-composition on all (web)pages" is not present in my Chrome.

    Is Parallels working on this?
     
  13. pechar

    pechar Bit Poster

    Messages:
    18
    Of course not @Danny_Scheelings. I even contacted support and got a reply with the usual delete, this remove that, re-install this, re-install that. I had fixed it on my own and none of what they stated helped. The only way I got it to work was removing Chrome and very important delete the AppData folder traces of Chrome. Re-installing Chrome alone did not help but removing all it's traces did. It is possible you might need to re-install Parallel tools after removing Chrome completely and once more after installation of the clean Chrome. However I cannot confirm the last part...
     
  14. Nicholas_Head

    Nicholas_Head Bit Poster

    Messages:
    4
    Just a heads up, under Chrome's "Advanced Settings" (Settings -> Scroll to Bottom -> Show Advanced Settings), there's a checkbox for "Use hardware acceleration when available". Uncheck this, and click the "restart" link it shows. I had to do this for VMWare, also. It seems the way Chrome is accelerating doesn't jive with VM software.
     
  15. JonathanF5

    JonathanF5

    Messages:
    1
    Hi, yesterday I upgrade Chrome. And now I have this black screen. I have Mac OS Mojave 10.14.4 with Parallels 14.1.2 (45479). I run an Ubuntu 18.04 VM. And Chrome version is 69.0.3497.92
    I reinstalled Chrome and I removed the config in ~/.config/google-chrome. But the problem is still there.
    What should I do? Please advise.
     
  16. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,846
    Hi, could you please generate the problem report after the issue reproduced and reply us back with the report id?
     

Share This Page