Guest Install of Ubuntu 20.04-x64 Desktop Hangs - Parallels 15.1.4, MacOS 10.12.6

Discussion in 'Linux Guest OS Discussion' started by Christopher Nielsen, May 20, 2020.

  1. Christopher Nielsen

    Christopher Nielsen Bit Poster

    Messages:
    19
    Folks,
    I'm trying to create a fresh install of Ubuntu 20.04, but after the initial installation screen, the VM simply hangs with a black screen.
    I searched the forum, and this seems to be the only related thread. Unfortunately it's a fundamentally different issue:
    Behavior-wise, I'm seeing the VM max out on CPU time (200%, corresponding to two vCPUs), and the Parallels VM log file (parallels.log) rapidly fills with the following messages at 50-ish megabytes per second:
    05-20 16:52:18.347 W /monitor/ [Decoder] #UD reason 13, exec_addr=0x1346b, cAddr=1, cOp=1
    05-20 16:52:18.347 F /monitor/ ++++++++++++++++++++ Dump Memory Begin 1-1346b ++++++++++++++++++
    05-20 16:52:18.347 F /monitor/ uLinAddrBeg=0x1346b, uLinAddrEnd=0x1347b byte_count=0x00000010
    05-20 16:52:18.347 F /monitor/ 1346b: f3 0f 1e fb 66 57 66 56 66 83 ec 58 66 b8 61 4b
    05-20 16:52:18.347 F /monitor/ ++++++++++++++++++++ Dump Memory End 1-1346b ++++++++++++++++++++​
    Host Info:
    • Parallels 15.1.4 Home Edition (47270), latest available release.
    • MacPro 2008, Dual Quad-Core 2.8Ghz, 32gb RAM, four SATA HDDs in a RAID-10 configuration.
    • Graphics: ATI Radeon 5770 1gb (official Apple card)
    • MacOS 10.12.6, with all of the latest updates. No antivirus or antispyware software installed.
    Guest Config Info:
    • 2 vCPUs, 4gb RAM
    • 1 virtual disk, 64gb
    • All Mac sharing features, coherence, etc, all disabled. The only two exceptions: Time syncing from Mac is enabled, along with Mac clipboard sharing.
    • Automatic sharing of USB devices, etc, disabled.
    Other Relevant Info:
    • I've created, and routinely use, a variety of other VMs within Parallels 15. All work perfectly: Windows XP (both x32 and x64), Windows 7 x64, Windows 10 x64, Ubuntu Desktop 16.04 x64, Ubuntu Desktop 18.04 (both x32 and x64), MacOS 10.9.5.
    • In short, I've been running Parallels 15 extensively for a few months now, and it has been absolutely rock-solid with everything I've thrown at it. (And the performance has also been outstanding.) This is the first time I've ever had any issue installing a guest, or running a VM. So hopefully that rules out any issues with my setup.
    The VM log file is attached, albeit with 99% of the repeated memory dump statements removed for brevity. Let me know if you folks need any additional info.
    Thanks so much for your help,
    -Chris
    Parallels user since Parallels 3
     
  2. Christopher Nielsen

    Christopher Nielsen Bit Poster

    Messages:
    19
    VM log file attached, albeit with 99% of the memory dump statements removed for brevity.
     

    Attached Files:

  3. Christopher Nielsen

    Christopher Nielsen Bit Poster

    Messages:
    19
    Another VM log file attached, this time with option "Use detailed log messages" enabled. Again, 99% of memory dump statements removed.
     

    Attached Files:

  4. Christopher Nielsen

    Christopher Nielsen Bit Poster

    Messages:
    19
    As a point of reference, I also tried this on Parallels 9 and MacOS 10.8.6, with the same result. The only difference is that Parallels 9 outputs just one memory dump statement.
    Parallels staff, can you verify whether Ubuntu 20.04 Desktop is an officially-supported guest OS at this point?
     
  5. Christopher Nielsen

    Christopher Nielsen Bit Poster

    Messages:
    19
    Anyone... Anyone...
    Bueller... Bueller...
     
  6. GowthamR@Parallels

    GowthamR@Parallels Bit Poster

    Messages:
    83
    @Cajun Man hi, Ubuntu 20.04 is not supported with Parallels Desktop 15 for Mac. Please find the list of supported operating systems of Parallels Desktop 15 for Mac by referring this KB article https://kb.parallels.com/124223
     
    Christopher Nielsen likes this.
  7. StephenC9

    StephenC9 Bit Poster

    Messages:
    11
    Strange, I installed 20.04 on my Parallels 15 for Mac - no installation issues whatsoever.
    I'll admit I'm not a power user and mainly use Linux to support a couple of friends who have to use it and have occasional queries I need a copy to answer. I've still got 18-04 as an isolated VM if I need to visit a site flagged as suspicious by Safari (usually just an expired certificate - but if I need to visit it I'd rather put an extra barrier to potential problems)...
     
  8. You can try installing any OS version using Parallels Desktop for Mac and most of the OS will work. However, Parallels Tools will not be available for the guest OS which are not supported.
     
  9. MichaelA38

    MichaelA38 Bit Poster

    Messages:
    1
    Just seen this thread and realise it's probably a bit late and of no practical use to anyone, but I can personally confirm that with Parallels 15.1.4 running on Mojave 4k iMac, I've had no issues with Ubuntu 20.04 or with any of it's updates and in fact, is running very slick and fast and as writing this, is using 2% processor. In fact, I've just made a mistake of clicking About to see my version of Parallels, I accidentally clicked Exit Parallels. It shut down, but on running again, resumed from where I'd left off. So, it seems very stable on mine.
     
  10. Christopher Nielsen

    Christopher Nielsen Bit Poster

    Messages:
    19
    Everyone, thank you for your replies!
    As an update: After upgrading to Parallels 16, Ubuntu 20.04 installs and works beautifully. Hooray!
     
  11. rjgebis

    rjgebis Kilo Poster

    Messages:
    186
    I am running Ubuntu Mate 20.04. After upgrading from Parallels 14 to 16 under heavy use my entire machine is locking and shutting down. I called support three time and they took information. I been assured someone will call me back from higher support, and guess what .. No one did. Still having problem and support is as useless as I can only describe.
    Does anyone have issue locking entire machine under heavy VM use?
     
  12. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,494
    Hey, we've replied you in other thread, please check and reply us back with the tech report.
    Looking forward to your reply.
     

Share This Page