HASP driver on M1 Max Macbook w/Parallels Windows 11

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by ARGAS, Dec 1, 2021.

  1. LemonX

    LemonX Bit poster

    My experience after installation the drivers 9 for OSX, then is HASP key visible in OSX but after installation the driwers 9 for win to the windows 11 / on parallels desktop is not visible. My question is, is possible share the working HASP from OSX to the windows 11 on Parralles? Hase some on experience with this?


  2. JosephS14

    JosephS14 Bit poster

    There is no Windows ARM driver for the HASP key. There is a macOS one. There's currently no good way to make it work yet. The one suggestion here didn't work for me and I assume others that dont use that specific software he referenced.
  3. JJ_10

    JJ_10 Bit poster

    After few struggles, I made it to work on my machine. I'm using MacBook M2 Ventura 13.4.1. Sentinel License Dongle is working finally for me for a Java application that only works on Windows 11...

    This is how I did it.

    In your Mac with Apple Silicon chip:
    1. Install Sentinel HASP/LDK MacOS Runtime GUI installation from - link I used was:
    2. Install Rosetta 2 on your terminal, execute:
      softwareupdate --install-rosetta
    3. Restart your machine
    4. Start Parallels Desktop, wait for it to load
    5. Connect Sentinel USB, connect it to your Mac
    6. At this point, you should be able to see the device connected if you navigate to: http://localhost:1947/_int_/devices.html
    7. Open Systems Settings, search for Firewall, then add Parallels Desktop into the list to allow incoming connections
    8. Open Systems Settings -> General -> Sharing, and find your macbook host name (should be like User-Macbook-Pro.local)
      ... save this so you can use it later

    For Windows 11 steps:
    1. Disable firewall, OR allow incoming request from Mac (Not sure how to do this, so I just disabled the firewall)
    2. Start cmd as admin
    3. Enter below command:
      netsh interface portproxy add v4tov4 listenaddress=localhost listenport=1947 connectaddress=YourHostName.lan connectport=1947
      You need to get rid of .local part of the name, so if the above macbook step displayed User-Macbook-Pro.local, connectaddress should be User-Macbook-Pro.lan
    4. Check that it's added correctly:
      netsh interface portproxy show v4tov4

    Hopefully that should do it. It worked for me but hoping it will work for others too
    andreigherghe likes this.
  4. pasjac

    pasjac Bit poster

    Cela ne fonctionne pas pour moi, j'ai toujours le message de dongle inexistant.
    Peut-être dois je faire d'autres actions, pourtant la procédure a bien été suivie et exécuté.
    It doesn't work for me, I still have the non-existent dongle message.
    Maybe I have to do other actions, yet the procedure has been followed and executed.
    Best regards
  5. andreigherghe

    andreigherghe Bit poster

    I wasn't able to get it working, but will post my experience so far. Thanks everyone for looking into it!
    Software is LONATI Digraph3+ (created by DINEMA), used to program industrial knitting machines.
    M2 Max MacBook Pro, Ventura 13.4.1
    1. As a temporary solution, I got everything running in Windows 7 via UTM (emulation). Performance is roughly 30% compared to Windows running in Parallels on a i9 MacBook Pro, but only after forcing multi-core support in UTM settings and increasing it to 4 cores. My workload is mainly single-threaded, so depending on your use case you could bump it to maximum (with the drawback that macOS speed will decrease). UI is snappy enough to be usable.
    2. On the i9 MacBook Pro, in Windows, the dongle is NOT visible in http://localhost:1947/_int_/devices.html. Only the DEMOMA evaluation key is present. However, everything works fine, and the dongle red light is on. Perhaps not all dongle versions show up, even though they work?
    3. In my case Rosetta 2 was already installed, since I was already using some x86 apps.
    4. By default, macOS Ventura came with Firewall disabled.
    The software I'm using seems to have a two-stage check.
    • On the i9 Mac via Parallels (or M2 UTM), when the Sentinel Runtime is not installed, it throws the error "Install protection driver". When the driver is installed but the dongle is not connected, a different error shows up "Keys DIG3PLUS or DIG3+UPGRADE not found".
    Screenshot 2023-06-26 at 16.47.58.jpeg
    • On the M2 Mac, I get the error "Install protection driver", regardless of the HASP or Runtime status. I couldn't get past it.
    Screenshot 2023-06-26 at 16.48.11.jpeg
    Maybe there is a different method used by the software to check if the Runtime is installed, other than trying to communicate via port 1947?
    I tried installing the Runtime both on Windows and macOS, and then doing the portproxy. Nothing changed.

    Another thing is that I tried accessing http://localhost:1947/_int_/devices.html in Windows after doing the portproxy to andreis-macbook-pro.lan. It wasn't working, so I also tried andreis-macbook-pro.local.
    That way, instead of no reply at all, I got a "403 Forbidden" page. Not sure if it's supposed to be working or not, and whether .lan vs .local is supposed to change this.
    Screenshot 2023-06-26 at 16.48.33.jpeg

    One alternative I can think of is to try to use UTM exclusively for the Sentinel Runtime, with the USB HASP connected to it, and Parallels to just run the software.
    I also tried using the i9 Parallels Mac with a working setup as the host, but it didn't change anything in my case. It should work, theoretically.

    I will try to get in touch with Dinema (the creator of the software) to see if they have any suggestions. If I receive any good input I'll follow up, maybe it applies to other scenarios as well.
  6. JosephS14

    JosephS14 Bit poster

    Looks like this only works if you have a net hasp, not if you have the local USB one. Mine do not show up on the sentinel admin control centre, but do show as being plugged into my Mac. But I have a nethasp for something else that does show.
  7. gillesg3

    gillesg3 Bit poster

    I have tried the installation on my MacBook Pro M1 and the dongle is visible and I can launch my application (windev 28). Unfortunately after 10 min I have a crashed on the app (I suppose it's a timer test for the dongle). Is there somebody who a working solution (VincentB8 is not there anymore) ?
  8. AdibJ

    AdibJ Bit poster

    I also tried the steps on #63. The dongle is seen on both mac and win11. The usb dongle is lit. But device manager still shows the drvier for the HASP dev is not working. Software is not able to read the license from the dongle. I am running Win 11 on Parallels on M2 Macbook. Any other suggestions. Blocked with this software not working.
  9. ARGAS

    ARGAS Junior Member

    anyone succeeded with USB HASP drive on Windows 11 ARM via Parallels? It bugs me a lot that I need to carry two laptops on construction site...

  10. ArturL2

    ArturL2 Bit poster

    Until we've got ARM Driver from Sentinel, it's going like this. I've tried HASP net version, it worked by the method mentioned above, but after 10 launches it stops to work (trial version?).
  11. gabrieleb4

    gabrieleb4 Bit poster

    I have a macbook pro m1max. I use a structural calculation program that uses the sentinel key to activate the license. The trial version program works perfectly. if I use my license it freezes due to the flash drive not being read.
    It is read by the OS and Win Parallels system but does not communicate with the program. I've been trying to fix this for a year. It's frustrating to know that the program works perfectly on parallels but I can't use it with the license
  12. gillesg3

    gillesg3 Bit poster

    I make it work with Windev/webdev app following the information provide, but after 10 minutes the app (webbed) is crashing. I don't know if it came from PCSOFT or from Parallel. If somebody had made it works Please give us information....

Share This Page