Help! Can't activate Parallels 10.

Discussion in 'Installation and Configuration' started by JohnG37, Oct 22, 2020.

  1. JohnG37

    JohnG37 Bit Poster

    Messages:
    2
    Hey Guys,
    In desperate need here... :/ Thanks in advance.
    So i have an old MAC that on upgrading operating system to Sierra stopped running the desktop parallels 9 installed. Soooo
    I bought and installed Parallels 10 (the max version compatible with OSX Sierra)
    I logged in, registered the key on my account then cut and paste activation key; only to get a red cross and a message ; 'an invalid argument was passed' under the key. No activation and no access to my virtual machine (windows panel) eek!

    So far i have tried...
    1. deleting the licence.xml file then restarting Parallels.
    2. following help centre instructions to clear out 'host file' via 'terminal' app
    3. re installation and many restart combinations.
    ... still no activation.
    Frustratingly despite claims of 24/7 support via email or call centre on this site but i have NO IDEA how to access support beyond a keyword help search. Feel free to tell me how that goes pre activation?

    Big thanks for your attention to my problem here.
    John
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,969
    Hello,
    could you please provide us with your Parallels Desktop license key and purchase order number via the private message?
     
  3. JohnG37

    JohnG37 Bit Poster

    Messages:
    2
    I don't know how to PM here. There is no PM button. Ive 'followed' you but beyond that... nada.
    My email is jonhap@***mail.com.
     
  4. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    2,568
    The key you have can be only used with Parallels Desktop 11 or higher versions. As you have macOS Sierra, you can use Parallels Desktop 14.
     

Share This Page