Help with various issues (Wayland support, poor audio quality, stuck shortcut)

Discussion in 'Parallels Client for Linux' started by MatthewT11, May 10, 2022.

  1. MatthewT11

    MatthewT11 Bit poster

    Hello, I'm using the parallels client on archlinux, kernel 5.17, kde plasma and have the following issues:

    1. Wayland doesn't work so I need to logout / switch to x11 session, is there any workaround?
    2. Very poor audio quality, wondering if this is only an issue on pipewire and if so if there anything I can configure to make it better. The audio quality on windows is also bad but an imporovement (i have a gigabit connection and good pc specs so I don't think its hardware related)
    3. Shortcut meta + alt + m get's *stuck* randomly. For example, just pressing 'm' will force the session to minimize. I'll often have to mash the shortcut keys or close the session and re-connect to fix it.

    Any suggestions are greatly appreciated!
  2. jpc

    jpc Pro

    What is the version of the parallels client that is being used?
    1. As far as I know, Parallels client does not yet support running on Wayland. However you could try to force it to use xcb plugin by setting QT_QPA_PLATFORM=xcb when running the client.
    2. Performance of audio redirection on RDP depends on the application that is being used on the server. Some win32 apis work poorly over RDP. What application are you using? However I'm afraid that if audio quality when using Windows client is poor too, I don't think there is a lot that can be done.
    3. The alt key getting stuck issue should have been fixed in v18.2 (Change logs: Client for Linux Changelog.txt)

Share This Page