Hide windows icons on my MAC desktop

Discussion in 'General Questions' started by jfavero, Nov 4, 2009.

  1. jfavero

    jfavero Junior Member

    I hate, hate, hate having my windows icons on my Mac desktop... is there a way to hide them? I use them frequently on my VM because of how Windows is structured and the work I do on that side of my machine, however, I never, ever use them on my Mac side.

  2. Andrew @ Parallels

    Andrew @ Parallels Parallels Team


    Just go to menu Virtual Machine->Configure, Options->Shared Profile and uncheck Desktop checkbox.
  3. DebbieS1

    DebbieS1 Bit poster

    I have the same problem. I have followed your instructions but the icons from the windows desktop still show up on my mac desktop. Any other advice? I am using parallels 10
  4. RyanL1

    RyanL1 Bit poster

    This is a very big annoyance. Can we please get some confirmation from Parallels that this is either a bug or in development. I'm considering switching Virtualization software because of how bad this is.
  5. JamesB1

    JamesB1 Bit poster

    I agree..a HUGE annoyance. I thought this was supposed to be a completely transparent program, and the settings mentioned in this thread are over 5 years old. Where are they found in Parallels 10?
  6. Manoj@Parallels

    Manoj@Parallels Parallels Support Parallels Support

    Hi all,
    Please follow the steps below to enable Shared Folders Tool :
    1. Open virtual machine window (Do not click Start).
    2. Open virtual machine configuration http://kb.parallels.com/117287 > switch to Options tab > Sharing.
    3. Set Share Folders to the desired value.
    4. Choose the Custom Folders (Desktop,Documents etc..) if you need.
  7. DickV1

    DickV1 Bit poster

    Sorry, Manoj, that does not tell me how to get the icons off my desktop. I find I can add the icon for each software package running in Parallels to Launchpad and/or to the bar at the bottom of the screen. But the original icon remains on the desktop. If I trash that desktop icon I trash the software package. I want to have the icon in the bar at the bottom of the screen and/or in Launchpad. I do not want the icon on the desktop.

    If, as in your instructions above, changing a setting in Share Folders will remove the icons from the desktop then please tell me which share folders setting will do so.
  8. DickV1

    DickV1 Bit poster

    Ok, a little more hunting around and I have my own solution.
    If you simply drag the icon from desktop to Launchpad it will stay on both the Launchpad and desktop.
    If you simply drag the icon from desktop to the bar at the bottom of the screen it will stay in both places.
    If you want the icon off the desktop then make the moves using Finder. From Desktop in Finder move the ***.app to the Applications folder.
    This is working well so far.
  9. AlessandroV

    AlessandroV Bit poster

    Its Easy...
    Go to Virtual Machine->Configure->Options->Sharing->Share Windows and uncheck "Shortcuts to virtual disks on Mac desktop".
  10. Guna@Parallels

    Guna@Parallels Parallels Support

    Hi @AlessandroV
    Thanks for sharing the information.
  11. marcoparvis

    marcoparvis Bit poster

    Windows 7 an parallels show on the desktop links form various locations i.e. \\psf\Home\Desktop, C:\Users\Public\Desktop,...
    Most of them are mirrored in the mac environment but not those in C:\Users\Public\Desktop so the solution is simply moving the link there.

    A procedure that should work in most cases is:

    1) In windows point to the link which appear also on the mac and right click properties/general. The link should be in \\psf\Home\Desktop
    2) Move to shortcut tab and look the file it points to
    3) Go to that file and create a shortcut to it (point to the file, right click create shortcut)
    4) Go on bottom left icon/ show all programs / Accessories / Point to Command Prompt and select Run as administrator
    5) By using the command line provided by the command prompt, Move the freshly created shortcut to C:\Users\Public\Desktop\ (i.e. move xxxxx.lnk C:\Users\Public\Desktop\xxxx.lnk)

    6) Et voila': the link should immediately appear on your windows desktop (but not on the mac)
    7) Now you can safely delete the old link on your mac desktop
    Hope this can help
  12. Jack.Jack

    Jack.Jack Bit poster

    None of the suggestions here seem to work for Parallels 13. I wish software companies would STOP CHANGING THINGS THAT WORK!!!
  13. BrianT2

    BrianT2 Bit poster

    If you Go to Virtual Machine->Configure->Options->Sharing->Share Mac -> Configure and uncheck "Desktop" this will remove the Mapping of the Mac desktop to Windows
  14. JustinR4

    JustinR4 Bit poster

    Just tried this for Parallels 13. It doesn't work & causes a restart fail loop on starting Windows & doesn't remove the shortcuts on the Mac desktop. Please review this & rectify. I've been a user of Parallels since version 7 so please resolve ASAP. Thanks
    ThanZ likes this.
  15. VladoD

    VladoD Bit poster

    The Parallel's Windows icons are a real pest. I uninstalled my Parallels 13, as I bought a Lenovo Windows PC, so didn't require Parallels any more.
    The Windows icons that Parallels have inserted in the Mac's Launchpad seems to be impossible to get rid of.
    I read all forums and made a lot of searches, but none of them resolves my problem, where I have uninstalled the Parallels.
    Why wouldn't Parallels remove these icons during uninstall?
    I have been a Parallels user since day one, paid for many many upgrades, and used it well, but I don't want any residuals of Windows on my Mac.
    Please help.
  16. AJ@Parallels


    Hello VladoD, Kindly right click on the Windows icon in the dock--> Options--> Remove from Dock.
  17. AbrahamO

    AbrahamO Bit poster

    Would be nice with an Update of this thread. Parallels 13 does not have options mentioned here, or they don't have the wanted effekt.
    I've just installed 13 on my mac and added a windows 10 - now my mac screen is covered with icons from windows desktop, that I cannot find a way to remove.

    @parallels support, please fill in the blanks, referring to v.13:
    "Just go to menu... ____"
  18. Hi AbrahamO. Shut down the virtual machine by select Actions (from Mac menu bar) -> Shit down and open the configuration window, select Options -> Sharing -> Share Mac -> Configure and uncheck 'Desktop' which will separate the Mac and Windows Desktop icons.
  19. ClaytonH

    ClaytonH Bit poster

    can we get an update on this? i have tried all of the above and nothing works. I want to hide these .lnk icons and cant.
  20. DebasmitaM

    DebasmitaM Forum Maven

    Hello, please refer to this KB article for hiding Windows application Icons from Mac side.

Share This Page