High cpu usage due to bsdtar process

Discussion in 'General Questions' started by CarlB7, Oct 9, 2019.

  1. ArifJ

    ArifJ Bit Poster

    Messages:
    1
    Parallels: Version 15.1.4 (47270)
    Parallels toolbox: Version 2.6.1 (1620)
    MacOS Catalina : version 10.15.5 (19F101)

    So what is the latest software version that solve this issue?
    Im using much later version but the issue still not fix.

    Start to loosing my faith with Parallels
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,470
    Hello, the latest Parallels Toolbox version is 3.9.
    (please let us know if it's not that case)
     
  3. RobertS64

    RobertS64 Bit Poster

    Messages:
    8
    Hello,

    Parallels team: Are you ever going to fix this long term issue?? I have had this issue since I installed Parallels and Do Not Sleep. Of course I have the latest version of both.
    I am on Catatalina and the issue comes and goes every other day. It is a nightmare. Whenever the fan starts I have to keep an eye on the Activity Monitor and always there is a couple of more instances of this Bsdtar taking 100%+ of CPU usage! I am starting to consider other options. This is very bothersome.
     
  4. BrianP13

    BrianP13

    Messages:
    1
    Pretty shady in my opinion to install software that needs a license but didn't used to need it. I don't use Toolbox, so I will simply not load it any longer. However, it should not be included in the Parallels Desktop install and should be an option for install. Not happy with how I had to discover "Bdstar" processes were killing my productivity and pegging my CPU at 100%. I wonder how many less technical users are sitting at their MACs wondering why their machine is so slow and the fan won't stop running. Parallels should do the right thing and put out a service bulletin to all users letting them know this is an issue.
     
  5. RikS

    RikS Bit Poster

    Messages:
    4
    OK, so five months have passed, and I decided to try to re-install Toolbox, and see if any interim updates may have solved the problem, but now I get "Your license key is invalid for this version of Parallels Toolbox. Please downgrade or buy a new license."
     
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,470
    Hi, could you please share with us a screenshot if the issue? Looks like you're trying to activate new Parallels Toolbox version with the old key.
     
  7. BillD6

    BillD6 Bit Poster

    Messages:
    2
    Maria, I've also fought this issue for months. I've tried LaunchAgents to detect the bsdtar process on an hourly basis yet I still return to a laptop with the fans spinning at their highest speed. I can see this process is archiving data and then passing it to the network tool curl. It's a process that is posting data, and I do not see any preferences option in Toolbox to disable this.

    This thread is now at 8 pages, with no apparently concern on the part of the Parallels team. If you're going to continually charge for the annual updates, then you should be addressing this issue. Please stop asking for reports and screen shots. This is code that is absolutely included in the Parallels Toolbox software. It is sending data back to your servers. It is obviously included by design, but the archiving and posting of this data is causing unintended consequences in the form of maximizing all CPU usage. There is no reason your team cannot find and disable this in a release and then update this thread.

    I'd expect this with freeware ... not with an Apple product which continually prompts for $$$ for upgrades.
     
    Henkd3 likes this.
  8. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,470
    Hello,
    thank you for your feedback.
    Could you please share with us your Parallels Toolbox version?
     
  9. BillD6

    BillD6 Bit Poster

    Messages:
    2

    Actually, I can't. I've remove it to keep my Mac from overheating. I believe it was 2.6.xx or 2.7.xx.

    Can you describe what this tar report | curl ... command is supposed to be doing. I do not see how posting data with curl is in any way a feature of the toolbox. This sounds like your s/w team collecting information that somehow broke. BTW, I selected to NOT send data for diagnostic purposes. This feels like data is still being collected nonetheless.

    I know I'm ranting here. I'm not even looking for a fix since I've remove the software. I'm just very disappointed that purchased software is:
    1.) Not being fixed (This thread is almost a year old with no real explanation or fix.)
    2.) Underhandedly collecting data
     
  10. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    2,652
    This issue is resolved in the latest Parallels Toolbox built and it is occurring with older Parallels Toolbox with incompatible macOS X.
     
  11. RikS

    RikS Bit Poster

    Messages:
    4
    The only key I have is the one that came with my version 15 Screen Shot 2020-08-02 at 11.37.43 AM.png Screen Shot 2020-08-02 at 11.38.01 AM.png
     
  12. RikS

    RikS Bit Poster

    Messages:
    4
    Please delete previous image with my fulll key.
     

    Attached Files:

  13. Henkd3

    Henkd3 Bit Poster

    Messages:
    1
    Following (and suffering) this issue for months now. Yes, there was even an update from Parallels that didn't address this issue. In the end, I just wrote a cron script that checks every 5 minutes if the bsdtars are running, and then kills them, and got on with my life.

    Here's the cron script. I named it 'killbsdtar':
    -----------------
    #!/bin/bash
    # crontab -e
    # then add the line (press i, then paste):
    # 00,05,10,15,20,25,30,35,40,45,50,55 * * * * /Users/<your username>/bin/killbsdtar
    # and save the file (type :wq)
    log=~/bin/killbsdtar.log
    #echo "$(date) $0 started" >> $log
    n=$(ps -ef | grep "tar -czf /Users.*toolbox_report" | wc -l)
    if (( $n > 3 )) ; then
    killall -9 tar
    echo "$(date) killed $n running instances of bsdtar" >> $log
    fi
    #EOF
    ------------------
    You can install it with the command on the second line (without the # of course). You (as user) must be the same user that uses Parallels Desktop, and/or you must have sudo permissions to let the killall work.
    For alternative intervals for running, take a look at https://crontab.guru/examples.html

    For you guys at Parallels reading this thread, here's my log file to date:
    Fri Jul 10 18:45:00 CEST 2020 killed 15 running instances of bsdtar
    Tue Jul 14 09:25:02 CEST 2020 killed 16 running instances of bsdtar
    Tue Jul 21 09:25:01 CEST 2020 killed 16 running instances of bsdtar
    Tue Jul 28 08:05:01 CEST 2020 killed 17 running instances of bsdtar
    Tue Aug 4 08:05:00 CEST 2020 killed 18 running instances of bsdtar
    which proves:
    * it is a longstanding issue (it started with 5 or 6 bsdtars, a long time ago, now there're 18)
    * it is a serious issue (having 18 processes running all claiming 100% cpu is no joke)
    * it gets worse over time (15, 16, 17, 18, ...)
    * it happens about every week and often after a reboot

    FIX THIS, please. There's enough hints in this thread as to the cause.
     
    RobertS64 likes this.
  14. RobertS64

    RobertS64 Bit Poster

    Messages:
    8
    It's getting worse... It's showing up almost every day now!!. Please fix it!
     
  15. PeterJ18

    PeterJ18 Bit Poster

    Messages:
    71
    It gives off an impression of being Parallels Toolbox v2.6.1 which came packaged with Parallels Desktop v13. I'm utilizing Parallels Desktop v15 now yet it didn't accompany the tool compartment so as yet utilizing this old rendition.

    The CPU spike didn't appear to end in a sensible measure of time for me. I wound up expelling Parallels Toolbox from my startup/login things:

    Framework Preferences > Users and Groups > left sheet, click your login > Login Items tab > feature "matches tool compartment" and snap "- " to expel it from the startup.
     
  16. RobertS64

    RobertS64 Bit Poster

    Messages:
    8
    I updated to latest version 16 2 days ago and today when launching Parallels the same nightmare!! 11 instances of Bsdtar eating all my CPU!! I use Do Not Sleep which I think it is the culprit!. When are you going to fix this??
     
  17. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,470
    Hi, did you get the bsdtar process issue after Parallels Desktop start?
    What is your Parallels Toolbox version?
     
  18. RobertS64

    RobertS64 Bit Poster

    Messages:
    8
    Please stop asking questions pretending this issue is isolated to just a few unfortunate users!!. Come on this is very easy to replicate!. Yes this happens after launching Parallels but sometimes when it is running after some while! I have the latest version installed in both parallels and toolbox!
     
  19. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,470
    This issue has been fixed at the Parallels Toolbox newest version.
    That is why we asked questions about the new appeared issues. Please share with us your Parallels Toolbox version.
     
  20. RobertS64

    RobertS64 Bit Poster

    Messages:
    8
    I have Do Not Sleep version 1.6.0 (920) and it says it's up to date. However yesterday the issue hit me again with 11 instances of the process!
     

Share This Page