High CPU usage on disk access since update to Mojave 10.14.4 ?

Discussion in 'Windows Guest OS Discussion' started by PatrickC11, Mar 27, 2019.

  1. PaulC27

    PaulC27 Bit Poster

    Messages:
    1
    Is there any prospect of this CPU cycle sink to be resolved? I'm up for renewal of Parallels in September, and to be frank, I just have no idea whether I'll stay with them or move to something else.

    I recently retired my 2015 MacBook Pro and bought an 8-core MacBook Pro with 2TB disk and 32 GB RAM to give me somebreathing room. Switching to the Apple hypervisor helps, but my MacBook still reports one core at 100% a lot of the time doing sweet FA in my VMs. Using the Parallels hypervisor my machines just crawl.

    Very disappointed with Parallels. Truly awful. Have been a customer for years, but this is tanking.
     
    ChristianW8 likes this.
  2. Ryan2000

    Ryan2000 Bit Poster

    Messages:
    2
    Seems like all their engineering is working Parallels 15, my guess is this will be fixed in the next major release?
     
  3. MichaelL49

    MichaelL49 Bit Poster

    Messages:
    2
    Yeah, what ever happened tanked the parallels hypervisor performance. Runs horribly bad, and thats before I turn on Visual Studio or docker. Since the Apple hypervisor doesn't support nested vms, that solution does not help me. Hoping they have a release that fixes these issues soon, it has traditionally been my favorite vm platform for my mac, but going to have to drop it and find another platform for now.
     
  4. ChristianW8

    ChristianW8 Bit Poster

    Messages:
    13
    Well, I just can confirm your issues. I bought a new Mac Mini now and installed all from scratch and still all the same. One CPU with 100% all the time (pro_disp_service) and plugging USB devices takes minutes until they appear and disappear. Shutdown can take 5 Minutes as well because of this.

    Please do not expect an update soon. Parallels is not working on this issue. I reported this bug 4 months ago and they do not contact me any more because it would be obvious that they are not working on it.

    Since they were bought by Corel the support stopped. I already canceled my subscription.
     
    Julian1 likes this.
  5. GaryB16

    GaryB16 Bit Poster

    Messages:
    1
    Best Answer
    I noticed that with Parallels Desktop 14 for Mac Pro Edition and macOS 10.14.5 my CPU usage was abnormally high intermittently. Overall performance was sluggish and unresponsive to input for several seconds at a time. Delays in opening the Start menu, programs, and even choppy/stuttering video playback.

    I tried changing the Hypervisor in VM Configuration > Hardware > CPU & Memory > Advanced Settings from "Parallels" to "Apple" but this had a negligible impact to the overall performance.

    I noticed that my MacBook Pro's discrete graphics were not enabled when checking "About this Mac". I forced the discrete graphics to enable by opening up the Photos application within macOS. I notice an immediate improvement in performance within the VM.

    I disabled "automatic graphics switiching" VM Configuration > Hardware > Graphics > Advanced Settings. Now when I start up the Windows 10 VM my discrete graphics are enabled automatically and performance is improved.

    There is still a noticeable decrease in overall performance for my Windows 10 VM with Parallels Desktop 14 vs the previous Parallels Desktop 13 version.

    Hope this helps others.
     
    ZacharyB1 and Maria@Parallels like this.
  6. ZacharyB1

    ZacharyB1 Bit Poster

    Messages:
    4
    Thank you! Can't believe I didn't try this. This brings back UI smoothness to my machine, whether I'm on Parallels or Apple hypevisor. I'm still using more CPU than I should be, but this way the discreet graphics are able to keep the UI going instead of the CPU being bogged down with them too. Hopefully the actual underlying problem will be fixed at some point, but this makes my MacBook Pro much more usable.
     
  7. PhilS6

    PhilS6 Bit Poster

    Messages:
    3
    Same here - Windows 10 VM virtually ground to a halt after updating today to 10.14.6. Switching to the Apple hypervisor has helped somewhat but things are still slower than before the OS update.

    Interestingly, I noticed in the VMWare forum that the same issue appears to have happened to VMWare! So it must be something that Apple changed under the hood in their latest OS.
     
  8. KendallB

    KendallB Bit Poster

    Messages:
    29
    Interesting, I was wondering if/when VMWare would get affected. I actually tried using VMWare myself (had to buy it again as my trial was over), but alas it's way worse than Parallels for performance in a lot of areas (especially graphics). Just doing a build from the command line takes 30-40% longer on VMWare so even with the slower performance using the Apple hypervisor, it's still better than VMWare. I just wish Parallels could figure this out so we could use their Hypervisor again as it was considerably better performance :(
     
  9. KendallB

    KendallB Bit Poster

    Messages:
    29
    Well, my Mac just updated itself to 10.14.6 today, and Parallels 15 came out so I installed that, upgraded the parallels tools and then rebooted with the Parallels Hypervisor active. So far so good! Performance seems decent, so crossing my fingers that either Parallels 15 fixed this, or 10.14.6 did.

    Curious if others are having a similar experience?
     
  10. KendallB

    KendallB Bit Poster

    Messages:
    29
    Bugger, spoke too soon. After using it for a while I ran into sluggishness, so ended up back on the Apple Hypervisor ...
     
  11. SopDa

    SopDa Bit Poster

    Messages:
    4
    Its working now with macOS Catalina Beta 5 and Parallels 15.
     
  12. jms.lwly

    jms.lwly Bit Poster

    Messages:
    5
    +1 (to the problem and the semi-fix...)

    I use my iMac Pro for rendering (often in Windows via Parallels due to software requirements), and had a similar issue when I updated to 10.14.4. The rendering software that I use has an 'interactive' mode, which allows you to make live changes in your 3D model and see it rendered in realtime - using 10.14.4 this became almost unusable as the OS became super laggy and slow.

    When this happened originally, I reverted to a Time Machine backup of 10.14.2 which worked fine - but decided to try updating again with Parallels 15. The issue returned, which lead me to this forum thread!

    Switched to Apple Hypervisor and it seems to have resolved the issue for now, albeit slightly slower than originally - but am hoping macOS Catalina will resolve it properly when it comes out (don't fancy running a beta on my business machine...)
     
  13. AdrianB2

    AdrianB2 Bit Poster

    Messages:
    7
    I've been struggling with this since upgrading to 10.14.6 from 10.14.3. According to https://planetvm.net/blog/?p=67185, Apple has acknowledged an IO bug that causes some pretty huge slowdowns in virtual memory for any VM using between 4-32gb of RAM. Most of the discussion of the bug has been in the context of VMWare Fusion, but I can confirm that if I drop my Win10 Parallels VM down to 3gb, it runs much better, albeit with a whole new set of problems thanks to the low memory ceiling.
     
  14. ZacharyB1

    ZacharyB1 Bit Poster

    Messages:
    4
  15. AdrianB2

    AdrianB2 Bit Poster

    Messages:
    7
    So far so good. I'm able to allocate 8GB again and it's not immediately grinding to a halt.
     
  16. jms.lwly

    jms.lwly Bit Poster

    Messages:
    5
    I've found the supplemental fix makes no difference (still on Apple hypervisor, Parallels one has the same slowdown as previous) - and still getting similar speed and occasional Windows app crashing. Hoping 10.15 resolves everything!
     
  17. AirPurfierR

    AirPurfierR Bit Poster

    Messages:
    1
    Yes, My PC are slow too.High CPU load
     
  18. AlekseyM2

    AlekseyM2 Bit Poster

    Messages:
    52
    I updated my Windows 10 yesterday to 1903 and it seems to work better. I do not see as high CPU usage anymore.
     
  19. joevt

    joevt Kilo Poster

    Messages:
    1,204
    Went from macOS 10.14.3 to 10.14.6, now my Windows 7 VM is unusably slow in Parallels 15. I don't have an Apple Hypervisor option in the config settings (running on MacPro3,1) so I guess I have to go back to 10.14.3.
     
  20. joevt

    joevt Kilo Poster

    Messages:
    1,204
    Problem has not improved with Catalina or Parallels 15. I have to switch to Mojave 10.14.3...
     

Share This Page