Hints for configuring a VPN connection?

Discussion in 'Windows Guest OS Discussion' started by flipdoubt, Jul 4, 2007.

  1. flipdoubt

    flipdoubt

    Messages:
    49
    I have a Bootcamped Vista VM on which I've installed the SonicWall VPN client. Each time I try the connection on Parallels, the log says the peer never responded, but I get no such errors when connecting via Bootcamp. Since the VPN creates its own virtual network device, are there any special steps I should take when trying to establish the connection via Parallels?
     
  2. swivet

    swivet

    Messages:
    20
    Are you using a bridged network configuration in your Parallels setup? If so, the VPN client may need to have transparent NAT/PAT tunneling enabled in order to get past the bridge.

    /swv
     
  3. flipdoubt

    flipdoubt

    Messages:
    49
    Nope, shared.
     
  4. flipdoubt

    flipdoubt

    Messages:
    49
    I still don't "grok" how networking works for my VM. How does Parallels get by with just one network adapter when my Windows should have at least 3? The wireless, the wired, and the virtual adapter for the VPN.

    If nothing else, can someone refer me to docs on configuring a VPN in a VM?
     
  5. flipdoubt

    flipdoubt

    Messages:
    49
    Can you point me to the documentation that specifically addresses VPNs on a guest Vista VM? I simply don't understand enough about how my VM gets by with one network adapter.
     
  6. Eru Ithildur

    Eru Ithildur

    Messages:
    1,960
    It gets by by creating multiple Virtual Adapters. You can see these inside of your System Preferences.

    Here is the chain:
    1. Your Apple Ethernet or Airport picks up a connection.
    2. Connection is passed to natd and routed to the Apple machine AND the Parallels machine via those new internal IPs you see in the System Preferences.
    3. Parallels Virtualizes the system to connect to one of those new IPs via a virtual adapter.

    Did I make sense? If not, tell me where I lost you and I'll try again.

    I am not sure if VPN will work through the Shared Networking, never tried it as I like to use Bridged. If you are using Bridged, just set up a VPN connection like you would with any other physical computer.
     
  7. flipdoubt

    flipdoubt

    Messages:
    49
    I changed to a Bridged connection and experimented by Enabling and Disabling NAT traversal on VPN connection, but I got the same result. The log looks like this:

    Information <local host> The connection "Office" has been enabled.
    2007/07/06 11:57:23:474 Information <Remote IP> Starting ISAKMP phase 1 negotiation.
    2007/07/06 11:57:41:665 Error <Remote IP> The peer is not responding to phase 1 ISAKMP requests.

    On Bootcamp, the status of the connection always goes from Disabled-Provisioning-Connecting-Connected. In Parallels, the status of the connection goes from Disabled-Connecting and just stays at Connecting. I wonder why it skips Provisioning.
     
  8. Eru Ithildur

    Eru Ithildur

    Messages:
    1,960
    Hmm... What kind of VPN are you running? Do you NEED that particular client, if not have you tried any other ones, at least for the troubleshooting process? Do you have access to the server logs? I wonder if it detects the spoofing going on...
     
  9. flipdoubt

    flipdoubt

    Messages:
    49
    Thanks for the replies, Eru. I'm using the SonicWall Global VPN Client to connect to a connect to a SonicWall VPN device, and I think that is my problem. It doesn't exactly support Vista with UAC turned on.

    Those times when it worked was right after I installed it, and I had UAC off to make installing less of a crap shoot. With UAC off, I can connect in Parallels.

    I'm not a VPN expert, but I don't know whether I can use another client.
     
  10. Eru Ithildur

    Eru Ithildur

    Messages:
    1,960
    Well, it sure sounds like UAC in Vista is your issue if turning that off allows you to use it... Probably want to check some Vista forums. Sorry, I stay far away from it after doing a couple tech calls.
     

Share This Page