Hints for Solaris Widescreen laptops

Discussion in 'Parallels Workstation for Windows and Linux' started by aitch, Dec 6, 2006.

  1. aitch


    After a bit of fighting i finally managed to get my Solaris 10 U1 JDS guest running widescreen on my windows laptop host. Note this is not OpenSolaris but may help in some places. I used a few of the posts on this board plus external links and a bit of fudging. Installation was pretty much flawless but defaults to 1024x768. Full screen aspect ratio was weird (in a window it worked great)

    Anyway I thought it might help someone else so here it is. I've also attached my xorg.conf file for reference. Please add any additional information as you see fit!

    My laptop is an Acer 1683WLMI ( 15.3", 1280x800 Radeon 9700, 2Gb )

    The standard network patch supplied with parallels allowed solaris to share the existing wireless WPA-PSK connection to see the outside world

    For Video:

    Run /usr/X11/bin/gtf to ascertain modelines for specific resolutions (not in the path by default!)

    /usr/X11/bin/gtf 1280 800 50.00
    /usr/X11/bin/gtf 1280 800 60.00
    /usr/X11/bin/gtf 1280 800 85.00

    Within /etc/X11/xorg.conf create a new "Modes" section and paste in the output
    (My numbers are irrelevant, generate your own!)

    Section "Modes"
    Identifier "MyModes"
    Modeline "1280x800" 68.56 1280 1336 1472 1664 800 801 804 824 -HSync +Vsync
    Modeline "1280x800_60.00" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync
    Modeline "1280x800_85.00" 123.38 1280 1368 1504 1728 800 801 804 828 -HSync +Vsync

    It's not entirely clear to me whether all 3 are required with these refresh rates (not being so appropriate to laptop screens) but i found a blog post for another acer laptop native on ubuntu that used this approach and haven't tried without.

    Then refer to the MyModes section in the corresponding Monitor section

    Section "Monitor"
    Identifier "Local Flat Panel"
    VendorName "Acer"
    ModelName "LCD Panel 1280x800"
    Option "DPMS"
    UseModes "MyModes"
    DisplaySize 322 201

    The final problem I had was that gnome seemed wedged in 1024x768. Curiously my dtlogin screen was displaying in 1280x800 properly but either flicked to 1024x768 or a corrupted display on login. Also there was no option for 1280x800 on the "Change Desktop Resolution" menu option. On a hunch I thought that gnome was wedged in 1024x768. I'm not sure whether it made a difference but i also had to hack ~/.gconf/desktop/gnome/screen/default/0/%gconf.xml to change the 1024x768 to 1280x800 after a full reboot i was in full widescreen.

    Other random notes:

    I've been trying to strip down my xorg.conf file by removing things like sync/refresh rates and thus these go to defaults

    /var/log/Xorg.0.log is full of good information

    You may need to run (as root) dtlogin reset periodically, especially if on the command line. If you have a GUI up then logging out and back in again seems to do it. Sometimes a full reboot works better.

    If you don't have cut and paste (eg command line login) then it's useful to redirect the gtf output to the end of xorg.conf then use vi to move the line. eg /usr/X11/bin/gtf 1280 800 60 >> /etc/X11/xorg.conf

    It now looks and works GREAT!


    (note the xorg attachment may need to be opened in wordpad)

    Attached Files:

    Last edited: Dec 6, 2006

Share This Page