Host only networking and internet access

Discussion in 'Parallels Workstation for Windows and Linux' started by ironphil, Apr 23, 2006.

  1. ironphil

    ironphil

    Messages:
    1
    Is it possible to set up a guest vm with host only networking and still have access to the internet? When I change the setting to host only, my vm does not have any internet access. I know it says "host only" so maybe it is not possible but I'm asking because my university does not like bridged connection (more than one ip address from the same plug) so I thought I could try the host only.
     
  2. afore

    afore

    Messages:
    86
    Apparently you can do this with Mac or Windows as host OS. There are several posts on this lists about this. I have been trying to do this with SuSE 10.0 as host and WinXP as guest with no success.

    Art
     
  3. tgrogan

    tgrogan

    Messages:
    255
    Under Suse startup and configure Squid to allow internet access. This will not give your email access, but who in their right mind would want to use outlook when there are many good email clients in Suse. If you must do email too, you will have to configure routing. Your guest will have to be routed from the host only network to your host's connection. I don't know how to do this, but if you need help somebody else probably knows.
     
  4. afore

    afore

    Messages:
    86
    Host only networking with Suse 10.0

    Found out how to do this with Suse 10.0 as host and WinXP as guest OS. Here from Jos van Kan of the suse-e mail list: (just change wlan0 to eth0 or what ever you network card is called and he wrote it for Suse 9.3, but it works for 10.0)

    By running parallells-config or /usr/lib/parallels/autostart/drivers_start a virtual network interface (vnic0) has been established with (local) IP addres 10.xxx.xxx.xxx Run /sbin/ifconfig to find out this ipaddress. For me this is 10.37.129.2 and the domain will be 10.37.129.0/24.

    Make sure the SuSEfirewall is running, this guarantees that the ip_tables module has been loaded.

    Change to root.

    1. Set ip forwarding
    sysctl -w net.ipv4.ip_forward=1

    Edit /etc/sysconfig/sysctl and set IP_FORWARD="yes"
    This guarantees that ip forwarding will be on after reboots.

    2. Set ip masquerading for vnic0

    Edit /etc/sysconfig/SuSEfirewall2

    a. Add vnic0 to FW_DEV_INT and make sure FW_DEV_EXT="wlan0"
    b. Set FW_ROUTE="yes"
    c. Set FW_MASQUERADE="yes"
    d. Make sure FW_MASQ_DEV="$FW_DEV_EXT"
    e. Add the vnic0 domain to FW_MASQ_NETS, in my case:
    FW_MASQ_NETS="10.37.129.0/24"

    3. Restart the firewall
    rcSuSEfirewall restart

    4.
    In the guest/OS set up a LAN, with IP in th vnic0 domain but not 1 or 2 (they have been used already), say 10.37.129.3, mask 255.255.255.0 and gateway the (local) IP of the wlan0 (in my case that would be 192.168.2.3)

    All should work now. Fire up a console in the guest os and
    ping 10.37.129.3 (Should always work, unless the drivers havent been installed)
    ping your wlan
    ping your wireless router
    ping the internet

    I might add that if you go to System, Monitor, Network interfaces, it will show your network interfaces where Yast, Network devices will not show vnic0. I added it under Network devices.
     
  5. gandalf

    gandalf

    Messages:
    3
    Host only networking and internet acces

    I may add, that for the life of me I haven't been able to get this to work with a Linux guest. I tried both the Gentoo and Suse 10.1 installation, but although the virtual interface is recognized (had to load an ne2000 module in Suse 10) the internal network is unreacheable.
    For an XP guest it works, so this is something quite tricky I'm afraid.
     
    Last edited: Apr 30, 2006
  6. gandalf

    gandalf

    Messages:
    3
    Wireless networking for Linux guests SOLVED

    Just to show that wireless networking on virtual machines is something of a black art: if you want to work wireless on a linux guest under a linux host you have to choose "bridged networking", choose the wlan0 as primary interface, set in the guest OS networking to "wired", no dhcp, choose a new IP from your existing subnet (192.168.xxx.xxx) for the virtual eth0, make the ip of real wlan0 your gateway and in the host os set

    iptables -t nat A POSTROUTING -s <your virtual ip> -o wlan0 -j MASQUERADE

    That's all. (Don't forget to restart the firewall though)
    Worked on both the Suse 10.1 and the Gentoo installations

    :cool:
     
    Last edited: May 1, 2006

Share This Page