Hot GPU causing MacBook Pro fans to run high most of the time

Discussion in 'Installation and Configuration' started by MacJedi, Feb 5, 2014.

  1. metavolta

    metavolta Bit Poster

    Messages:
    2
    How do you disable DX10? Try searching online but no straight forward answer
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,990
    Hello, did you try some instructions from this KB article?
     
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,990
    Did you play with VM configuration -> Hardware-> Graphic settings?
     
  4. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    123
    I frequently have issues with parallels causing my mac to run hot. I have a 2019 MBP with 6 cores. What I've noticed is that the prl_disp_service takes up 7-15% of my CPU resources even when no apps are running in the guest windows VM, and much more when I'm actually doing work. This can lead to the fans kicking in.

    Maybe there's no solution to this, since virtualization is obviously not free from a computational standpoint. But one thing I've done to help keep the laptop cooler and the fans quieter is to install Turbo Boost Switcher Pro from http://tbswitcher.rugarciap.com/. What this does is let you disable the turbo boost option on your MBP CPUs, which helps keep the peak CPU frequency down, and hence the CPU temp lower, which keeps the fans from kicking in. You lose a little performance, but you probably won't notice it unless you're doing really CPU-intensive tasks. And you can switch it on and off whenever you want, so if you suddenly need peak performance you can re-enable turbo boost instantly.
     
    AlbertoM6 likes this.
  5. JoelW3

    JoelW3 Bit Poster

    Messages:
    6
    Hi - I have this issue too. I've been using parallels for 8 years with no issues and long battery life in my macbook 15 inch, but on buying a 16inch Macbook and running Parallels 15/16, the software is heating up my machine and eating my battery significantly.
    Has anyone found a solution?
     
  6. JoelW3

    JoelW3 Bit Poster

    Messages:
    6
    I'm running 16 inch with top config, same issue. Did you find a solution?
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,990
    Hello, could you collect the tech report once the issue reproduced please and post the report's ID here?
     
  8. JoelW3

    JoelW3 Bit Poster

    Messages:
    6
    Hi Maria,
    The report ID is below:
    351219726
     
  9. MahdiK

    MahdiK Bit Poster

    Messages:
    2
    Same here, running a top confg mac pro, the built in keyboard gets so hot, I can't touch it. Fans running all the time.
    I am thinking of dropping Parallels, and going back to bootcamp.

    upload_2020-10-12_2-17-1.png
     

    Attached Files:

  10. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,990
    Please upgrade to the latest Parallels Desktop 15 build: 15.1.5 and check the issue.
     
  11. MahdiK

    MahdiK Bit Poster

    Messages:
    2
    Switched to Bootcamp, it is much better. The resources on my machine are better utilised, and performance difference is considerable.
     
  12. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,990
    Hello, did you check the issue with Parallels Desktop 15.1.5?
    We're still looking forward to your reply.
     
  13. ParalllelsJ

    ParalllelsJ Bit Poster

    Messages:
    2
    I'm using a brand new install of Paralells 16.1.2-49151. I'm using a fairly new 16" MacBook pro. When I load by BootCamp Windows installation into Paralells, my processory is running VERY hot and the fans are running non-stop.
     
  14. JoelW3

    JoelW3 Bit Poster

    Messages:
    6
    Try checking Task Manager in Windows to see if there are any rogue processes - that was my issue even in a clean and legitimate install of Windows.
     
  15. Moises1

    Moises1 Bit Poster

    Messages:
    1
    Hello.

    I have the same issue, when i work with parallels using two displays (external display + macbook) the processor increase the temperature and the fans are running non-stop.

    Specs:
    upload_2021-3-10_21-30-30.png

    upload_2021-3-10_21-39-32.png

    Fans:
    upload_2021-3-10_21-37-7.png



    Process Consumption in Mac:
    upload_2021-3-10_21-38-44.png

    Process Consumption in Windows 10 (Parallels):
    upload_2021-3-10_21-40-33.png

    Parallels config:
    upload_2021-3-10_21-42-53.png

    There is no reason for this to happen, it is clear that this is an excessive resource consumption problem in Parallels when used in full screen with an external monitor and the mac screen.

    Do you have a solution for this?
     

    Attached Files:

  16. AlbertoM6

    AlbertoM6 Bit Poster

    Messages:
    2
    Hi, Mois├ęs. This is more related to your MBP than to Parallels, I own exactly same MBP model like you (only difference being my GPU with 8GiB). Check on next links:
    You have an option to help cooling your VRM and avoid this fan craziness (I did it and works):
    Buena suerte.
     
  17. Aries@Parallels

    Aries@Parallels Bit Poster

    Messages:
    53
    Just chiming in to point out that Windows is not optimized for the hardware like MacOS is (for obvious reasons), so the fans will kick in more often, if not always. I grabbed MacsFanControl (shown above by someone else) and when I see the temps spike above 75-80C (no matter the OS), then I'll push the fans to full. Yes, it's louder and going to use more power, but you get your Windows running. Now I Am using a 2012 MBP, so mine happens more frequently than I'd like, but it may be that I need to replace the thermal layers due to age as well.
     
  18. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,990
    Hello guys, could you collect the tech report once the issue reproduced and reply su back with the report's ID here please?
     

Share This Page