How to best troubleshoot performance issues in Win 11 ARM on Mac M1

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by JohnD63, Mar 1, 2022.

  1. JohnD63

    JohnD63 Bit Poster

    Messages:
    4
    Hi
    I have started using Parallels recently in connection with my new Mac M1 Max.
    I have installed the Windows VMs that I need now on Windows 11 ARM (64bit). Most of the time everything runs fine and fast. However, when I build a project in IBM Domino Designer (which is Eclipse) then it take several minutes... On VMware Fusion on my 6 year old previous computer it takes seconds....
    I have tried to configure the VMs' CPU and memory as "Automatic" as that is marked as the recommended option. I also added the "Parallels" folder where my VMs are to the Spotlight / Privacy as suggested by another user. But still no joy.
    I have seen it perform Ok a few times - but cannot really pinpoint what was different at those times. At one time I thought it was just after a reboot of the entire machine and the VMs - but cannot reproduce this consistently. Just rebooting the VMs really has no effect...

    The Mac itself has 64GB RAM, 2TR SSD disk and the fastest processor - so running one or two Windows VMs should not push it near any limits.

    What can I do to troubleshoot this so I can get rid of my old machine with the VMware Fusion VMs?
     
  2. JohnD63

    JohnD63 Bit Poster

    Messages:
    4
    No-one????
    At the moment I have to have an old Intel based Mac with VMware Fusion running next to the new computer to do some work in a decent time... From the pattern I have a feeling that disk access (possible to a shared folder but not limited to that) seems to just take for ages....
    I would really appreciate som ideas on how to confirm that that is the problem - or just as good that it is not the problem - so I can test further for a solution. But at the moment my Windows in Parallels is not really usable :-(
     
  3. SimonT16

    SimonT16 Bit Poster

    Messages:
    2
    I have a similar experience. I am running Excel within Parallels to run some pretty simple power query activities. Takes 7-8 mins within Parallels. On a standalone Windows machine its takes seconds. Something in parallels needs work. Mac is M1 Max with 64gb. Standalone machine is 6 years old and has 32gb. Both virtual and standalone running Windows 11.
     
  4. JohnD63

    JohnD63 Bit Poster

    Messages:
    4
    Since one of the updates a month or two ago it has been much faster and is now usable :)
     
  5. SimonT16

    SimonT16 Bit Poster

    Messages:
    2
    Wish I could say the same - what settings are you running with?
     
  6. JohnD63

    JohnD63 Bit Poster

    Messages:
    4
    Well, there are a few :)
    I was just trying to see if I could find a config file instead of going through all of the config. screens....
    • Optimisation: No limit
    • CPU & Memory: Auto
    • Graphics: Scaled
    • Disk: SATA 0:1 - Enabled Trim
    • Not encrypted nor isolated from Mac
    • Not backed up automatically by Time Machine
     

Share This Page