How to configure "Sharing Network" to use Wi-Fi adapter only.

Discussion in 'Installation and Configuration' started by Damonwinner, Nov 3, 2021.

  1. Damonwinner

    Damonwinner Bit Poster

    Hi Everybody!
    I need your help! tried to googling but unsuccessfully.
    I'm using two types on network adapters (LAN and Wi-Fi). LAN is using for access to corporate network and Wi-Fi for guest. I have VM with Windows and app what need to sync with app on my phone. Phone connected to guest network by Wi-Fi.
    I've tried to use "Bridged Network" > Wi-Fi in VM's configuration. But synchronisation was terrible. 95% of attempts were unsuccessful. Firewall in MaOS is off.
    I've switched to "Shared Network" and make routes for port from host to VM. And it was success until I connected LAN. If I use booth networks then synchronisation doesn't work. I think Parallels is using LAN adapter for virtual network.
    How I can change this? How I can configure "Shared Network" to use Wi-Fi Adapter for virtual network?
    Thanks everybody!
  2. McallenT@Parallels

    McallenT@Parallels Staff Member

    Please refer to the below KB articles and check.
  3. Damonwinner

    Damonwinner Bit Poster

    Hi McAllen!
    This links aren't related with my issue.
    I've solved this task by adding rote by command line.
    route add -host -interface en0 -
    VM's IP.
    en0 - name of Wi-Fi interface.
    I'm testing this configuration. Still works fine.

Share This Page