How to disable spotlight on all USB drives

Discussion in 'Installation and Configuration' started by David Lethe, Dec 8, 2012.

  1. David Lethe

    David Lethe Bit Poster

    Messages:
    7
    How in the heck do I disable spotlight from indexing any USB-attached drives whenever I mount them? I can take a fresh new USB, plug it into my mac running windows as the guest O/S, tell parallels to assign the USB to windows, but it still indexes it.

    I don't see any settings in Parallels that addresses disabling indexing on USB devices (or for that matter macs). My spotlight is even set up to disable indexing on "Volumes", but I fear that parallels is somehow breaking this due to my settings.

    My sharing options for the Windows VM are:
    Security: everything unchecked, including the "Isolate Mac from Windows"
    Backup: TimeMachine - unchecked, so it does back up via time machine, Smartguard disabled,
    Sharing: Home folder only, plus one subdirectory, equivalent to the windows "D" drive; shared profile unchecked, smartmount unchecked, access windows folders from mac - unchecked, mount virtual disks to mac desktop checked but greyed out;
    Parallels general settings - USB: When USB device is detected-Ask me what to do Under Permanent assignments, the apple keyboard, isight, and bluetooth host controller#2 all connected to computer.

    Note i do use time machine, but any new stick gets indexed with spotlight immediately, so at least this happens before time machine is run on the virtual windows machine.
     

Share This Page