How to Disable WinKey Shortcuts in Windows 11 VM

Discussion in 'Parallels Desktop for Mac' started by DavidD62, Mar 31, 2023.

  1. DavidD62

    DavidD62 Bit poster

    Hi y'all. I'm coming from being a proficient Mac/JetBrains IDE shortcut power user. Now that I'm (kinda) forced to use Parallel's Windows 11 VM I'm trying to quickly port over my shortcuts in my Mac JetBrains IDE (Rider) to the Windows version. I use a custom split keyboard running on QMK and my layout has been customized to my 150+ custom shortcuts in my IDE so that I can reduce my wrist/arm pain by reducing the need to reach away from the home row and/or use the mouse.

    I am trying to disable the Windows 11 shortcuts that make use of WinKey so that I can map those combinations to specific shortcuts I use A LOT within my IDE. The reason I want to do this is that I have mapped my CMD key (that is in a special location because of my custom keyboard and custom layout) to the WinKey and was hoping I could just quickly map my same shortcuts to the same layout. However, as I found out, you cannot override system shortcuts in the IDE in Windows like you can on a Mac. Upon research it seems that I can disable those shortcuts using the described steps below. However, upon doing those steps and trying to log-out/log-back-in, restart, shutdown, and even reset the VM I still haven't been able to disable those shortcuts.

    Steps I followed to try and disable the Windows 11 WinKey shortcuts:

    To disable Windows 11 shortcuts that utilize the Windows key inside a Parallels Windows 11 VM, you can modify the Windows Registry of the virtual machine. Here are the steps to do so:
    1. Start the Parallels virtual machine and log in to Windows 11.
    2. Press the "Windows" key + "R" key on your keyboard to open the "Run" dialog box.
    3. Type "regedit" and press "Enter" to open the Registry Editor.
    4. Navigate to the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    5. Right-click on an empty area in the right pane and select "New" > "DWORD (32-bit) Value".
    6. Name the new value "DisabledHotkeys".
    7. Double-click on the "DisabledHotkeys" value and set its value data to "1".
    8. Click "OK" to save the changes and close the Registry Editor.
    Am I doing something wrong? Is there any way that I can override those system shortcuts so that I can use the WinKey shortcuts in my IDE? Or, is it just impossible regardless if I was able to disable those system shortcuts (i.e., would disabling those shortcuts prevent the ability to use those key combination anywhere in Windows 11?)

    Thank in advance for the help!!!!!

Share This Page