How To Enable VT (aka VTX or VT-x) with rEFIt and vmx-var-set.efi

Discussion in 'Parallels Desktop for Mac' started by monoclast, Jul 13, 2006.

  1. monoclast

    monoclast

    Messages:
    24
    I've seen a bunch of instructions here for doing this; but all of them seemed to leave out one or two crucial details. So I'll try to provide those who need it a more complete list of steps to get this done, as well as some background about why one might want to do this to begin with:

    The chips Apple uses in the Intel Macintosh computers have VT built into them. VT stands for Virtualization Technology — it allows the chip to run multiple operating systems and applications in independent partitions on the chip, resulting in reletively large speed increases for the end user. Basically, you will see fairly dramatic speed increases running Parallels with VT enabled compared to running Parallels without VT enabled. For detailed information about VT, see http://www.intel.com/technology/computing/vptech/.

    Unfortunately for us Mac users, VT is not turned on in all current Intel Macintosh computers, for whatever reason. As a result, Parallels users have experienced intermittant success with Parallels ability to enable VT on its own. These instructions show you how to use the EFI firmware in Intel Macs to enable VT in the processor permanently, so that it lasts through restarts of the computer.

    1. If firmware update is available for your Intel Mac, install it before continuing. (NOTE: There was a firmware update for the Intel Mac mini when this procedure was written: http://www.apple.com/support/downloads/macminiearly2006firmwareupdate101.html).
    2. Download rEFIt disk image from: http://prdownloads.sourceforge.net/refit/rEFIt-0.5.dmg?download
    3. Download vmx-var-set.efi zip archive from: http://i30www.ira.uka.de/~joshua/vmx.zip
    4. Mount rEFIt disk image.
    5. Decompress vmx zip archive.
    6. Copy rEFIt "efi" folder to root of startup volume.
    7. Copy "vmx" folder into "efi" folder at root of startup volume.
    8. Open Terminal.
    9. In Terminal, enter command: cd /efi/refit
    10. Enter command: ./enable.sh
    11. At prompt, enter your user account password.
    12. Restart computer, holding down Option/Alt key on keyboard until you see boot device selection menu.
    13. Select rEFIt boot device to enter rEFIt menu.
    14. In rEFIt menu, select Console.
    15. At console prompt, enter volume command: fs0:
    16. Enter command: ls
    17. If root of startup volume is not listed:
      1. Increment volume number (for example, "fs1")
      2. Re-enter volume command (for example, fs1: )
      3. Go back to step 16.
    18. If root of startup volume is listed (NOTE: you should see items such as: Users, Volumes, etc, mach, private, var, usr), enter command: cd efi
    19. Enter command: cd vmx
    20. Enter command: vmx-var-set.efi
    21. If an error message was displayed, here or at any point prior to this, it's possible some files are not in the right place, or you missed a step. Try the steps again from the start, and if they still don't work, seek help online!
    22. If no error message was displayed, enter command: exit
    23. From rEFIt menu, boot into Mac OS X (usually the first menu item).
    24. Remove "efi" folder from root of startup volume.
    25. Open Apple menu > System Preferences > Startup Disk.
    26. Select your normal Mac OS X startup disk.
    27. Close System Preferences.
    28. Shut down.
    29. Leave computer completely off for 10 seconds.
    30. Turn computer back on and boot up normally (no keys held down).
    31. Run Parallels.
    32. In Parallels, open and start a virtual machine. (NOTE: The About Parallels dialog box does not show Intel VT-x unless a virtual machine is currently loaded and running!)
    33. From Parallels menu bar, select Parallels > About Parallels Desktop.
    34. In About Parallels Desktop dialog box, click More Info button.
    35. About dialog box should now show Virtualization Mode: Intel VT-x.

    Hope this helps!

    -mono
     
    Last edited: Jul 13, 2006
  2. GregMeach

    GregMeach

    Messages:
    4
    Very nice... I'm going to try this on my new iMini when I get home. It surprised me when I copied over my image from my MacBook drive (it's out getting repaired and we need to run Quicken) and it compained that VT was not available.

    I wonder why the mini has it disabled? Is it because of the slower CPU (1.66 vs 1.83)?
     
  3. SteveS

    SteveS

    Messages:
    4
    iMac -- After firmware upgrade, I just get a black screen in my XP guest

    I just got an iMac 20" and installed parallels. Working great--and fast--installed a couple of other things (dragon naturally speaking, the whole reason I wanted to be able to run XP and firefox), and then I did both the 1.01 and 1.0 SMC firmware upgrades, but not in that order. The SMC update went off without a hitch. But I was also thinking about using bootcamp, so I had to do the 1.01 update as well. After running that, all I get is a black screen in my guest OS. Is there something related to this VT discussion in the update that could be causing my problem?

    Any help will be appreciated.
     
  4. blondsummer

    blondsummer

    Messages:
    5
    i've just buy a miniMac dual core

    Do you try with the last version of mini mac ? does it works fine ? what is the problem if you have an error ? can you block the minimac ? can we restore the VT to disable if an error appear ? and the last question :) do you think apple will make a correction soon ? (ah ahah this last question is stupid i know)
     
    Last edited: Jul 20, 2006
  5. ajay

    ajay

    Messages:
    153
    Isn't there an easier way? I'm not that conversant with the Mac and from the look of the instructions, I could foul something up. Currently, everytime I reboot, I put my Mac mni to sleep and then wake it up. This enables VT for me. I would like a permanent fix but am hesitant to go through those 20 steps. Is there a patch or something I could just copy?
     
  6. blondsummer

    blondsummer

    Messages:
    5
    Can u explain ?

    Hi, can u explain what do you do to have in a mac mini the VT-X enable ? you just put the mac mini to sleep ? and after you laught parallels and all is working well ??? i've just test but for me it's not working. :(
     
  7. ajay

    ajay

    Messages:
    153
    What works for me is to restart the mini, then after it comes up and settles down, i manually put it to sleep via the apple drop down (upper left corner) for about 5 seconds. I then move the mouse to wake it up and I have VT enabled. It stays that way until and unless I reboot.
     
  8. blondsummer

    blondsummer

    Messages:
    5
    Fabulous

    Now you're right, i've made what you said, and now i don't have the box tell me that the VT-X is disable... so it means that it's enable :) how can i be sure that it's enable ?
     
  9. ajay

    ajay

    Messages:
    153
    Well, you've hit on the first clue. If the startup box message does not say VT-x is disabled, you're on your way. In the Configuration Editor, (the Parallels Desktop panel that first pops up), be sure the Enable Intel VT-x support box is checked. It may be found under Options/VM Flags. Bring up your Guest OS, and once up and running click the Parallels Desktop header at the top left of your screen. Select the About Parallels Desktop from the dropdown box and then click the More Info box on the Parallels Panel. It wil bring up a screen which will show (Virtualization Mode) whether or not VT-x is enabled. That's it. It's a minor annoyance to have to remember to put the Mac to sleep after rebooting/restarting, but it's easier (in my opinion) than following those 20 odd steps mentioned earlier in this thread.:)
     
  10. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Thanks, AJAY. I'm glad you explained this. I did the check and mine is enabled. Probably always has been??? My computer has ample opportunity to go to sleep so I guess that it is the reason it was enabled?
     
  11. ajay

    ajay

    Messages:
    153
    That is probably the reason, although not all Mac's experience this annoyance. I'm all for whatever works and the simpler the better. Good luck.:)
     
  12. GADesser

    GADesser

    Messages:
    3
    Thank you!

    :) Great procedure.:)

    When I started Parallels I received a message that Hardware Virtualization was not enabled and had to be enabled in the Firmware. After I found your procedure and followed your clear, concise steps the About dialog box in Parallels now shows Virtualization Mode: Intel VT-x as indicated in the last step.

    Again, thank you for a great procedure.:) :)
     
  13. poshpaws

    poshpaws

    Messages:
    7
    mac pro working

    early days but it boots XP with out KP! (normally locks machine as soon as i start any vm)
    this tip works thanks


    Mac pro 3Ghz - 3gb ram , X1900 Gfx

    ok spoke too soon , kp's on xp install completeing textmode :(

    doing further testing


    is it me or does seting vt on make the machine faster?
    seems to boot quicker - YMMV!
     
    Last edited: Sep 15, 2006
  14. j-active

    j-active

    Messages:
    43
    Can someone verify this was tried on a Dual Xeon Mac Pro and works correctly?

    I'm not clear if people have tried and/or having problems.

    Thanks.
     
  15. poshpaws

    poshpaws

    Messages:
    7
    clarity

    Works for me

    Mac pro Dual 3ghz , 2gb ram , X1900 gfx

    had to remove 1gb of ram (running 2) , will test with the nvram settings tomorrow (it's 11pm here)




    tested with Multiple xp vm's running , 2 running existing images - the others running installers and a Sol10 vm


    the network settings hack is needed to get any of the vm's to talk to the internet


    if you try this procedure please - confirm something for me , after setting , and rebooting my machines seems to be much faster


    YMMV
     
  16. David Watson

    David Watson

    Messages:
    15
    Did not work on my Mac Pro. Followed all the steps, no errors. Still telling me VT-X is not enabled. I haven't gotten the sleep trick to work either. Still runs pretty fast, though.
     
  17. j-active

    j-active

    Messages:
    43
    The original instructions worked on a Mac Pro Dual Xeon 2.66 with 2MB ram.

    VT-x appears to be permanently enabled now.

    Yeah!

    Interesting observation about the booting. I thought I was imaging it, but my machine boots much, much faster now too.
     
  18. irie

    irie

    Messages:
    2
    Did not work on my 3Ghz Mac Pro. The computer seems to take longer to shut down and enter sleep mode. Is there any way to undo this?
     
  19. poshpaws

    poshpaws

    Messages:
    7
    I would think a pram reset would get rid of this
     
  20. poshpaws

    poshpaws

    Messages:
    7
     

Share This Page