How To Enable VT (aka VTX or VT-x) with rEFIt and vmx-var-set.efi

Discussion in 'Parallels Desktop for Mac' started by monoclast, Jul 13, 2006.

  1. jbmelby

    jbmelby

    Messages:
    80
    When you say "the original instructions", do you mean the ones in monoclast's post of July 13th? If not, which post are you referring to?
     
  2. j-active

    j-active

    Messages:
    43
    I followed the list of instructions and used the downloads available in the first post of this thread. Of course, I skipped the mini firmware update listed in step 1.

    [edit: found an interesting problem related to OS X build, starting a new thread]
     
    Last edited: Sep 17, 2006
  3. darkwing

    darkwing

    Messages:
    5
    No go on enabling VT-x

    Well, I followed the instructions and it did not work ... Mac Pro dual 2.66 ... note that the instructions are rather cryptic and there is no CONSOLE command ... instead, I wound up in the EFI Shell ... is that why it didn't work, maybe???
     
  4. Pleiades

    Pleiades

    Messages:
    79
    I tried it on my 3GB 2.66GHz Mac Pro and it did not work. I still get the VT-X warning when starting up a VM. The More Info... in the about box tells me that it's in Software Mode 2.

    Even though it didn't do a thing to fix that problem, my Mac Pro does boot up now lightning fast. It took about 15 seconds total to go from chime to full desktop. Wow! So what did that do, exactly, besides trying to permanently enable VT-X (which it didn't actually do but had a great side effect).
     
  5. echeng

    echeng

    Messages:
    3
    I tried this on my Mac Pro 3Ghz, and it also doesn't work. I'm showing Software Mode 0. :(
     
  6. firebird2k

    firebird2k

    Messages:
    9
    I tried the same thing without any success... The sleep trick still works, but can't get it set permanently.
     
  7. dnanian

    dnanian

    Messages:
    42
    Same thing here. Applied the update fine, but VT-X does not enable without sleep. 3GHz Mac Pro.
     
  8. sydbarrett74

    sydbarrett74

    Messages:
    61
    This didn't work for me -- I still go into a VM and it says VT-x is locked by the firmware. Also, I got a message saying that Parallels would only work with 2GB (I have 4GB in my Mac Pro), and so it disabled the other 2GB.
     
  9. foulgernz

    foulgernz

    Messages:
    2
    Please help an idiot. I stuffed up the procedure by putting vmx folder in wrong place. Can some kind person tel me how to uninstall the VT-x refit so that I can start again, please. E-Mails to foulger@macservice.co.nz. Thanks so much
     
  10. darkwing

    darkwing

    Messages:
    5
    Try installing 10.4.8 and RC 1922 -- that fixed the matter for me
     
  11. webdeck

    webdeck

    Messages:
    21
    Has anyone gotten this to work with a Mac Pro? My Mac Pro won't go to sleep because of its ATTO PCIe SCSI adapter, so I can't use the sleep workaround.
     
  12. mvk

    mvk

    Messages:
    28
    With RC 1922, manually uninstall Tools from the add/remove control panel, reboot the VM, and reinstall Tools. PD now works perfectly on my MacPro. No more VT-x errors.
     
  13. jbmelby

    jbmelby

    Messages:
    80
    Didn't work for me.
     
  14. webdeck

    webdeck

    Messages:
    21
    I can confirm that vmx-var-set.efi does nothing on the Mac Pro. The variable it is trying to alter has a different name on the Mac Pro. Even if you edit the program to change the name, the size of the contents of that variable is shorter than the byte it is trying to modify. So, no luck for the Mac Pro.

    -Mike
     
  15. SteveCook

    SteveCook

    Messages:
    3
    I've never gotten sleep to make a difference. Has any of you? Mac Pro 3.0Ghz, 4GB Ram....
     
  16. davert

    davert Bit Poster

    Messages:
    53
    Sleep didn't work for me either.
     

Share This Page