How to increase Parallels/Windows performance

Discussion in 'Installation and Configuration' started by PedroS3, Jun 5, 2020.

  1. PedroS3

    PedroS3 Bit Poster

    Messages:
    8
    Hi, group!

    Well, I was struggling with Parallels configuration, until I received the invaluable help of Maria, from Parallels staff, which made things easy and clean.

    I'm a Mac user since 1983 and NEVER got really into Windows ambient.
    So, I am "forced" to use Windows, because there are a couple of apps I really need to work with, which don't have Mac versions.

    When trying to work with them, I figured Parallels/Windows is painfully sloooooow, even if there are no apps running on the "Mac side"!
    This Mac I'm working with has only a couple of months, so, there isn't a "Mac power" problem.

    So, my question is: is there a way to improve Parallels performance? Maybe allocating more RAM or something. If there is the case, how can I do that?

    Sorry for being so "newbie" at this, but I really don't know what to do.

    Thanks in advance for any tips
    Best,

    Pedro
     
  2. Hello PedroS3. Please refer to this article and optimize the settings for a good performance. If the issue still persists, kindly let us know for further assistance.
     
  3. PedroS3

    PedroS3 Bit Poster

    Messages:
    8
    Hello.

    Thanks for your reply.
    I was a little busy till now... so, I tried to configure things to improve performance.

    But... when I tried to change VM settings - and although I "unlocked" the lock to do so - but nothing happens and I cannot change anything.

    I join an image and ask you how to go from here.

    Thanks in advance

    Best

    Pedro
     

    Attached Files:

    • 00.png
      00.png
      File size:
      325 KB
      Views:
      3
  4. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,694
    Hello, please shut down your Windows VM. Click on Start button and choose "Shut down", then please try to perform the steps above one more time.
    Please let us know if you have any additional questions.
     
  5. PedroS3

    PedroS3 Bit Poster

    Messages:
    8
    Hello, Maria, we meet again. And again, you solved (a part of) my problem.
    In fact, after shutting down VM, I could perform some changes. I increased RAM to 4.096 and noticed there was no TRIM option to disable.
    But... Windows continue desperately slow, I don't know why. No problem on the "Mac power" side, because the unit is relatively new.

    Have you got some "magical" configuration you want me to try? Hope you do.

    Thanks for your interest.
    Best regards

    Pedro
     
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,694
    Hello, Pedro, please try to change the hypervisor type at VM configurations> CPU and Memory > Advanced > change Parallels hypervisor to Apple.
     

Share This Page