How to prevent parallels 12 from pausing when I'm away

Discussion in 'Mac OS X Guest OS Discussion' started by HeranQ, Nov 11, 2016.

  1. HeranQ

    HeranQ Bit Poster

    Messages:
    1
    Hi,
    I'm running a CPU intensive program in Mac client when after a while it is paused automatically. I googled but all I got is for Windows. I can't find any option about pause. Is there anyway I can stop it?
    Thanks
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hello HeranQ, please check out this article to know how to prevent pausing virtual machine automatically.
     
  3. DavidK18

    DavidK18 Bit Poster

    Messages:
    4
    @PaulChris@Parallels That kb article appears to be only for Windows guests. The OP is asking about disabling the auto-pause for MacOS guests. I am also having the same issue. I don't see the "Performance" section or the "Pause MacOS when possible" option in the Optimization tab under Options (see my screenshot). I've tried this when the VM is running AND when the VM is shut down. My VM also has the latest Parallels Tools installed.
     

    Attached Files:

  4. BenK1

    BenK1 Bit Poster

    Messages:
    10
    Can someone answer this ?? should be pretty simple
     
  5. alexg

    alexg Parallels Developers

    Messages:
    543
    BenK1, to disable "pausing" macOS guest please disable sleep in macOS guest system preferences.
     

    Attached Files:

  6. JimS9

    JimS9 Bit Poster

    Messages:
    2
    Does this apply to Parallels 13 running on macOS High Sierra? I can't find anything that addresses that.
     
  7. CristianA2

    CristianA2 Bit Poster

    Messages:
    4
    In the Parallels 11 Configure menu, Options tab. Uncheck "Pause Windows when possible"
     

    Attached Files:

  8. ScottK11

    ScottK11 Bit Poster

    Messages:
    1
    @PaulChris@Parallels @alexg

    This question still isn't answered for Mac clients, at least not for current versions of macOS. The Energy Savings settings does not have individual options for Plugged in and Battery on a High Sierra Mac client. The only check box option is "Put hard disks to sleep when possible" which I have unchecked.
     

    Attached Files:

  9. neilb10

    neilb10

    Messages:
    1
    Hey ScottK11,
    ChristianA2 wrote
    "In the Parallels 11 Configure menu, Options tab. Uncheck "Pause Windows when possible"
    he's right, its there on Sierra, but on your screenshot, you are in the mac OS energy saver preferences - not the Parallels control panel. At the top of your screen with windows running click actions then configure. That's the menu you need.
    In my case, under the options tab the "pause windows when possible" option was inside the "startup and Shutdown" section.
     
  10. Ken Cunningham

    Ken Cunningham Bit Poster

    Messages:
    18
    Thanks, everyone. For me, opening up the "System Preferences" -> "Energy Savings" inside the guest macOS, and setting the guest macOS system to sleep "Never", indeed stops the VM from pausing during long compiles, etc. I also disabled "Display Sleep" and unchecked "Put hard disks to sleep..." as I presume that Parallels and the host machine would like to take care of those issues.

    I don't know at present what happens when the host computer wants to sleep but the guest OS is set to "Sleep Never" -- but this machine I am using it on never sleeps anyway, so that's not an issue I have to worry about.
     

Share This Page