How to reproduce sticky key problem (and others)

Discussion in 'Windows Guest OS Discussion' started by Wildnight, Nov 12, 2008.

  1. Chris von Rabenau

    Chris von Rabenau Bit Poster

    Still a problem

    This is still a problem for me. Agree that is it happening less often, but now it is more persistent when it does. I used to be able to get it to stop by going to the host and returning to Parallels. This does not work any more for me. Reboot is required to end the problem.
  2. Sara Turner

    Sara Turner

    Same issues plus one more

    My supervisor and I noticed this problem as soon as we upgraded to 4.0. When my keyboard starts getting whacked out, I turn on my caps lock key and type with my shift key down. It a pain to have to do but you can type that way.

    The past couple of days I've had a new issue. I try to left click on a window in parallels and parallels is reading it as a right click. I couldn't get out it until I unplugged my keyboard and plugged it back in -- it would not resolve while the keyboard was unplugged but did once it was plugged back in.

    This is really aggravating!
  3. Alain HERVE

    Alain HERVE

    Everything was OK with french keyboard and PD3 on a MacPro, but when switching to PD4 build 3810, I consistently get the following errors, even after full reinstallation:
    Top numeral line : left key in both modes @ -> ² and # -> nothing
    Top numeral line : key 6 in non-Shift mode § -> -
    Top numeral line : key 8 in non-Shift mode ! -> _
    Top numeral line : right key in both modes - -> = and _ -> =
    Upper letter line : right key in Shift mode * -> £
    Middle letter line : right key in both modes ` -> * and £ -> µ
    Lower letter line : right key in both modes = -> ! and + -> §

    I hope all these reported errors are different symptoms of the same error in mapping keyboards!
  4. jwjohnson99

    jwjohnson99 Bit Poster

    I'm still having problems with sticky command key. I've submitted a problem report. I am using the latest build. (3810 with the hotfix).
  5. Chris von Rabenau

    Chris von Rabenau Bit Poster


    Not a fix for the cause of the issue, but I have discovered that pressing the Command (Windows) key repeatedly, until the Start menu opens breaks to stuck key, without leaving the guest or rebooting. Of couse, if your first sign the problem is typing a word that begins with 'L', the level of frustration is hardly reduced. :)
  6. enginpost


    The answer

    OK - sticky keys have been killing me and someone on here suggested that if Ikeep hitting the command [windows] key repeatedly and until the vista/xp menu popped up, then the stuck key issue would be solved. I must have hit it a million times. Then I thought, "Hmm? What if i just click the parallels icon until the vista/xp menu pops up?" I had to click it a couple times and it did and suddenly my stuck key issue was over.

    i thought I would post that here as a possible suggestion. It also might help in debugging the issue. Why wouldn't the menu show up on the first click of the parallels icon. Does that add a symptom to the stack!?

    Thanks for your hints everyone!
  7. grahamb


    sticky keys

    Build : 4.0.3844, Guest OS is Windows XP SP3.

    Same issue here with the sticky keys. When it happens, double tapping ctrl seems to clear it. Problem is it's got a nasty habit of occurring just at the wrong moment.

    Any idea when we're going to see a proper fix for this, rather than the work arounds we have currently?
  8. Sara Turner

    Sara Turner

    Temporary fix

    I have found that when the issue arises, if I hold down command, option, control and escape, the issue resolves temporarily (sometimes minutes, sometimes hours).
  9. BrienT


    Fix for sticky keys issue... I think.

    Folks, I was having the same problem... and it was REALLY pi$$ing me off! Of course, having to use Windoze at all does that to me... I HATE IT.

    Any way, I was looking up a fix and stumbled across an unrelated issue people were having in Windoze about wanting to permanently turn off "Filter Keys".

    The fix for that was to hold down the "Shift" key for 8 seconds while in Windoze.

    On a whim, I tried it. After holding the key down for 8 seconds, my L, E, S, R, and M keys acted normal again. I don't know if the problem will come back, but Windoze is acting normal for now.

    Funny thing is, I have no idea how the sticky keys got turned on in the first place... I have never intentionally held down the "Shift" key for eight seconds before. But, that is what we all know Windoze for... cropping up fun issues to tick us all off and keep the MCSE guys in business.

    GOD love Apple!
  10. Chris von Rabenau

    Chris von Rabenau Bit Poster

    Problem still exists in 5.0

    I continue to have this problem creep up in version 5. Pretty frustrating, as it usually happens, as BrienT describes, 'at the wrong moment'. Clearly, it is a Windoze sticky key issue, but there must be something related to Parallels, as I think the M$ community would be up in arms if it happened as frequently as it does to me. Of course, they seem to put up with a lot of other annoyances, too, so who knows.

    I am going to try BrienT's trick the next time it happens to me, but I can verify my tip of tapping the command key until the Windoze menu shows up does the trick for me.


Share This Page