How to: Resolve trouble between Parallels and Windows under Boot Camp

Discussion in 'Windows Guest OS Discussion' started by bulletproof, Sep 8, 2007.

  1. joevt

    joevt Kilo Poster

    Messages:
    1,210
    Backup and restore are a big hassle and probably not necessary since everything else seems to be working fine.

    I'm not sure what you mean by partition "changes". Do you mean changes to the number, location, or size of partitions or do you mean just changes to the contents (files/folders) of the partition? The contents don't matter to Parallels. Only the size and location of the partitions. NTFS mounts don't affect partition information. They are a part of the OS.

    I would sync the GPT and MBR. The output of the 3 commands will help decide which partition information is correct. Or use the script at http://members.shaw.ca/joevt/dumpvols2.sh.zip which will provide more information (such as boot block information).
     
  2. ViktorE

    ViktorE

    Messages:
    2
    Hello, haven't found the same issue I have also
    I have Boot Camp and Win 7 installed on in , running as VM in PD7
    following the user guide i installed transporter agent on VM and did migration to new VM in order to move it to my new mac.
    After migration finished and it tried to boot it is saying "No boot device found..." and can't boot.
    Do anyone know how to solve this issue? thanks in advance
     
  3. joevt

    joevt Kilo Poster

    Messages:
    1,210
    Use the "Import Boot Camp" option to move Windows 7 from your virtual machine that uses a Boot Camp partition to a new virtual machine that will use a virtual hard disk.
    This was discussed recently at http://forum.parallels.com/showthread.php?t=114291
     
  4. MarinusL

    MarinusL

    Messages:
    1
    Has anyone got Parallels 7 working with Windows 7 and OS X 10.7.2 on a 2011 Mac mini i5-2540M with discrete GPU?

    I am asking because no matter what I do or how I install Windows 7 I get prompted with an error telling me to reboot. If I do not reboot then the virtual machine will hang after a short while. I have logged a support call and get only canned answers and I have the impression that the error log file has not been looked at and that even my emails do not get read properly. At this stage I regard this product as a waste of my time. Grrrr....

    edit: Never mind, my time and the required stability of my system is too valueable to muck about with this. Will use another solution instead. (no faith in that it will ever work consistent and stable)
     
    Last edited: Nov 14, 2011
  5. megavolt17

    megavolt17 Product Expert

    Messages:
    367
    Are you being asked to reboot the Mac, or to restart Windows 7? Do you get any report of an error or anything? Did the Windows 7 install go normally, or is the install when you are being asked to reboot?
     
  6. RenatoJ

    RenatoJ

    Messages:
    5
    Remove trial version without messing with BootCamp

    It is a shame that Parallels didn't warn about the issue with using an existing BootCamp partition and Windows 7 activation when installing the trial version. The instructions make it seem like a seamless process. Well, my BootCamp partition crashed today (now it's yesterday...), I booted into MacOS and tried to repair it through Parallels, when I was asked to activate Windows 7 again. After doing that automatically, blue-screening several times and after an unsuccessfull system restore, Windows came back to life. I rebooted back into BootCamp and after an automatic chkdsk, Windows 7 was being listed as counterfeit. I tried unsuccessfully a system restore one more time. When I went online to MS's site to try to reactivate it, the detection script wouldn't find the Product ID; I went to check it at the Control Panel and it was blank! I was going through several support screen showing my options (none, as my Windows7 Pro is OEM and no ID was being detected) and ran another MS script to repair the activation error (or something alike) while the activation pop-up was frantically coming up. Suddenly the Genuine Software screen came up welcoming me, Windows7 had been activated again. Apparently, everything is back to normal with BootCamp, but I didn't yet reboot.

    Now, if anyone could tell me how to get rid of Parallels trial without touching my existing BootCamp, I would be very glad. Considering I could have lost a lot of data just because of the lack of information on the activation issue (of course, I wouldn't have tried if I knew), I will think twice before trying a future version of Parallels again. I liked the idea, but definitely, it's not ready for prime time, at least not using an existing BootCamp partition, which is the ideal for me.
     
  7. shanjoyb

    shanjoyb

    Messages:
    48
    Having read through this excellent thread, I'm having an issue I still can't figure out...

    I have a Ghosted XP image that we install on our Windows boxes here. This image also works/installs fine -- in bootcamp.

    However, whenever I try to access this bootcamp partition in Parallels (5160), I get the following message on the black screen:

    Windows could not start because of a computer disk hardware configuration problem.


    ________________

    Shanjob [​IMG]
     
  8. iphone747

    iphone747

    Messages:
    1
    Hi@all i am new here,
    last month i downloaded the parallels 7 Trail Version for my MacBook Pro 2011.
    I tried the Bootcamp version for using my existing Windows 7 Partition on my Lion System.
    But this feature was horrible for me! First i had to activate myWindows licence again and later i found out that my AutoCAD Student Version didn't run, because i can't activate it.

    But i can't go back so i reinstalled my Windows Partition and uninstalled Parallels 7 Trail. Now to my Question.
    Is this Error fixed with Parallels 8 or is ist the same Problem? I really like the feature to use 2 Systems at the same time but i also need all my Programms.

    Greatings
     
  9. illinirazorback

    illinirazorback

    Messages:
    2
    I can't seem to find reference to my specific problem, but it's definitely related to Windows in Boot Camp not playing well with others as far as activation. It had been working fine, but then I upgraded the Windows partition in Boot Camp from Home Premium to Ultimate. Now when I start it in Parallels, it wants to reactivate windows and says my copy isn't genuine. Now, there's been endless discussion around here of selecting the telephone option and calling Microsoft to get a code, but Windows doesn't GIVE me that option. It only will let me re-enter my activation code or "go online" to resolve it. The online thing only works about half the time, and gets annoying quickly.

    So with that, I need help. Please fire away. Thanks.
     
  10. ThilinaG

    ThilinaG

    Messages:
    1
    Metro Apps and Windows Store not working

    I was using Windows 8 on my mac's boot camp partition. The apps worked fine and I was able to download any number of apps I wanted.
    Then I tried to create a new virtual machine for using the Boot Camp Windows 8 partition using Parallels Desktop. And everything looked fine when I installed the Parallels Tools in Windows 8 except I can't download any app from the store and most of the metro apps like Mail and Messaging won't open. And for certain programs I get activation issues.
     
  11. ALobban

    ALobban

    Messages:
    6
    You actually got it to install the Windows 8 from the Boot Camp partition!? I get an error when trying to do so from PD8 trial version saying something of the sort "no read/write access."

    Issue Resolved!
    I was unaware that I had a bad install of a previous version of Mac OS before installed Mountain Lion. I went to the apple store and they cleaned it up with a full install of Mountain Lion; came home and after re-registering my Parallels, was able to boot and run from Parallels 8 my BootCamp version of Windows 8.
     
    Last edited: Jan 14, 2013
  12. SubhroP

    SubhroP

    Messages:
    1
    Windows 8 parallel on MAC: Excel opening in separate instances on double click

    Hi,

    I have windows 8 parallel on mac. The problem I am facing is that when I open excel through windows explorer by double clicking, it opens in separate instances. The only way I can open it in the same instance is if I drag and drop new file icon on an open application window or if I open by pressing ctrl+o. I have tried both office 2010 and 2007, but with same results. It is inconvenient operating like this. Please suggest how to get it working right.

    Thanks
     
  13. PatrickP

    PatrickP Bit Poster

    Messages:
    15
    Parallels 8 and Windows 7

    My daughter has Win 7 installed in bootcamp under Mountain Lion. I installed Parallels 8 and everything seemed to be fine until today. When booting into bootcamp today, it first ran chkdisk as it said the volume was dirty, then I got an error that Windows was not genuine and it wants me to purchase it. Same problem when booting into
    Win 7 using Parallels 8 with a virtual machine of the bootcamp install. Her school has a site license for Win 7,, so I hope to get the Windows keys tomorrow. Now for my questions:
    1) What is the best way to set up Win 7? The first item in this thread talked about setting up separate profiles for XP bootcamp and XP parallels. Does Win 7 use profiles as well? If not, is there something I should do to Win 7 under bootcamp so that she can use one or the other? Some professors at her school do not want the students to use Parallels, so I want to give her both alternatives.
    2) Last night she accidentally started Parallels while working on her Mac. She used the bottom button of the Parallels window to stop the startup and then shut it down. Today it is corrupted and no longer has the product keys so that it thinks it is an invalid install. Can stopping a boot corrupt the install that badly or should we be looking for something else? When setting this up I did validate the Win 7 image again after the initial boot of Win 7 under Parallels.
    Thank you
     
  14. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    643
    Hi PatrickP,

    Easy tips on Windows install in a VM can be found at http://kb.parallels.com/4729
    Also I'm not sure why you want to create a new VM - even though Windows asks to be reactivated, you can always call Microsoft and reactivate by phone.

    Try to reinstall Parallels Desktop as suggested here: http://kb.parallels.com/114624
     
  15. LucasW

    LucasW

    Messages:
    1
    Hello - I m having a similar issue. Every time I launch Boot Camp from within Parallels it crashes part way through the booting process. I have tried the suggestions above (except for the registry edit - I am afraid to mess up my windows build) and nothing has worked. It always bombs after it asks for me to activate windows - whether I click yes, no, or not at all. It does not blue screen, it just stops booting, and crashes. I would appreciate any help! Thanks!
     
    Last edited by a moderator: Feb 24, 2013
  16. whywhyh

    whywhyh

    Messages:
    1
    Hi,

    I have two problems with Boot Camp in Parallels 8.
    1. The Boot Camp partition is not mounted in Mac when Parallels is running although I turned on the "Access Windows folders from Mac" and "Mount virtual disks to Mac desktop". How can I access the partition in Mac?
    2. The Boot Camp program icon in Windows taskbar is missing since I installed Parallels. I understand it is hidden when using Parallels to access Boot Camp. But if I boot my Mac into Boot Camp I still can't see the Boot Camp icon since then. Is there any way to bring it back?

    Thanks,
    Ryan
     
  17. manhthang13787

    manhthang13787

    Messages:
    2
    Hello
    Has anyone got Parallels 7 working with Windows 7 and OS X 10.7.2 on a 2011 Mac mini i5-2540M with discrete GPU?
    help me
     
  18. manhthang13787

    manhthang13787

    Messages:
    2
    Parallels 7 working with Windows 7 and OS X 10.7.2 on a 2011 Mac mini i5-2540M

    Hello
    Has anyone got Parallels 7 working with Windows 7 and OS X 10.7.2 on a 2011 Mac mini i5-2540M with discrete GPU?
    help me
     
  19. bfindlay

    bfindlay Bit Poster

    Messages:
    25
    Windows 7 professional constantly asks to be re-activated. If I resolve it in Parallels, then all is fine - until I reboot into Boot Camp. Then it craps out again. Sometimes if I leave it 'not genuine' when I get back to parallels it is still activated, sometimes not. Sometimes it is fine with a quick online check, sometimes with re-entering my product code, sometimes it wants me to go through the time consuming hassle of phone reactivation. Regardless of what I do, I cannot seamlessly move between Boot Camp and Parallels.

    Short of buying a second installation key is there ANY WAY to get this tracking machine to behave?
     

Share This Page