How to: Resolve trouble between Parallels and Windows under Boot Camp

Discussion in 'Windows Virtual Machine' started by bulletproof, Sep 8, 2007.

  1. smarnold

    smarnold Bit poster

    Boot Camp and Parallels working... just! But...

    Just a couple of other variations on this whole thing that maybe someone can help me with.

    I followed the whole conversation after my Boot Camp installation and my Parallels both went down. reset it all up (winXP on a MacBook running Parallels 3.4560(?)).

    I set up the hardware profiles as suggested and very carefully installed Boot Camp drivers in the Boot Camp one and Parallels Tools in the other.

    Now I can get into both but:

    1. As soon as my Boot Camp starts up, it freezes at the Hardware Choice page: possibly not freezes - maybe just the keyboard and trackpad are non-functional. Either way, the only way out is to force power down.

    BUT if I hold down Fn-F8 on startup, I go to the "Safe Mode" page: I choose Normal Windows XP (default), choose my winXP installation, and then it goes to the Hardware Profile page and it works fine - I can choose my Boot Camp profile and all loads great.

    So what is going on here?

    2. When I boot into Parallels, the whole way through the boot process my screen has this huge warning that "Parallels Tools initialisation underway" and don't touch anything or risk data loss"!!! Goes through fine and goes away at the login screen.

    Finally, my Parallels is unable to upgrade to the latest build 5160 - it downloads it and then then hangs.

    Any thoughts team?
  2. Jigs Gaton

    Jigs Gaton Product Expert

    This just rots.

    I went thru all of this with a sigh. Someone has not thought this thru, and it seems there are some very bad incompats between PD and Bootcamp. What's happening is that there are files in the system32 directory that are getting written everytime PD goes into a session. Sometimes they get written, and sometimes they don't fully make it. We have verified this behavior and the simple fix is to have a working backup of the 6 or 7 files that are getting updated and clobbered. Then ya just have replace them and u are good to go, again. forget all that stuff about the registry and reinstalling whatever. Just make sure u have the latest PD and Bootcamp, and u have been able to install the new drivers in windows.

    Another worrisome problem is product activation. Adobe products are failing. Premiere Pro Cs2 requires reactivation every time and Photoshop CS3 occasionally. I am going thru the entire suite now to see what else. Encore 2 seems fine so far but that's as far as I've gotten - a lot of suites to test!

    So if things like hal and other files are getting trashed on boot, and we are dealing with fat32 disks, product reactivations, and crazy time resets, it seems like this will be a disaster from the get go to roll out to poor users. Parallels has some very nice features, but I think we will be moving to VMware for some stability very soon, what else can we do?

    PS. are they every going to give us a firewire driver? And what about that lighted keyboard and reliable audio...but i guess that's apple's gig...o well
    Last edited: Sep 29, 2007
  3. WesGaige

    WesGaige Junior Member


    How does one do this in Vista?
  4. gmorris

    gmorris Junior Member

    Vista Hardware Profiles

    The short answer is that Vista doesn't use hardware profiles in the same way that XP did, so you cannot set up two separate profiles to choose from. Vista does this automatically for you based on what it sees.

    The only thing you can do is mess around with services in vista and set which ones will start and which ones won't under different circumstances.
  5. bulletproof

    bulletproof Member


    The problem that you are having sounds like your hard disk may have some errors on it. I have had the occasional hang, but in windows, never at the hardware profiles screen. I would try to run a chkdsk /r in windows (from the cmd), and check the disk integrity in OS X. The message you are getting with Parallels least it always happens this way for me too.

    Hope this helps!
  6. bulletproof

    bulletproof Member


    Sorry I did not get back to you sooner. I'm not sure if you got your trouble resolved with booting into your Boot Camp Installation through Parallels or not, but thought I would try to help you some anyway.

    The trouble appears to be related to the partition Windows thinks it is installed on under Parallels. Parallels adds an entry to Windows boot.ini file and uses this record when booting into Windows. My guess is that the entry needs to be corrected.

    You will see something like this when viewing it in notepad

    The information "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" is the location WINDOWS is (or should be) installed. You should have one for Boot Camp, and one for Parallels. If the entry is wrong, then you will get the error:

    So, either Parallels botched the boot.ini file during its first boot into your Boot Camp installation, or the correct entry is missing all together. Since you can get into Windows through Boot Camp. I would modify your boot.ini file there.

    All you should have to add (or change) is the entry for "multi(0)disk(0)rdisk(0)partition(x)\WINDOWS="Parallels" /fastdetect /noexecute=optin" Making sure that "multi(0)disk(0)rdisk(0)" is the same as your original Boot Camp entry. The only thing that you will need to change is the number for "partition(x)".

    I know there are also some adjustments for this in Parallels, but am unsure if it will correct this issue for you.

    Here are instructions on how to edit your boot.ini file.

    If you go into your System Properties in the Control Panel, on the Advanced Tab, you will see a Settings button under Startup and Recovery. This is where you can change the default entry, and the time to display the list of operating systems. If you click on Edit, it will open your boot.ini file for direct editing.

    Your Boot Camp entry should be the entry labeled "Microsoft Windows XP Professional" DO NOT CHANGE THE PARAMETERS FOR THIS ENTRY! If you do, you will no longer be able to get into Windows through Boot Camp! You can however correct this through the Recovery Console using the command "bootcfg /rebuild".

    I hope this helps!
    Last edited: Nov 5, 2007
  7. bulletproof

    bulletproof Member

    Thank you gmorris! I updated my original post with this information. Anyone that has any questions about using Hardware Profiles in Vista, please see the link posted by gmorris.
  8. cadement

    cadement Bit poster


    Hi all,

    I'm experience an issue similar to what has been described above but with some key differences:

    I've got a Bootcamp'd load of Windows XP that has been working fine with Parallels for several months. A few days ago I upgraded to Leopard and everything was still fine - XP would load under Parallels no problem.

    But as of yesterday, when I try to load XP under Parallels it fails and tells me that my ntoskrnl.exe file is either missing or corrupt. However! - if I simply reboot and load XP from Bootcamp it loads no problem whatsoever so obviously the file is there and fine.

    Could this be a problem with Leopard? Could it be that the file really is corrupt but in a way that only Parallels notices? I'm stumped! Any guidance would be greatly appreciated.

  9. ofey

    ofey Bit poster

    I've tried your proposal as I am facing the same problem. Though it does nothing except provide another option on the boot up screen so you can actually select one other option besides Windows XP Professional.

    Ideas anyone else?
  10. flysi

    flysi Bit poster


    I'm in the same boat as Casey. I had been using my Boot Camp install of Windows happily with Parallels for months now, and even for about a week after installing Leopard. Then I updated my Parallels install to 5540, and that was when I started getting the above error. Any ideas?

    - Simon
  11. Khoji

    Khoji Member

    My conclusion on accessing the Boot Camp partition in Parallels: Don't do it.

    It's simply not worth the trouble and it doesn't bring you any real benefits. In my case Parallels has completely destroyed three Boot Camp partitions and even when it was working it was much slower and less stable than a normal Parallels virtual machine. In addition to this, Parallels appears to make changes to the Windows installation in Boot Camp and that is by definition a bad thing. The whole reason for creating a Boot Camp partition is to have a real native installation of Windows running directly on your hardware. If you let Parallels mess with that you are threatening the integrity of that system -- at least in my case the Boot Camp Windows installation was always funky after Parallels had touched it.

    Conclusion: If you want to access Windows without leaving OSX then use a real virtual machine. If you want to access Windows directly on the hardware use a real Boot Camp installation and don't allow Parallels anywhere near it. Keep the two things completely separate and you will be much, much happier.
  12. ofey

    ofey Bit poster


    That's a bit harsh. I never do any tweaking/upgrading be it on Mac or on windows without first consulting these forum boards and I've had no problems since doing my fresh install of 10.5.

    Care no doubt has to be taken but it can work.
  13. Khoji

    Khoji Member

    Before my experiences with Parallels and Boot Camp I would have said so too -- but I'm not even on Leopard, I'm still running Tiger and my Boot Camp + Parallels experience has been a complete disaster from beginning to end. It was something I really wanted to like because it would have been very practical, but it just didn't work. It was slow and instable and ended up trashing my Boot Camp partition three times.

    As a result I now have NO Boot Camp partition because I can't recreate it again under Tiger (Boot Camp beta has expired) and I refuse to install Leopard until Parallels releases a Leopard-compatible version that is not a beta. My work depends on Parallels because I work in the Windows software industry, so stability is radically more important to me than any bells and whistles.

    Perhaps you can make it work by jumping through all the many hoops described in this thread but that really shouldn't be necessary. A function that needs that much tweaking isn't ready for public release.
    Last edited: Nov 23, 2007
  14. louden

    louden Bit poster

    Here's my list of problems

    Hardware: MacBookPro C2D 2.33 (Pretty common hardware for Parallels users - I'd assume!)

    Base OS: Mac OS Leopard (10.5.1)
    Guest OS: Windows Vista Ultimate (my Bootcamp image)

    - Can't install Parallels tools - Install can start but upon any reboot, I get a BSOD on prlfs.sys.
    - Network Drivers won't work. I can see them with the bang (!) in Windows Device Manager and an error showing that "there are not enough resources" for the network driver to work... Even after I've disabled sound, CD Rom, and any other non-essenstial Parallels services
    - Video Adapter - Parallels adapter doesn't work - not enough resources
    - Activation - OS is not activated. Why would try to activate this version if nothing works on it?

    Luckily, I haven't hosed by Bootcamp partition...

    Considering I have a C2D with 2GB of memory, I'm not sure why I'm having these problems.

    Anybody else in the same boat?
    Last edited: Nov 24, 2007
  15. Khoji

    Khoji Member

    2GB of memory is only just enough to run Vista, you should have at least 1GB assigned to the Vista virtual machine. But that isn't your problem here. If you insist on trying to run Parallels with Leopard you need the beta version, 5160 often won't work at all. Uninstall Parallels first, then get the beta here:

    After installing the beta reboot your Mac before doing anything else. Parallels doesn't tell you to do this but it's absolutely essential, it won't work properly after installing if you don't.
  16. Kickpoint

    Kickpoint Bit poster

    I have to agree. I finally through in the towel, and dumped the Boot Camp partition in favor of a true VM partition. It was just too much trouble on a regular basis to keep it up and running (Leopard and 5540). It's too bad too, because working in Boot Camp was really the preferred method; with a true windows working environment and 100% of the available RAM and CPU usage to speed things up. However restarting was a hassle, and file sharing a problem, so the VM won.

    I will say that 5540 and Leopard has been great for me when Boot Camp is not in the equation, so kudos to the Dev team for that.

    I am willing to acknowledge that until only recently, Boot Camp was a beta only application and the Parallels team might not have had the best possible opportunity to work out the kinks. However, now that Leopard is out, and Boot Camp is a mainstream app supported by Apple, I would love to see a version of Parallels that fully supports this work flow.
  17. tobrien

    tobrien Bit poster

    Do we know if this resolves licensing issues such as Microsoft Office and Autodesk products? I have been able to activate Windows on both Bootcamp and Parallels independently without the need for the hardware profile. So I don't want to have it permantly showing up everytime if it doesn't fix our problems with Autocad and Office program licensing.

    Any help will be much appreciated.

  18. Kickpoint

    Kickpoint Bit poster

    This procedure helped, but ultimately did not solve the major issues of corrupt or missing .dlls, and constant reactivation of windows and other software due to significant "hardware" modifications and a regular basis. The later I had hoped would go away all together but not so.
  19. Cosby

    Cosby Junior Member

    Parallels Tool issue

    Hi guys, I've installed leopard and update parallels. So when i run parallels i must update parallels tool. But i receive always this error:
    "Parallels Tools require that your Windows is running under Virtual Machine. The installation will be stopped". I'm using a bootcamp partition. I've tryed remove parallels tool manually but i have the same problem while reinstall the tools. If I run my vm in safety mode all work fine, that is that my screen resolution end color is ok but if i run vm in normal mode my screen resolution is 800x600 and use 256 colors. Please help me. I se parallels to work and I NEED IT.

  20. Drone6738WK0612

    Drone6738WK0612 Bit poster

    My problems seems similar to cadement: Everything was working fine for months until parallels (build 5540) crashed during its initialization. I knew I was in trouble as something like this happened to me a few months back. As I feared, XP didn't start in either bootcamp or parallels and gave me the dreaded "...ntoskrnl.exe is missing or corrupted....". Gasp...;-(((

    The file was present in windows\system32 but I figured I would go thru the motion anyway so I followed the instructions supplied at which fixed the bootcamp problem. Bootcamp now starts normally.

    Under parallels however, I still get the ntoskrnl.exe missing error.

    I looked around but I don't seem to find what I need.
    I do not know where to go from here...

    Help anyone?

Share This Page