How to: Resolve trouble between Parallels and Windows under Boot Camp

Discussion in 'Windows Guest OS Discussion' started by bulletproof, Sep 8, 2007.

  1. I-che

    I-che

    Messages:
    493
    Hi Mike,
    thank you for report. Supposedly the problem is with memory allocation to VM. Please try to do the following:
    1. Reinstall Parallels Tools: remove any entry of Parallels Tools from Programs list, restart VM, install Parallels Tools from Virtual Machine menu. Try to start Boot Camp based VM again.
    2. If this did not help, please try to reinstall Parallels Desktop per KB:
    http://kb.parallels.com/en/6904
     
  2. Mike_Meyers

    Mike_Meyers

    Messages:
    4
    After uninstalling the Parallels Tools, the Boot Camp VM took only 2-3 minutes from boot-login-desktop. Booting to the native Boot Camp was still at least 10-11 minutes. When I reinstalled Parallel Tools, the boot to desktop time on the VM went back to around 11 minutes. It seems to me like it is the Parallels Tools that is to fault here, but I could be wrong. I can try uninstalling and reinstalling Parallels one more time, but I don't think that will help.

    Thanks,

    Mike
     
  3. I-che

    I-che

    Messages:
    493
    Hi Mike,
    please try reinstalling PD following Knowledgebase article and let me know the results.
     
  4. Fai Lau

    Fai Lau

    Messages:
    10
    Just how should I activate Windows 7?

    Hi. Just what is the official supported method of activating Windows 7 when one uses the same Windows 7 installation under both Bootcamp and Parallels? I have a Windows 7 Bootcamp installation activated but when I run it using Parallels it complains that hardware has changed and wants me to reactivate it agin. Thanks.
     
  5. MikaA

    MikaA

    Messages:
    1
    BSOD Stop 0x0000007B error - bootcamp Windows 7

    Hi,

    I just recently upgraded Windows Vista to Windows 7. Everything works fine while booted directly to bootcamp instance.

    However, I cannot get into Windows 7 through Parallels - right after displaying "Starting Windows..." the boot crashes with BSOD 0x0000007B error. Same thing happens even if I try to boot in safe mode. I have latest bootcamp drivers (3.1) installed.

    Setup:
    MBP 2.8GHz - 4GB
    Snow Leopard
    Windows 7 bootcamp (upgraded from Vista; 1st removed bootcamp drivers in order get W7 upgrade running)
    Parallels Desktop 5 Build 5.0.9344
    Memory allocated to virtual machine 2048MB, 1 Processor

    I have tried following solutions (proposed on various forums), and always deleted the old VM instance before trying out next procedure:
    Removed Bootcamp drivers from Windows 7 - Created new VM
    Reinstalled Bootcamp drivers - Created new VM
    Installed MacDrive 8 trial (like suggested at http://forum.parallels.com/showthread.php?t=96119) - Created new VM
    Tried booting OSX from Snow Leopard DVD, ran the disk utility to check host disk errors / privileges errors - Created new VM
    Changed boot order for VM - VM instance booted from W7 setup DVD - Windows startup repair ran

    The only thing that I have not tried out (of that I have been able to find for a suggestions) is the registry merge (the fix suggested in this thread for XP BSOD and described in http://support.microsoft.com/kb/314082). Is that the only remedy even if I am running W7 - not XP?

    I have also submitted an error report: ID 5781398

    I am really out of suggestions at this point. I hope this does not mean that I have now useless Parallels 5....

    Any help is welcome!
     
  6. sean lancaster

    sean lancaster

    Messages:
    3
    I've been waiting a few days to even start up Parallels at this point and I had started a new discussion that is being viewed but working its way down the page . . . perhaps I was supposed to post that topic in this discussion here instead? I didn't find the answer in this thread, but this thread seems to be the right place.

    --
    i am going through the hassle of reactivation of Windows 7. i have Boot Camp installed on one of my 4 internal HDs and it's using Windows 7 just fine. i set Parallels 5 up to use my Boot Camp install and it worked fine the first time -- no activation of Windows requested. when i returned to Parallels the next time, i had 2 Windows 7 (Windows 7 & My Boot Camp) listed in my Parallels menu. i wasn't sure which one to use as i am sure i just created 1 Windows 7 VM the very first time i started it up. so i picked one and it wanted me to activate. i quickly shut that one down and tried the other. it again wants me to activate. i suppose i have to call MS and explain, which is fine, but i'd rather figure out which VM i should be using and then delete the other one to avoid future confusion. Does anyone know whether i should be using the plain Windows 7 or the My Boot Camp VM? (if it's any consolation, i believe i named the only VM i made 'Windows 7' and it showed 2 GB of RAM the way i set it up)
     
    Last edited: May 8, 2010
  7. RabiK

    RabiK

    Messages:
    2
    Nice threads going on ... Keep it up guys. I have found similar discussion in ForexTradingEVO .com

    Your discussion is really knowledgeable for me and i solve my problem through your discussion.

    Thank You
     
  8. RabiK

    RabiK

    Messages:
    2
    Nice threads going on ... Keep it up guys. I have found similar discussion in ForexTradingEVO .com

    Your discussion is really knowledgeable for me and i solve my problem through your discussion.

    Thank You
     
  9. mog0

    mog0

    Messages:
    12
    Problems with sound

    Hi
    I've posted a problem elsewhere on the forum and had no response so thought I'd try reposting my problem here to see if I get any luck.

    I have installed Win7 x64 in Bootcamp and got everything working great and then set it up in Parallels desktop so that it could be used either in physical or virtual mode. Unfortunately since installing Parallels tools the sound is almost completely inaudible in bootcamp, even with the windows volume set to 100%. Before installing parallels tools it was absolutely normal.

    On the volume control you can see the green line rising when a sound is played but it will not go above 5% of the way up, again with 100% volume.

    Has anyone else seen this behaviour and more importantly does anyone know of a workaround??

    I've tried uninstalling the sound device in the windows device manager, but the problem remained after windows restarted, detected the sound device and set the device back up. I've also uninstalled parallels tools completely and again this has had no effect.

    The original thread I created is at: http://forum.parallels.com/showthread.php?t=103384

    Thanks
    Scott
     
  10. Digweed

    Digweed

    Messages:
    1
    Can't start Windows 7 - 'SCSI controller not installed'

    Hey All

    I'm really hoping you guys can help me, this is really frustrating and I've spent ages reading around the internet looking for an answer without luck.

    A couple of weeks ago I got a new 17" Macbook Pro and a copy of Windows 7 Ultimate. I installed Windows 7 through Boot Camp and the installation seems to have gone smoothly apart from a problem with the driver for the wireless network card. I have updated windows and installed the Boot Camp 3.1 upgrade.

    I then returned to Mac OS X 10.6.4 and installed Parallels desktop, which I had uninstalled just before I moved from my older Macbook Pro (on which I had been running Windows XP). I was prompted when I began the install to download a newer version of Parallels, which I did.

    When I tried to run Windows 7 through Parallels it initially suggested I increase the amount of memory for the 3D acceleration support, which I increased to 256MB.

    Now, when I try to run Windows 7 I get the following message:

    768MB physical memory is installed

    SCSI controller is not installed
    Network bootrom is installed
    Trying to boot from Primary Master IDE drive ...

    A disk read error occurred
    Press Ctrl+Alt+Delete to restart

    Parallels then freezes. I don't know what to do!

    Thanks for any help you can give!
     
  11. joevt

    joevt Kilo Poster

    Messages:
    1,203
    Make sure the disk is selected correctly in Parallels Desktop -> Configure -> Hardware -> Hard Disk 1. If there's more than one partition for Windows 7 then make sure they're all selected by clicking the Edit Partitions button (which is not visible when there's only one Boot Camp partition).

    Use the following commands to check your partition information:
    Code:
    diskutil list
    sudo gpt -r show /dev/disk0
    sudo gpt -r show -l /dev/disk0
    sudo fdisk /dev/rdisk0
    
    gpt dumps the GUID partition table used by Mac OS X. fdisk dumps the MBR partition table used by Windows. The MBR partition table should contain an entry for the Windows 7 partition which matches the corresponding entry in the gpt. The entry in the MBR should also be flagged as active.
     
  12. kendellrt

    kendellrt

    Messages:
    4
    Not completely true!

    This is not completely true. I have Win 7 x64 installed on an NTFS BC partition. PD 5 will not work with this partition, it won't even mount!

    I can't get Transporter to migrate the BC partition successfully, either. I have a trouble ticket #973116, for reference. I boot into Win 7 under BC run the Transporter. After booting back into 10.6, I run transporter again, exactly as outlined. When that is all finished and PD 5 begins to config the new VM it stops while booting and says there is "no boot device available..." I have done it several times now, and I'm pretty upset with the situation. What can I do? I bought PD 5 specifically so that I didn't need to setup Windows again as it is supposed to function via the BC partition or migrate over to a VM.
     
  13. joevt

    joevt Kilo Poster

    Messages:
    1,203
    I installed Windows 7 32 bit and Windows 7 64 bit today into Boot Camp and they both work in Parallels Desktop.

    I installed them on my /dev/disk3 disk:
    Code:
    JoeMacPro:~ joevt$ diskutil list /dev/disk3
    /dev/disk3
       #:                       TYPE NAME                 SIZE
       0:      GUID_partition_scheme                     *1.0 TB
       1:                        EFI                      209.7 MB
       2:       Microsoft Basic Data                      21.3 GB
       3:       Microsoft Basic Data Windows 7 32         75.2 GB
       4:       Microsoft Basic Data Windows 7 64         76.0 GB
       5:                  Apple_HFS Classic              42.9 GB
       6:                  Apple_HFS Misc4                107.4 GB
       7:                  Apple_HFS Multimedia           322.1 GB
       8:                 Linux Swap                      32.2 GB
       9:                  Apple_HFS Big                  322.1 GB
    JoeMacPro:~ joevt$ sudo gpt -r show /dev/disk3
    ...
    JoeMacPro:~ joevt$ sudo gpt -r show -l /dev/disk3
    gpt show: /dev/disk3: Suspicious MBR at sector 0
           start        size  index  contents
               0           1         MBR
               1           1         Pri GPT header
               2          32         Pri GPT table
              34           6         
              40      409600      1  GPT part - "EFI"
          409640   209715200      6  GPT part - "Misc4"
       210124840      262144         
       210386984    62914560      8  GPT part - "Ubuntu Swap"
       273301544    41680896      2  GPT part - "Ubuntu"
       314982440      262144         
       315244584   629145600      7  GPT part - "Multimedia"
       944390184      262144         
       944652328   629145600      9  GPT part - "Big"
      1573797928      262144         
      1574060072    83886080      5  GPT part - "Classic"
      1657946152      262144         
      1658208296   146800633      3  GPT part - "Windows 7 32"
      1805008929           7         
      1805008936   148516193      4  GPT part - "Windows 7 64"
      1953525129           6         
      1953525135          32         Sec GPT table
      1953525167           1         Sec GPT header
    JoeMacPro:~ joevt$ sudo fdisk /dev/rdisk3
    Disk: /dev/rdisk3	geometry: 121601/255/63
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------
     1: EE    0   0   2 - 1023  59  47 [         1 -  273301543] 
    *2: 07 1023  59  48 - 1023 191  17 [ 273301544 -   41680896]
     3: 07 1023 176  39 - 1023 155  24 [1658208296 -  146800633]
     4: 07 1023 155  32 - 1023  80  24 [1805008936 -  148516193]
    
    Before you add a Boot Camp Windows installation to a Parallels Desktop virtual machine, do the following:

    1) Make sure it has a boot folder and bootmgr. If it doesn't, then run EasyBCD to create a BCD and then you need to setup a default boot entry for Windows 7. Note Windows XP uses NTLDR and boot.ini, not bootmgr and boot folder which are used by Windows Vista and Windows 7.
    2) Make sure the partition is flagged as active because Parallels does not have an option to do that for you. This is only necessary if you use something like rEFIt which modifies the active partition flag everytime you boot and you have more than one legacy OS on the same disk. In the fdisk output above, partition 2 is active but Windows 7 32 bit is on partition 3 so I did the following:
    Code:
    JoeMacPro:~ joevt$ sudo fdisk -e /dev/rdisk3
    fdisk: could not open MBR file /usr/standalone/i386/boot0
    Enter 'help' for information
    fdisk: 1> f 3
    Partition 3 marked active.
    fdisk:*1> quit
    Writing current MBR to disk.
    Device could not be accessed exclusively.
    A reboot will be needed for changes to take effect. OK? [n] y
    
    You don't need to reboot after using fdisk. Then I created the Windows 7 32 virtual machine by selecting partition 3 on disk 3. When Parallels Desktop finished setting it up and installing Parallels Tools, I shut it down and started to add a Windows 7 64 virtual machine. First I had to set the active partition to partition 4:
    Code:
    JoeMacPro:~ joevt$ sudo fdisk -e /dev/rdisk3
    Password:
    fdisk: could not open MBR file /usr/standalone/i386/boot0
    Enter 'help' for information
    fdisk: 1> f 4
    Partition 4 marked active.
    fdisk:*1> quit
    Writing current MBR to disk.
    Device could not be accessed exclusively.
    A reboot will be needed for changes to take effect. OK? [n] y
    JoeMacPro:~ joevt$ sudo fdisk -e /dev/rdisk3
    
    Then I created a Windows 7 64 virtual machine in Parallels Desktop by selecting partition 4 on disk3.
     
  14. HassaanA

    HassaanA

    Messages:
    3
    I have a legit W7 installed on Boot Camp. Today I installed Parallels running W7 from my Boot Camp installation. Currently, I am requested to buy a new key for W7 before three days.

    Should I buy it, or have I done something wrong?
     
  15. joevt

    joevt Kilo Poster

    Messages:
    1,203
    Do you know if it was an OEM version or a normal retail version of W7?

    You should only need to activate Windows twice - once in Boot Camp and again after Parallels Tools are installed in Parallels Desktop.
     
  16. HassaanA

    HassaanA

    Messages:
    3
    It is a retain version. In Boot Camp it has been activated a couple of months ago. Yesterday I installed Parallels and tried activating W7. It did tell me my version is authentic but didn't accept to activate it without buying a new key.
     
  17. joevt

    joevt Kilo Poster

    Messages:
    1,203
    To check activation, right click Computer in the Start menu and select Properties. Windows activation status is displayed at the bottom of the window.

    Did you install Parallels Tools before activating in Parallels Desktop? Are you using Parallels Desktop 5?

    I didn't have any problems activating in both Boot Camp and Parallels. Maybe I'm using a different version (Windows 7 Professional).

    You may need to call Microsoft for activation if automatic activation isn't working.
     
  18. HassaanA

    HassaanA

    Messages:
    3
    1) It says two days until automatic activation. Once I try to do it myself, it requires a new key.
    2) Parallel desktop was activated, I clicked them on My Boot Camp that installed automatically W7 then I tried activating W7.
    3) It is W7 Professional & Parallels Desktop 5
    4) I'd rather buy another key than to waste time calling Microsoft. But the question would two keys work or would I have conflicts?

    seriously the complains on the net about this matter are endless. Just try to Google it and you'll see for yourself! If this is the case, then Parallels Desktop would be useless!
     
  19. P N RR

    P N RR

    Messages:
    1
    I have bought a Macbook Pro and installed Windows 7-32 Bit under Boot Camp. Now I want to install Parallel and open Windows in Mac. Can you suggest which version of Parallel's I should use and what is the installation and configuration process. Thanks
     
  20. ImSeeker

    ImSeeker Bit Poster

    Messages:
    34
    I'm very close - can you get me past one problem.

    I successfully installed Windows 7 Home Premium 64bit in Bootcamp on my Macbook Pro 6.2 i7 machine. (That would be an entire article on the hassles to do so, but I did it!) Even got Bootcamp 3.1 drivers and NVidia video and wireless working.

    In fact, it was SO good, that I even have a disk drive when Windows Bootcamp boots that POINTS TO The Macintosh HD! That totally surprised me, but I find that the latest bootcamp supports this (no more macdrive software needed!)

    I then successfully created a VM in Parallels 6 that accesses bootcamp. Again, everything seems fine, EXCEPT, I periodically get:

    Unable to access hard disk 1

    at the top of my screen. Anyone know how to eliminate that?

    Here is my SUSPICION: When opening windows 7 with parallels, the bootcamp windows 7 shows a hard disk e:, which would match the Macintosh HD when running in Bootcamp. But if you click on this in Parallels, it not surprisingly says "needs formatting" (can't access your own drive?). What scares the bejeebers out of me is that Parallels/Windows now offers to FORMAT THIS DISK! (I would hope it doesn't work if I said yes.... but I'm certainly not going to try!)

    I THINK this the hard disk 1 it cannot access; but I like having it if I boot in bootcamp, but would like it to not be there when Parallels runs. Given bootcamp now supports this, I'd THINK that everyone would be having this problem, but I only find old reports about it.

    Any thoughts or help? I got past most everything else - last step, I hope!
     

Share This Page