How to stop document icons on Mac opening Parallels?

Discussion in 'Windows Guest OS Discussion' started by drooth, Dec 12, 2008.

  1. drooth

    drooth

    Messages:
    2
    I've been using Parallels for some time now and it's an invaluable part of my work regime. But there is one thing that drives me crazy and crashes my machine.

    I _never_ want to click on a document file that is on my Mac and for parallels to then open to try to run the Windows app that shows that document. And I mean never.

    I run XP and Vista and Linux under Parallels but I keep getting documents (e.g. .swf) that then get registered to Windows under the Mac. I can't keep going through and fixing every association and even when there is no Mac association I don't want Windows to open.

    Why? Because I have Parallels open already and it then opens another version of Vista, locks up and my Mac crashes meaning I have lost all work in both my Mac apps and my Windows apps.

    Is there any way to tell Parallels to never associate icons from the Mac to Windows.

    Here's hoping there some way of switching this off globally.

    Thanks all.
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    In Vista VM windows - Configure - Shared Applications- and clear Share Windows Applications with Mac OS
    Also right click on Vista VM pvm file - Show Package Contents and delete folder Windows Applications
     
  3. drooth

    drooth

    Messages:
    2
    Thanks.

    I'll try this out. It was driving me crazy. :)

    I think Parallels is a great product and rave about it to friends. This is the only trouble I have ever had with it and hopefully this will fix everything I need.

    Thanks.
     
  4. mkstevo

    mkstevo

    Messages:
    40
    Thank you, this did eventually work for me. I say eventually, as I didn't realise that I would have to delete the 'Windows Applications' folder from (all) my backup of my Parallels 'disks' which are stored on disks attached (permanently) by USB as well.

    Is it not an idea to firstly, provide an option to do this automatically when the 'Share Windows Applications' check box is cleared, and secondly, to flag up a message pointing out that backed up disks require this operation carrying out before the icons will revert to their original Mac states?

    Surely it would save some confusion?

    The file associations causing Parallels to open (and show incorrect icons on the Mac) was driving me demented. When I am working on the Mac, I want to work on the Mac, if I want to open a Windows file, I will start Parallels and work on it there. I don't want to find that if I accidentally click on a Windows file on the Mac, I have to wait while Parallels starts, while it starts Windows then while Windows starts the associated program, all this has to take place before I can close them all down again, and go back to what I was doing on the Mac, just because I accidentally clicked one icon!
     
  5. TamlinM

    TamlinM

    Messages:
    1
    Layman's terms?

    Can someone state a step-by-step direction for this? I'm having trouble because I do not know how to locate anything to do this "Vista VM windows - Configure - Shared Applications- and clear Share Windows Applications with Mac OS". Where do I find "Vista VM windows"? Actually - I'm running Windows 7 but I think it should be similar. Or similarly (http://forum.parallels.com/showthread.php?t=87840&highlight=stop+icon+launching+parallels) I cannot find an "actions tab". I found the "snapshop manager" but there was nothing there. And I'm not sure how to "stop your VM, then go to Edit->Virtual Machine... menu item. Select "Shared Applications" group, and disable 'Share Windows Applications to Mac'".

    These all seem to be the same directions but with no.. directions. Please help. It's all mostly my fault by clicking things I know are Windows applications on accident (instead of 'right clicking' and opening in something for Mac) but it is beyond annoying to have my computer freeze for 10 minutes while parallels launches Windows for a document I didn't really need opened in Windows.
     

Share This Page