How to stop top bar popping up in Windows

Discussion in 'Windows Virtual Machine' started by DanH5, Jan 4, 2017.

  1. DanH5

    DanH5 Bit poster

    Messages:
    6
    I am running Windows 10 fullscreen in Parallels Desktop 12 for Mac on a MacBook Pro. Whenever I move the mouse to the very top of the window in Windows, the Mac toolbar appears with the parallels options. How do I stop this from happening? I heard that you can stop it by requiring a password to exit fullscreen, but I don't want to do this as I frequently swipe (triple finger gesture) between the Windows and Mac desktops.
     
    AlexA4 likes this.
  2. AlexA4

    AlexA4 Member

    Messages:
    23
    I'd also like to know how to at least configure it so that the mouse needs to be held for more than a second for the MacOS bar to appear. It shouldn't just pop out instantly.
     
  3. DanH5

    DanH5 Bit poster

    Messages:
    6
    Yeah, it keeps popping up when I try and access the menu bar on a Windows program in Parallels. Can anyone help here?
     
    AlexA4 likes this.
  4. AlexA4

    AlexA4 Member

    Messages:
    23
    It wasn't like this in PD 11, something changed when it went to v12.
     
  5. DanH5

    DanH5 Bit poster

    Messages:
    6
    I don't understand how this can be possible, as it makes Windows unusable and defeats the purpose of Parallels. Surely we are missing something? Can one of the mods/devs comment please?
     
  6. MeyerJ

    MeyerJ Junior Member

    Messages:
    17
    Go to configuration menu of the virtual machine, register tab "hardware", section "mouse&keyboard", activate for "mouse" the option "optimized for games" and deactivate "mouse sticks at border" (I don't know if these texts in english are correct, because I am working with the german version).
     
  7. DanH5

    DanH5 Bit poster

    Messages:
    6
    Thanks for your input - those options were already selected.
     
  8. MeyerJ

    MeyerJ Junior Member

    Messages:
    17
    Strange - works for me on iMac 27" with MacOS Sierra 10.12.2 and Parallels Desktop Version 12.1.1 (41491) and on MacBook 12" with MacOS Sierra 10.12.2 and Parallels Desktop Version 12.1.2 (41525) ...
     
  9. DanH5

    DanH5 Bit poster

    Messages:
    6
    Doesn't work for me! Still keen on any ideas...
     
  10. MeyerJ

    MeyerJ Junior Member

    Messages:
    17
    Try the following: click anywhere into the desktop ara of your windows virtual machine. Press and hold down <ctrl> while additionally pressing <alt>: the shape of the mouse cursor changes to the shape of the MacOS cursor. Now click again into the desktop area of your Windows virtual machine: the Cursor shape changes back to the windows shape and the popping up of the MacOS bar on the top border of the sreen should not occur.
    I hope this helps ...
     
  11. DanH5

    DanH5 Bit poster

    Messages:
    6
    Meyerj - that might just have done the trick! I'll see how it goes. Many thanks!!
     
  12. Maria@Parallels

    Maria@Parallels Problem solver

    Messages:
    8,123
    Hi, please try VM configurations -> Options -> full screen -> untick "activate screen corners"
     
  13. AlexA4

    AlexA4 Member

    Messages:
    23
    That worked! Do I have to do that every time I restart the VM?
     
  14. Maria@Parallels

    Maria@Parallels Problem solver

    Messages:
    8,123
    No, it should be saved.
    You can check it and let us know if you need to perform these steps every time.
    Thanks for sharing the results by the way.
     
  15. AlexA4

    AlexA4 Member

    Messages:
    23
    There is no such option in PD 12.
     
  16. Maria@Parallels

    Maria@Parallels Problem solver

    Messages:
    8,123
    Ok, got you.
    So, did you resolve the issue?
     
  17. AlexA4

    AlexA4 Member

    Messages:
    23
    I can confirm that after restarting the VM the tip still works for preventing macOS elements from appearing immediately on mouse pointer hitting the edges. They only appear after 2-3 seconds.
     
  18. DavidH15

    DavidH15 Bit poster

    Messages:
    4
    170413 Parallels full screen error.png Not working for me and I'm also at a loss, I get the above in Parallels/Windows 10 full screen when I move the trackpad or mouse to the top of the screen despite having chosen the below settings. Seems to be recent introduction.
    Just to be clear (like the other posters), I ONLY want three finger slide to move me between macOS and Windows, and when in Windows I don't want ANY macOS windows, popups, alerts, docks or menus showing up.
    It would be highly beneficial and much easier for all these settings to be moved into one place in Parallels.
    • /parallels/configure/options/fullscreen both 'use all displays in full screen' and 'optimize full screen for games' are ticked ('activating virtual machine shows all its spaces' is not)
    • /parallels/configure/hardware/mouse & keyboard I've chosen 'optimize for games' which unticks 'mouse pointer sticks at window edges' and 'smooth scrolling' is ticked
    Any suggestions.?
     
  19. MeyerJ

    MeyerJ Junior Member

    Messages:
    17
    As you can see from my preceding post in this thread I had the same problems with the MacOS pop up at the top of the screen. Your post caused me to check the settings of my virtual Windows 10 machine. I found ONE DIFFERENCE: for me "Mouse pointer sticks at window edges" was activated.

    After disableing this option I have now no problems anymore. In fullscreen mode I now can move the mouse of my Windows 10 machine anywhere on the screen without any popups from MacOS. Attached to this post you find screenshots of the software releases I use and the Parallels settings of my Windows 10 ('Win10_1703_German_x32', creators update) virtual machine.
     

    Attached Files:

  20. DavidH15

    DavidH15 Bit poster

    Messages:
    4
    OK great, thanks @MeyerJ very helpful, have now ticked and will see how it goes. However one last very annoying item, there seems to be an imaginary Mac toolbar at the very top of the screen which if I grab it it moves the whole Windows desktop (screen) actually like a window within macOS. I've highlighted the area in the below pic, I've placed notepad there to more easily demonstrate the area, because when I try and move notepad away it 'grabs' the whole desktop (need to move the mouse one pixel below the very top of the screen - your mouse setting tip worked for that thx). This also needs a method of disabling because its exceedingly annoying, although I don't have the faintest clue where to start.
    Parallels error.png
     

Share This Page