How to type accented characters on a physical keyboard?

Discussion in 'Parallels Client for Android' started by J.H.Z, Sep 4, 2021.

  1. J.H.Z

    J.H.Z Bit Poster

    Messages:
    4
    Your Android RDP client works great, except for one thing: typing accented characters, like á and ä. The Windows client makes this possible with the US-International keyboard by pressing Ctrl + ' or " and then typing a, resulting in á or ä. How to achieve this in the Android client? Setting the Android keyboard setting to US-International doesn't work. With another RDP client (from Xtralogic) this works for á, but not for ä. Any thoughts on this?
     
  2. Eugene. K.

    Eugene. K. Parallels Team

    Messages:
    124
    Do you use the standard android keyboard in Parallels Client? I'm asking because we have a PC-keyboard mode that replaces the OS keyboard with ours.
     
  3. J.H.Z

    J.H.Z Bit Poster

    Messages:
    4
    I do. When I enable PC keyboard mode, every character I type is shown twice. Lliikkee tthhiiss. And in that mode typing accented characters is also not possible.
     
  4. J.H.Z

    J.H.Z Bit Poster

    Messages:
    4
    I found out the problem is related to Microsoft Swiftkey. Whenever that keyboard app is enabled as the current input method in the Android settings, typing accented characters (and sometimes pressing backspace) doesn't work well in the Parallels Client. But when enabling Gboard for example, everything is fine. Any idea how to fix the incompatibility with Swiftkey?
     
  5. J.H.Z

    J.H.Z Bit Poster

    Messages:
    4
    Dear team, any updates on this issue regarding the use of Microsoft Swiftkey in combination with your client?
     
  6. jpc

    jpc Kilo Poster

    Messages:
    342
    @J.H.Z From what I can understand, you are using a physical keyboard connected to an Android device. It is general helpful to indicate which device is being used, its Android OS version, what type of keyboard is being used and the version of Parallels client in use.

    As @Eugene. K. mentioned, it is advisable to use the PC keyboard layout when using a physical keyboard. In your case, it seems that this does not work correctly.

    As a self-fix first step, I would suggest to confirm that you check that the RDSH has the correct keyboard layout (US International) when connected. Secondly, try to use AltGr or Ctrl+Alt (keys for this layout: https://web.cortland.edu/ponterior/keyboard/).
    If you are using the US International keyboard layout, you should be able to use the "dead keys" functionality (where you type " ' " followed by " a " to get " á "). The "dead keys" functionality might break backspace sometimes, since "dead keys", once pressed, can not be cancelled with a backspace (need to press "space").

    If the above does not help, you could also try to report the issue directly to the official Parallels support and provide the OS/device/etc information.
     

Share This Page