How to use my CD-ROM drive?

Discussion in 'Parallels Workstation for Windows and Linux' started by Richard Fish, Oct 5, 2006.

  1. Richard Fish

    Richard Fish Bit poster

    I have parallels 2.2.2072 installed on Gentoo linux. My physical PATA CD-ROM drive goes through the SATA chipset, so it appears as a SCSI drive, at /dev/sr0. The option to "Use a physical CD/DVD-ROM drive" is disabled, despite the fact that my user is a member of the cdrom group, there is a symlink from /dev/cdrom to /dev/sr0, and my user has no problems reading from the CD.

    Any ideas on how I can use this drive with parallels?
  2. Richard Fish

    Richard Fish Bit poster

    Never mind. I hacked the .pvs file to change the image= to /dev/cdrom and media= to 1, and it worked fine. Thanks to parallels for making the configuration file plain text!! :)
  3. constant

    constant Forum Maven

    Try creating a symlink to /dev/hdc instead.
  4. soldidude

    soldidude Bit poster

    This worked.

    Parallels crew - this has been an absolute pain in the behind and YOU HAVE TO BE KIDDING ME that this is the fix.

    I have searched for hours. Only thing I can find from your documentations is the user must have privs to access the cd-rom and to chmod /dev/cdrom - c'mon! Ridiculous.

    There is obviously a bug- fix it!

    BTW - as a paying customer, it would be great for you to answer emails to support. I have sent 2 on a couple other issues and it has been months w/no reply.

  5. idauto-john

    idauto-john Bit poster

    Thanks so much

    As usual, the forums come through when parallels just absolutely fails.

    I got a call and an e-mail from a parallels sales guy today. I may have to call him back and let him know they won't be getting any more of my money until they do something about their support.

Share This Page