I shot myself in the foot

Discussion in 'Windows Guest OS Discussion' started by RobK9, Nov 5, 2022.

  1. RobK9

    RobK9

    Messages:
    3
    I had a licensed copy of Windows 11 on my licensed copy of Parallels Desktop.
    I responded to a link in Windows 11 offering to upgrade itself.
    The upgrade got stalled upon a Windows restart. I watched a black screen with a "spinner" icon for several days. I tried restarting the VM, but it just returned to the same state.
    Finally, out of frustration, I told Parallels Desktop to delete my Windows 11 VM but not to delete the files.
    Then I created a new Windows 11 VM, during which process Parallels Desktop downloaded the installation files from Microsoft and installed them.
    After I got the new Windows 11 VM running, I saw that I had to "activate" it and I couldn't find the activation code that I had used in my deleted Windows 11 VM.
    I am hoping either:
    • To restore my deleted (but files not removed) Windows 11 VM; or
    • To locate the Windows registry files for my deleted Windows 11 VM, so I can extract the activation code from it.
    So far, Parallels Support hasn't been very helpful. (But if they ever come through with something useful, I'll be sure to post it here.)
    Thanks.
     
  2. RobK9

    RobK9

    Messages:
    3
    Well, I located my "deleted" Windows VM. Started it. It's still stuck in "upgrading" mode. Now all I have to do is figure out how to get it out of that mode.
     
  3. RobK9

    RobK9

    Messages:
    3
    And I figured out how to force Windows to shut down. Hold the Option key while choosing Actions, Stop in the Parallels Desktop menu.
    Then I restarted Windows and (Surprise!) it start up normally.
    Phew, I guess I dodged that bullet after all.
    Thanks for reading!
     
  4. Bhargava@Parallels

    Bhargava@Parallels Staff Member

    Messages:
    302
    Thank you. Please let us know if you have any additional questions.
     
  5. Willis43

    Willis43 Bit Poster

    Messages:
    5
    Thank you! I was struggling with the black screen and spinning circle without any success. Restarting Windows or even restarting my MacBook Pro wouldn't solve the problem as the black screen and spinning circle would resume after startup. Your suggestion above about using the 'Option' key and Parallels > Actions > Stop fixed it immediately for me.

    Thank you for posting your solution!
     

Share This Page