I want to get to the Internet. Is that so much to ask?

Discussion in 'Parallels Desktop for Mac' started by johnaskins, Sep 30, 2006.

  1. johnaskins

    johnaskins

    Messages:
    6
    I've slogged through build after build of Parallels, hoping to get to one that would actually work to get me on the Internet from my Mac Pro. It never works. I've turned on Internet Sharing and Personal Web Sharing in OS X and I've got the right adapter on the bridged Ethernet and I can't choose Host-Only Networking because it's grayed out. My Mac is connected to the Internet via a DSL router and Safari is working fine. I'm not asking for advice or help; I just wanted to say that if you're lucky or bright enough to have it working, congratulations. On behalf of the rest of us, and I know we are legion, I hope the development team figures out a way to make Internet access easy and workable by the time Parallels graduates from beta. Between now and then, I ain't screwing with it no more. My guess is that Crossover is going to be able to do this for me and I won't even think about Parallels again, but who knows?

    Just wanted to get that off my chest.
     
  2. BenInBlack

    BenInBlack

    Messages:
    372
    Do you have a DHCP server on your router? If So turn it on
     
  3. n4khq

    n4khq

    Messages:
    81
    Parallels works great for internet access. I have never had a problem and from the post, very few have a problem getting internet access. My guess is you DSL router (DSL modem with a router?) is not supplying a second IP number. The only other possibility is your settings in parallels
     
    Last edited: Sep 30, 2006
  4. MarkHolbrook

    MarkHolbrook

    Messages:
    350
    That works best for me in Parallels. I have a MBP and I setup Parallels to get it's own IP address from DHCP. It works perfectly at home and at work.

    M
     
  5. robinchee

    robinchee

    Messages:
    11
    I had the same problem with my iMac core 2. Turns out I did not install the Parallel Tools, which installs the necessary network drivers and thus enabling your network access, which is needed for internet access.
     
  6. johntm1

    johntm1

    Messages:
    5
    Internet

    I'm running Guest XP on a Macbook Pro with a wired cable modem.
    The only way I've found to connect from XP is: Open a terminal for OSX and enter ifconfig. Note the en0 ether address (6 pairs of numbers seperated by colons). Enter this address into the MAC
    address with the Guest configuration editor, minus the colons. Now
    launch XP and see if it connects. It worked for me, but I can't
    connect with OSX w/o closing the Guest.
     
  7. Aliturus

    Aliturus

    Messages:
    1
    The Parallels Internet Blues -- am I right?

    Having silently shared the frustrations of the many who can't get internet via Parallels, and who have received no help on this from the otherwise helpful support team, I thought I should share what seems to be the best (not happy) solution for those who have a similar setup to mine (high-speed cable modem from home via dominant ISP in my area, southern Ontario in Canada).
    1. When I couldn't get an IP address while running Windows XP Pro as guest OS, I installed a Linux OS (Ubuntu) with excellent click-by-click instructions for installation under Parallels. If I could get the internet with Linux, that would confirm that it was a WIndows problem (as my prejudices made me willing to believe). But, no joy with Linux either, in spite of detailed suggestions on that site for internet troubleshooting. So it is a more general problem -- given my standard setup -- with running any guest OS in Parallels.
    2. A couple of observations from other members of this group (e.g., that the guest OSs work with wireless hub but not on a fixed connection, or in an office LAN environment with freely available DHCP assignments but not at home, and a suggestion about fooling the guest OS by giving it the same MAC/hardware address as the Mac), combined with long conversations with my ISP support team, lead me to conclude what was probably obvious to some experts all along, but wasn't to me.
    3. Namely, the guest OS (contrary to my expectation) does not take over the ethernet-hardware address of the Mac. In my case, Windows and Linux each produces its own ethernet address. An obvious problem, then: since the Macintel's ethernet address has already monopolized the DHCP assignment, and since the ISP offer only one IP address per home customer (and claim indignantly that this is standard practice among providers), the other OSs have no chance of getting internet access under Parallels, with a cable modem. It's that simple.
    4. Unless: (i) I use a router (wireless or hardwired), which itself distributes DHCP addresses to different hardware addresses from the one signal coming in; (ii) purchase from the ISP a second IP address (@$10/mo.); or (iii) as someone already suggested, tell the guest OS that my MAC address for that system is the same as my OSX, though in that case use of the internet in the guest system would knock out its use in OSX, which would return only on closing the guest OS.
    5. I'd be willing to try (iii), but -- pardon my ingorance -- I don't understand how to force the guest OS to accept a new MAC address. Can anyone help? As far as I can see, although I can add DNS information, etc., to a network setup panel, the MAC address is given by the system.
    6. Finally, if what I (a non-techie, obviously) have concluded is basically accurate, it seems both straightforward and surely an extremely common problem. If it is common, why don't the people from Parallels mention it as a fairly serious limitation on the featured internet access via the guest OS?
     
  8. fmantek

    fmantek

    Messages:
    6
    I am sorry, but i do not see how this is Parallels problem at all. You would be in the same scenario if you bought a 2nd PC, if i understand this scenario correctly. If your ISP only gives you one IP address, than, to enable more than one PC, you need to setup NAT over a hardware router preferably. Those routers these days go for less than paralells cost you.

    And i would not use a software solution for this anyway if i would be in your shoes. Get a little router box, and be happy afterwards.

    Frank
     
  9. lmhaffner

    lmhaffner

    Messages:
    19
    If you really want to try this, shut down your guest OS and open the "Network Adapter" option for your virtual machine configuration. Choose the "Advanced" pane and enter the MAC address of your Mac interface. This is really not a great idea. There's no guarantee which OS is going to process a packet since they're both listening for the same ethernet address.

    If you end up purchasing a second IP number from your provider, you can hardwire a MAC address here (that you'd make up) in the same manner so that your Mac and guest OS's have different IP numbers.

    However a router that does NAT is the best solution for most simple network setups. Your Mac can do this, which is what OS X's Internet sharing combined with the "Host-only" networking option in Parallels does. But using "Bridged ethernet" and an external router will put your guest OS on the same "footing" as your Mac. Many DSL modems have a NAT option with DHCP built in nowadays, although you might have to turn it on by connecting to the router--typically through a special website address. Check the documentation for your modem or with your provider.

    Well, as the poster above mentioned, this is a general problem for any setup where you have one outside internet address available to use and multiple machines. Networking is still not very "plug-and-play" friendly outside of the OS, so the most they can do is provide a number of options for you to try depending on your setup. I think they've done a good job of that, personally.
     
  10. donnie

    donnie

    Messages:
    28
    I have the standard/usual cable modem connected directly to my iMac with no router. Host-only mode in Parallels works fine for me (with the proviso that I have to reboot after every new Parallels Build comes out).
     

Share This Page