import prlsdkapi fails

Discussion in 'Installation and Configuration' started by LynnO, Nov 11, 2011.

  1. LynnO

    LynnO

    Messages:
    28
    I haven't run my build tools for a while, and Parallels was updated to 7.0.15050 in the interim. When I load the build script, written in Python, it fails to import prlsdkapi. I tried uninstalling version 7.0.14922.693916 of the Parallels Virtualization SDK and installing the current version, 7.0.15050.797095, but the the import still fails.

    The installation created the folder:
    /Library/Frameworks/ParallelsVirtualizationSDK.framework/Versions/6/Libraries/Python/2.7/prlsdkapi

    But it does not appear that anything was installed into the default site-packages, even though the folder was touched (perhaps during the uninstall?).

    Any ideas on how to get this working again?
     
  2. Specimen

    Specimen Product Expert

    Messages:
    3,244
    That folder appears to be for version 6 of Parallels?
     
  3. LynnO

    LynnO

    Messages:
    28
    I saw that, but that is what the latest download of the SDK installs.
     
  4. PianistH

    PianistH

    Messages:
    1
    The same thing is happening to me, can't seem to figure out a solution.
     
    Last edited by a moderator: Nov 13, 2011
  5. LynnO

    LynnO

    Messages:
    28
    I find prlsdkapi in:
    It is an alias that points to:
    The target doesn't exist.

    When I get to:
    Libraries is an alias that points to:
    which contains only libprl_sdk.4.dylib on my system.

    Can someone from Parallels check the distributable ParallelsVirtualizationSDK-7.0.15050.707095.dmg to see if it contains the correct version and installs?

    I submitted a problem report (11163711) on this today.
     
    Last edited: Nov 13, 2011
  6. DirkS25

    DirkS25 Bit Poster

    Messages:
    2
    Any news here ?
     

Share This Page