Incorrect line ending conversion

Discussion in 'Windows Guest OS Discussion' started by Smudge2, Apr 25, 2013.

  1. Smudge2

    Smudge2

    Messages:
    37
    When copying and pasting text between the Mac host and the Windows 7 guest, the line endings are not converting properly.
    Just for some background info, here are the different types of line endings
    CR format which was used in Classic Mac OS 9 but is not common anymore.
    LF format which is used in OSX and other Unix/Linux systems
    CRLF format which is used in Windows systems


    [TABLE="class: grid, width: 500, align: left"]
    [TR]
    [TD]Source on Mac[/TD]
    [TD]Copy to Windows[/TD]
    [TD]Source on Windows[/TD]
    [TD]Copy to Mac[/TD]
    [/TR]
    [TR]
    [TD]CR[/TD]
    [TD]CRLF[/TD]
    [TD]CR[/TD]
    [TD]CR *3[/TD]
    [/TR]
    [TR]
    [TD]LF[/TD]
    [TD]CRLF[/TD]
    [TD]LF[/TD]
    [TD]LF[/TD]
    [/TR]
    [TR]
    [TD]CRLF[/TD]
    [TD]CRLFCRLF *1[/TD]
    [TD]CRLF[/TD]
    [TD]CR *2[/TD]
    [/TR]
    [/TABLE]


    As you can see, there are 2 incorrect conversions happening here, with a 3rd possible.
    1. The copy from Mac to Windows is converting the CR and LF properly but when it pastes the CRLF, it is converting both bytes individually and ending up with double CRLFs.
    2. The copy from Windows to Mac is stripping off the LF from the CRLF. This would have been correct back on OS9 but in OSX, the correct method would be to strip off the CR.
    3. Since the standard on OSX is LF, the CR to CR should really be CR to LF. This is already happening from the Mac to Windows attempting to make the line endings the Windows standard CRLF format.

    If I copy/paste between applications on each OS, they are not converted. Only when I'm going between Mac and Windows does this conversion happen.

    I've looked all over for any kind of setting but couldn't find one specifically for EOL conversion. Perhaps there is a hidden setting I can change in the preferences plist file?
    The closest setting is the "Preserve text formatting" option in the VM Config > Options > Advanced screen. I've tried it both ways and neither changed/fixed this issue.
    FYI, that option means to copy as either plain text or Rich Text (RTF) but both options have the line endings converted incorrectly.

    I've submitted this issue to support (ticket #1638661) but I'm just hoping that someone knows how to resolve this as I'm sure this will take support a while to fix and release. It would suck to have to wait until v9 in the fall for this fix.

    App: Parallels Desktop 8 for Mac, Build 8.0.18483 (Revision 860857)
    Host: MacBook Pro (Late 2011), OS X 10.8.3, 16GB RAM
    VM: Windows 7 Enterprise SP1 64bit, 3GB RAM
     
    Last edited: Apr 25, 2013
  2. beta_amadeusexmachina

    beta_amadeusexmachina Bit Poster

    Messages:
    1
    I have this same problem constantly. I work with files in my Mac host using the Windows CF+LF newline convention. When I copy this text and paste it into Windows in Parallels, every newline is doubled. I assume Parallels is converting each CR or LF into a separate CR+LF.
    I would love a VM setting in Parallels to disable newline conversion.

    App: Parallels Desktop 9 for Mac, 9.0.24229, Revision 991745
    Host: MacBook Pro Retina Mid 2012, OS X 10.9.3
    VM: Windows 7 Pro N SP1 64bit
     

Share This Page