Increase size of macOS guest vm on Apple Silicon

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by ImadB, Sep 24, 2023.

  1. ImadB

    ImadB Bit poster

    Messages:
    1
    Has anyone been able to increase the size of a MacOS vm on Apple Silicon? There is no UI for it and it's currently not officially supported by Parallels. Has anyone been able to successfully do this manually?
     
    ParallelsU591 likes this.
  2. Trishna Oobeyram

    Trishna Oobeyram Staff Member

    Messages:
    275
    Best Answer
    Hello @ImadB,
    Unfortunately, once the virtual machine is created, the disk size cannot be changed.
    However, you may change the disk size during the installation process.
    You can find more information in the 'Advanced installation' section in this article.
    Regards,
     
  3. JiriV2

    JiriV2 Bit poster

    Messages:
    2
    Hi, the process described in the article mention above didn't work for me. I have Parallels Desktop for Mac pro Edition Version 19.2.0 (54827)
    version 19. Has anything changed? It's unusable with 60GB HD!
    Thanks,
    Jiri
     
  4. ParallelsU591

    ParallelsU591 Junior Member

    Messages:
    10
    I have the same problem. There's no access to settings, I've exhausted the built-in disk size and need more. On Create New, once I select the IPSW it just starts up the VM immediately.
    On UTM, which is free software, going a similar route presents me with machine config:
    upload_2023-12-14_15-45-23.png

    upload_2023-12-14_15-46-8.png

    I would expect a commercial product to give me at least that.
     
  5. ChristopherB33

    ChristopherB33 Bit poster

    Messages:
    2
  6. JiriV2

    JiriV2 Bit poster

    Messages:
    2
    I've finally managed to resize the image this way:
    Follow the instructions from the article, but instead of truncating the file named disk0.img, apply the truncate command to the file whose name looks like harddisk.hdd.0.{some GUID} and which is located in the harddisk.hdd subfolder of the VM's folder. Find out the exact name of the file by typing ls harddisk.hdd when in the VM's folder.

    Note: I was unable to restore Sonoma ipsw on Ventura. I had to download Ventura ipsw. So, major versions of the current macOS and of the macOS being restored should probably match.

    Jiri
     

    Attached Files:

  7. ChristopherB33

    ChristopherB33 Bit poster

    Messages:
    2
    As a followup.
    1) Lastnight I tried reverting to Parallels 18, added the VM and then "upgraded" to Parallels 19. That worked.

    2) Following your suggestion, this morning I tried using Parallels 19, immediately after creating the VM, I only saw the two config files when viewing the package contents. So I started the VM, waited for the "hello" and then powered off before proceeding. There I saw the disk0.img and used the truncate.

    A) Downloaded IPSW file
    In terminal
    B)prlctl create "macOS2" -o macos --restore-image /Users/YOURUSERNAME/Downloads/UniversalMac_14.2.1_23C71_Restore.ipsw
    C)Started VM using Control Center, powering off after "hello"
    again in terminal
    E)cd /Users/YOURUSERNAME/Parallels/macOS.macvm
    to view disk name typed
    ls <return>
    truncate -s 250G disk0.img

    Worked for me.

    Would be nice if Parallels had a simpler command line they show for
    "Install macOS VM in Parallels Desktop 18 and earlier"

    Again thank you for your guidance
     

Share This Page