Infinite reboot after installing updates

Discussion in 'Installation and Configuration' started by DonghyunK, May 8, 2016.

  1. DonghyunK

    DonghyunK Bit Poster

    After installing the updates of Parallels tools, It keeps requesting to reboot to complete the installation.
    However, after trying dozen times with rebooting whole mac book pro and manually shut down and reopen the parallel tools,
    It is still not working. And the screen pops up to reboot the windows.
    Please help me out.
    MatthiasE5 likes this.
  2. DonghyunK

    DonghyunK Bit Poster

    Report ID: 98740781
  3. Arunn

    Arunn Parallels Support

    Hi DonghyunK, follow the steps below:
    1. Disable all services from Windows startup. (Click Start and type msconfig into the search box or press Win key+R to show the Run dialog and type msconfig. Go to the Services tab and put a tick in the "Hide all Microsoft services" box at the bottom left before hitting Disable all. )
    2. Disable Firewall in Windows.
    3. Install Parallels Tools manually and check how it goes.
  4. DonghyunK

    DonghyunK Bit Poster

    It does not work.
    Why does it happpen every time updating your software?
    MatthiasE5 likes this.
  5. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Hi, On the Mac side, open Activity Monitor from /Applications/Utilities/
    Find Parallels VM and, in Parallels Desktop 10, the process name is the virtual machine's name:
    Select this process and quit it by clicking on 'Force Quit' option.
    Restart the virtual machine and check if you are able to boot it successfully.
    If the issue still persists you may want to reboot your Mac.
  6. MatthiasE5

    MatthiasE5 Kilo Poster

    Some feedback (Parallels 18 / Win 11 ARM Pro / M1 MBA Monterey):
    what EVENTUALLY worked was this:
    - got the paralells tools installation "loop".
    - rebooted windows
    - shut down windows
    - rebooted mac (once)
    - rebooted windows SEVERAL times
    it is important that you see parallels tools installation go all the way up to 100% during windows restart (black screen, white font). you may want to activate verbose startup/reboot information in windows (not necessary though).
    - generally speaking, installation of parallels tools does not work very reliably, parallels needs to look closer into this. in particular, there should be a link to a help file for troubleshooting if the reboot message box keeps reappearing. it's not a nice user experience to be fearful of every parallels update because of parallels tools update.
  7. MatthiasE5

    MatthiasE5 Kilo Poster

    To everybody reading this thread: Note that the earlier postings are from 2016.
    Note that ARM may need the ARM version of Parallels Tools.
  8. MatthiasE5

    MatthiasE5 Kilo Poster

    I managed to get P Tools installed by following the instructions. However starting the software from the mounted CD drive showed no immediate effect (nothing happened, so I don't know if this was even a necessary step). It might be that the disabling of Windows Firerwall AND/OR the disabling of services and then rebooting might have triggered the ability to install Tools. It might be related to some other installed service. Please report the services that are running (minus Windows services) when you encounter a similar issue.
    In particular, I also followed the instructions to force quit the VM. I think this comes with some risk and you should not do that. It also did not help and is probably bad advice.
  9. MatthiasE5

    MatthiasE5 Kilo Poster

    It might have been that (?) that disabling services and then installing via the MENU worked.

  10. MatthiasE5

    MatthiasE5 Kilo Poster

    2023 June, Problem persists. Below description of problem and full solution.

    1. Shut Down Windows.
    2. Close Control Center.
    3. Parallels Menu : Update -> Yes
    4. After Update, Windows VM will show up.
    5. I boot Windows VM.
    6. Tools need to be updated dialogue appears. I restart Windows from that dialogue.
    7. Dialogue shows up again.
    8. I click Restart again.
    9. A black screen showing that Tools are being installed is shown, but apparantely only till 15%, and very quick.
    10. After reboot, dialouge shows up again (!).
    11. Another manual reboot, dialogue still shows up claining Parallels Tools need to be installed
    12. I run MSCONFIG
    13. I disable all services except MS services (use the option to hide MS) and except Parallels services (PTInstall shows as disabled already)
    14. Does not help.
    15. I disable all services except MS.
    16. Reboot.
    17. I disable Firewall by going to system configuration (classic windows sysconfig, not the new settings), then Win Defender Firewall, then Disable both private and public.
    18.1 I follow these instructions:
    18.2 For ARM (!!!) I connect via Menu -> Devices -> CD -> PRL-TOOLS-WIN-ARM.ISO (if you do this for the first time, you first need to find the file as described at 18.1 in the link, and connect the image (same menu (devices->CD->connect image -> "In the Open window navigate to Applications > Parallels Desktop > Contents > Resources --> choose the approriate ISO for your version of windows (or other virtualized OS) (!!WIN ARM if you have ARM / Apple Silicon!) )))
    18.3 Start Windows File Explorer.
    18.4 Navigate to This PC
    18.5. Click Paralels Tools Drive
    18.6. Double Click PTAgent.exe. If it does not work, start as Administrator (right click)
    18.7 Top left the white small box will appear, and IN THAT WHITE BOX (!) (not on a black full screen) you will see installation progress of Parallels Tools. Shortly before it reaches 100%, the Screen might go black with pixel artifacts for a second or two, as if the system crashed. Don't worry, it will go back to normal and then install up to 100% and the white box will turn green.
    19. Reboot the system.
    20. Double-Click the Firewall tray icon in system tray.
    21. Enable Firewall.
    22. Run MSCONFIG. NOTE: It is NORMAL if in GENERAL, user-defined is always activated. Don't worry about this, everything's fine.
    23. Go to MSCONFIG->Services. Hide MS Services. Enable all services that are shown now. (unless of course there are services of yours that you don't want to start).
    24. Reboot Windows.
    25. DONE.

    Don't ask me why Parallels is not capable of doing this by itself.

Share This Page