Infinite reboot after installing updates

Discussion in 'Installation and Configuration of Parallels Desktop' started by DonghyunK, May 8, 2016.

  1. DonghyunK

    DonghyunK Bit poster

    Messages:
    5
    After installing the updates of Parallels tools, It keeps requesting to reboot to complete the installation.
    However, after trying dozen times with rebooting whole mac book pro and manually shut down and reopen the parallel tools,
    It is still not working. And the screen pops up to reboot the windows.
    Please help me out.
    Thanks.
     
    MatthiasE5 likes this.
  2. DonghyunK

    DonghyunK Bit poster

    Messages:
    5
    Report ID: 98740781
     
  3. Arunn

    Arunn Parallels Support

    Messages:
    300
    Hi DonghyunK, follow the steps below:
    1. Disable all services from Windows startup. (Click Start and type msconfig into the search box or press Win key+R to show the Run dialog and type msconfig. Go to the Services tab and put a tick in the "Hide all Microsoft services" box at the bottom left before hitting Disable all. )
    2. Disable Firewall in Windows.
    3. Install Parallels Tools manually and check how it goes.
     
  4. DonghyunK

    DonghyunK Bit poster

    Messages:
    5
    It does not work.
    Why does it happpen every time updating your software?
     
    MatthiasE5 likes this.
  5. PaulChristopher@Parallels

    PaulChristopher@Parallels Product Expert Staff Member

    Messages:
    3,150
    Hi, On the Mac side, open Activity Monitor from /Applications/Utilities/
    Find Parallels VM and, in Parallels Desktop 10, the process name is the virtual machine's name:
    Select this process and quit it by clicking on 'Force Quit' option.
    Restart the virtual machine and check if you are able to boot it successfully.
    If the issue still persists you may want to reboot your Mac.
     
  6. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    Some feedback (Parallels 18 / Win 11 ARM Pro / M1 MBA Monterey):
    what EVENTUALLY worked was this:
    - got the paralells tools installation "loop".
    - rebooted windows
    - shut down windows
    - rebooted mac (once)
    - rebooted windows SEVERAL times
    it is important that you see parallels tools installation go all the way up to 100% during windows restart (black screen, white font). you may want to activate verbose startup/reboot information in windows (not necessary though).
    - generally speaking, installation of parallels tools does not work very reliably, parallels needs to look closer into this. in particular, there should be a link to a help file for troubleshooting if the reboot message box keeps reappearing. it's not a nice user experience to be fearful of every parallels update because of parallels tools update.
     
  7. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    To everybody reading this thread: Note that the earlier postings are from 2016.
    Note that ARM may need the ARM version of Parallels Tools.
     
  8. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    I managed to get P Tools installed by following the instructions. However starting the software from the mounted CD drive showed no immediate effect (nothing happened, so I don't know if this was even a necessary step). It might be that the disabling of Windows Firerwall AND/OR the disabling of services and then rebooting might have triggered the ability to install Tools. It might be related to some other installed service. Please report the services that are running (minus Windows services) when you encounter a similar issue.
    In particular, I also followed the instructions to force quit the VM. I think this comes with some risk and you should not do that. It also did not help and is probably bad advice.
     
  9. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    It might have been that (?) that disabling services and then installing via the MENU worked.

    I CANNOT STRESS ENOUGH THAT PARALLELS NEEDS TO ADDRESS THIS RECURRING ISSUE PLEASE.
     
  10. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    2023 June, Problem persists. Below description of problem and full solution.

    1. Shut Down Windows.
    2. Close Control Center.
    3. Parallels Menu : Update -> Yes
    4. After Update, Windows VM will show up.
    5. I boot Windows VM.
    6. Tools need to be updated dialogue appears. I restart Windows from that dialogue.
    7. Dialogue shows up again.
    8. I click Restart again.
    9. A black screen showing that Tools are being installed is shown, but apparantely only till 15%, and very quick.
    10. After reboot, dialouge shows up again (!).
    11. Another manual reboot, dialogue still shows up claining Parallels Tools need to be installed
    12. I run MSCONFIG
    13. I disable all services except MS services (use the option to hide MS) and except Parallels services (PTInstall shows as disabled already)
    14. Does not help.
    15. I disable all services except MS.
    16. Reboot.
    17. I disable Firewall by going to system configuration (classic windows sysconfig, not the new settings), then Win Defender Firewall, then Disable both private and public.
    18.1 I follow these instructions: https://web.archive.org/web/20230320231257/https://kb.parallels.com/112609
    18.2 For ARM (!!!) I connect via Menu -> Devices -> CD -> PRL-TOOLS-WIN-ARM.ISO (if you do this for the first time, you first need to find the file as described at 18.1 in the link, and connect the image (same menu (devices->CD->connect image -> "In the Open window navigate to Applications > Parallels Desktop > Contents > Resources --> choose the approriate ISO for your version of windows (or other virtualized OS) (!!WIN ARM if you have ARM / Apple Silicon!) )))
    18.3 Start Windows File Explorer.
    18.4 Navigate to This PC
    18.5. Click Paralels Tools Drive
    18.6. Double Click PTAgent.exe. If it does not work, start as Administrator (right click)
    18.7 Top left the white small box will appear, and IN THAT WHITE BOX (!) (not on a black full screen) you will see installation progress of Parallels Tools. Shortly before it reaches 100%, the Screen might go black with pixel artifacts for a second or two, as if the system crashed. Don't worry, it will go back to normal and then install up to 100% and the white box will turn green.
    19. Reboot the system.
    20. Double-Click the Firewall tray icon in system tray.
    21. Enable Firewall.
    22. Run MSCONFIG. NOTE: It is NORMAL if in GENERAL, user-defined is always activated. Don't worry about this, everything's fine.
    23. Go to MSCONFIG->Services. Hide MS Services. Enable all services that are shown now. (unless of course there are services of yours that you don't want to start).
    24. Reboot Windows.
    25. DONE.

    Don't ask me why Parallels is not capable of doing this by itself.
     
  11. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    it might be that rebooting after step 17 works. (i did clickt ptagent.exe before, but nothing happened after that. Aside from that I didn't do anything else at that point).
     
  12. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    Updating to Parallels 19.0.0: First reboot fails for P.Tools. Second reboot works.
    Updating to Parallels 19.0.1: It NEVER works. I can see when rebooting that it says "installing P Tools... 15%" but then this gets cut off. I can reproduce this. What is going on here!!!
     
  13. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    UPDATE:
    It worked after step 17: I.e., disabling all services except MS services and Parallels services (but PTInstall remaining disabled), AND disabling firewall made it possible to installe Parallels Tools. Next time I will try to narrow down exactly which service it is that causes this issue.
     
  14. MatthiasE5

    MatthiasE5 Hunter

    Messages:
    146
    I was now able to identify AllSync Scheduler Service as the reason for the blocking of Paralells Tools installation upon reboot.
    I am going to report the issue to the developer. (AllSync is excellent software otherwise, and has good support).
    After disabling the AllSync Service, upon first reboot, Parallels Tools started installation, but for some reason STILL aborted aber 20%. After the next reboot, it then went to full 100% installation.
    I re-enabled the AllSync Service after the installation of Parallels Tools.
    I have encountered issues with services of other programs too, causing long delays when shutting down. These delays were exclusive to Windows ARM on Parallels. I contacted the developer of that other software (I am not going to disclose the name but if Paralells engineers want to know I will gladly disclose). That developer was able to fix the issue with the delay.
    In other words, for some specific reason, some services seem to cause issues by either blocking Parallels Tools from installing, or by delaying the shutdown process.

    I hope this is of use to other users.

    TLDR: When Paralells Tools won't install, first thing to try is: go to msconfig, disable all services except MS services (use the option to hide MS) and except Parallels services (PTInstall shows as disabled already). Take note of services that are permanently disabled. Then reboot, if it does not work immediately try again at least once. When successfull, re-enable the services that you disabled (but not those that had already been permanently disabled, if any of these exist). If this does not help, please consider reporting what happend, in this forum.
     

Share This Page