Install Parallels Tools on Pop!_OS 22.04 LTS Virtual Machine (Parallels Version 19.0.0 (54570))

Discussion in 'Linux Virtual Machine' started by harkants, Sep 20, 2023.

  1. harkants

    harkants Bit poster

    I always got an error while installing Parallels Tools on Pop!_OS 22.04 installed over Parallels version 19.0.0. When the Parallels team was contacted I was told Pop!_OS kernel is not supported and that they did not have an ETA for resolution. So poured over the installation log and came up with the following conclusion -

    log file -
    Wed Sep 20 22:41:10 IST 2023
    Start installation or upgrade of Guest Tools
    warning: the compiler differs from the one used to build the kernel
      The kernel was built by: x86_64-linux-gnu-gcc-12 (Ubuntu 12.3.0-1ubuntu1~22.04) 12.3.0
      You are using:           cc (Ubuntu 11.4.0-1ubuntu1~22.04) 11.4.0
    cc: error: unrecognized command-line option '-ftrivial-auto-var-init=zero'
    make[3]: *** [scripts/ /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.o] Error 1
    make[2]: *** [Makefile:2038: /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg] Error 2
    make[1]: *** [Makefile:44: prl_tg] Error 2
    make: *** [Makefile.kmods:48: compile] Error 2
    Error: could not build kernel modules
    modprobe: FATAL: Module prl_tg not found in directory /lib/modules/6.4.6-76060406-generic
    modprobe: FATAL: Module prl_tg not found in directory /lib/modules/6.4.6-76060406-generic
    Error: failed to install Parallels Guest Tools!
    2023-09-20T22:41:11+0530: execCmd: ./install --install [167]
    2023-09-20T22:41:11+0530: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2023-09-20T22:41:16+0530: Exiting with code 1
    Examining the gcc installations in Pop!_OS I found that both "x86_64-linux-gnu-gcc-12 (Ubuntu 12.3.0-1ubuntu1~22.04) 12.3.0" and "gcc (Ubuntu 11.4.0-1ubuntu1~22.04) 11.4.0" were installed and symlink "/usr/bin/gcc" pointed to "/usr/bin/gcc-11".
    Changed the links to point to gcc-12 ->
    cd /usr/bin
    sudo ln -sf gcc-12 gcc
    sudo ln -sf gcc-ar-12 gcc-ar
    sudo ln -sf gcc-nm-12 gcc-nm
    sudo ln -sf gcc-ranlib-12 gcc-ranlib
    sudo rm /usr/lib/parallels-tools
    sudo rm /var/lib/parallel-tools
    cd /media/harkantsingh/Parallels Tools       #the mount directory of pro-tools-lin.iso
    sudo ./install
    It just worked.
    Pramesh Boodadoo and MatthewR20 like this.
  2. SergioM12

    SergioM12 Bit poster

    You are a life saver! This worked flawlessly for me. Thank you!
    harkants likes this.

Share This Page