Installing FTDI USB Driver issues

Discussion in 'Windows Virtual Machine' started by PaulR43, Jan 11, 2024.

  1. PaulR43

    PaulR43 Bit poster

    Messages:
    1
    Hello,

    I am running Parallels Desktop, on an M2 Mac Studio, but having problems with a USB device.
    The USB lead is a USB programming cable with an FTDI chipset.
    When the device is plugged in, I can see it connected as 'FT231X USB ART UART', however, when I open up the Device Manager, it is listed under 'Other Devices' with a warning icon next to it. When I go into the Properties, it tells me that the drivers are not installed.

    I have downloaded the correct drivers, however, when I try to find them by using the 'Update Driver' button, it can not find them.

    I contacted FTDI who told me....
    "The device driver files must be on Local disk (C:), as seen by Windows.
    The desktop shown in the home window of Parallels is actually the same as the Mac desktop. Windows apps and files run from here, but the device driver files must be located on the "actual" PC.


    However, as it's a Virtual Machine it's not something that FTDI usually support.

    We're only offering our ARM64 driver as we have heard that other customers got this working on Mac running Windows 10/11 on Parallels. We don't have access to this type of setup."

    I have tried all I can think of to install and locate the drivers, but to no avail.

    Is there anyone who might have had the same issue, or might be able to help?

    Thanks
    Paul
     
  2. 楊家泓

    楊家泓 Bit poster

    Messages:
    2
    I have the same issue with FT231X USB ART UART on M1 Macbook Pro
     
  3. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    345
    Hi Paul, 楊家泓,

    Have you tried disabling the Mirroring function and then attempting to reinstall the drivers?

    Please try this:

    1. Start Parallels Desktop.
    2. Shut down the Virtual Machine. Make sure that the virtual machine is shut down. If it is in a suspended state, please run it and then shut it down (Actions > Shut Down).
    3. Click on the Parallels icon in the Mac menu bar > Control Center > Right-click on the virtual machine > Configure.
    4. Click Options and select Sharing.
    5. Uncheck "Mirror Mac and Windows user folders".
    6. Start the Windows Virtual machine.
    7. Download the installation file once again.
    8. Run the setup file and attempt the installation.
     
    StevenC24 likes this.
  4. 楊家泓

    楊家泓 Bit poster

    Messages:
    2
    Hi,
    I tried following the above method, but it didn't work either.
    Thanks for your advice.
     
  5. StevenC24

    StevenC24

    Messages:
    1
    This worked for me. Thank you so much. Just download the ARM version and had to do the manual download. Worked like a charm.
     
    Adeboye Adeotan likes this.

Share This Page