Installing Programs on the Parallel PC

Discussion in 'General Questions' started by Elbot, Jun 24, 2007.

  1. Elbot

    Elbot

    Messages:
    4
    I have installed Parallels Desktop, and while I have been able to use everything that comes with it (ie Internet Explorer, Solitaire) I cannot seem to install programs. I have attempted to install the games "Painkiller" and "Warcraft III." In both cases, the installation is complete, but I am unable to open the program. In the case of "Painkiller", I am prompted to insert the correct CD (there are 3 CDs in the game) but I get the same message no matter what CD I insert. "Warcraft III" gets stuck on the loading screen and will not open.
     
  2. SanJoseBen

    SanJoseBen

    Messages:
    21
    Only Parallels 3 has 3d acceleration support. It must be enabled in the config screen for the VM in order to work. Warcraft 3 is supposed to work according to Parallels, but Painkiller isn't on their list, but may work. Also, Warcraft 3 is a mac game as well and should be on the CD. I don't know if it works in Rosetta but if it does, it'd probably run better than in parallels.

    Good Luck.
     
  3. Elbot

    Elbot

    Messages:
    4
    Thanks. This is a silly question, but how can I tell which version of Parallels I have? I used the "Get Info" function, but nowhere did it give a number. The closest I could find was when I opened it, and it said winxp2, which I suppose would mean I have Parallels 2. Would this be the case?

    Also I know Warcraft 3 is dual-compatible. I was just using it as a test to see if a less advanced game would work. Thanks for the tip though.
     
  4. hudlee

    hudlee

    Messages:
    1
    To find out what version of parallels your running goto about paralells desktop in the paralells desktop menu.

    Warcraft III (aka Warcraft 3 for the search engines out there) hung at the loading screen for me under parallels (Build 4128). Than I patched warcraft to version 1.21 and it worked

    http://www.blizzard.com/support/?id=mwr0738p

    Whether Warcraft 3 runs better natively or not is irrelevant. The point is a game on the list of tested games should work. I didn't even want to play warcraft I just installed it as my first test of parallels 3d support. Parallels is quite amazing really but the 3d support kind of reminds of when I tried winex when it was brand new.

    http://www.parallels.com/products/desktop/3d/
    It would be nice if the list of tested games (is there a better list?) included the version of the game that was tested. I assume when they tested warcraft 3 they installed the expansion before they tried opening it or something.
     

Share This Page