Installing Windows 98 SE

Discussion in 'Windows Guest OS Discussion' started by gemillam, Apr 7, 2006.

  1. terrymac

    terrymac

    Messages:
    5
    And Another Thing

    Can anyone give me some hints in getting the Windows 98SE VM to recognise a flash memory stick?

    I have istalled the necessary Flash memory manager, when I insert the stick and click Devices-USB I find the Flash Memory with a check beside it but it does not show in windows explorer. It is not recognised by the Mac either.
     
  2. kuliand

    kuliand

    Messages:
    1
    ok im having trouble finding the cd, i type CD D: or CD E: but it goes straight back to A: in dos?

    i still can't get my cd to work everything i type just gets me no where. I have been trying DIR E: and DIR F: but it say there is not enough memory so i guess it still isn't finding the cd drive?
     
    Last edited: Oct 6, 2007
  3. ehurtley

    ehurtley

    Messages:
    47
    In old-fashioned DOS, you change to another drive by just typing its drive letter with a colon.

    So to change to drive D, you don't type "CD D:", you just type "D:"

    Also, I'll also chime in that Windows CDs have been bootable for a very long time. I have a 95b that is bootable, and my 95a might even be bootable, too.
     
  4. For all people TRYING to access their shared parallels folder in Windows 98 that they probably already set up for windows XP - the following worked for me:

    Adding a New Share
    Open Terminal and type
    sudo pico /etc/smb.conf
    If you're prompted for your user password, enter it.

    You should now see the contents of your smb.conf file, complete with the [global] and [homes] sections described above, as well as some sample sections for [public] and [printers].

    Give yourself some space after the [homes] section by moving the cursor below it and pressing the enter key a few times. Now type in exactly what appears below:


    [shared]
    comment = Shared Directory
    path = /Users/Shared
    read only = no
    browseable = yes
    create mode = 755

    Once you've entered these changes, press Ctrl+O and then enter to save the file, then press Ctrl+X to quit.

    To verify that your changes were saved successfully, use the command cat /etc/smb.conf and read through to be sure everything is there.

    Now the changes don't immediately take effect. To make Samba aware of the changes, use the command in terminal
    sudo killall -HUP smbd

    This will tell the Samba daemon to reload its configuration information.

    Logged into Windows 98
    Click on My computer or anything that will get you the address bar.
    Type in
    \\your ip address or your mac's computer name \shared
    In my case I typed in:
    \\192.168.1.102\shared

    And voila, you should be able to see your shared parallels file now (or if you didn't have a parallels folder on the mac side you can create one.)

    The resource I used to get this is:
    http://www.oreillynet.com/pub/a/mac/2003/03/18/samba.html

    There's some additional information there about settings and security if you are trying to accomplish something similar but different.
     
  5. rowbearto

    rowbearto

    Messages:
    6
    Comprehensive How To Guide for Installing Windows 98 In Parallels

    There is a comprehensive step by step guide for installing Windows 98 in Parallels 3.0 which can be found here:

    http://robsnotebook.com/parallels_win98
     
  6. corvettejrw

    corvettejrw

    Messages:
    2
    Anyone fix the screen resolution issue in Windows 98?

    It is driving me crazy staring at a 640x480 screen in windows 98!

    Any fixes on the horizon?
    jrw
     
  7. jbh001

    jbh001

    Messages:
    87
    Windows 98 video fix

    This work-around was posted months ago. Do you know how to use the "search" fuction in these forums?
     
  8. corvettejrw

    corvettejrw

    Messages:
    2
    Thanks for the info. I have never heard of this thing you call "search." I will be sure to look it up in the dictionary when I finish this post.

    Thanks again.
     
  9. justinhoward

    justinhoward

    Messages:
    4
    Dear Parallels Team

    I am so wanting to be able to install Windows 95 and Windows 98 on my new MacBook Pro 2.2 gHz laptop.

    I am running Mac OSX 10.4.11:

    System Version: Mac OS X 10.4.11 (8S2167)
    Kernel Version: Darwin 8.11.1
    Boot Volume: Macintosh HD

    The problem is that I reach a point in the install where I receive an error message:

    ERROR SU-0013
    Setup could not create files on your startup drive and cannot setup Windows.

    If you have HPFS or Windows NT file system, you must create an MSDOS boot partition. If you have LANtastic server or Supersto compresssion, disable it befor running Setup. See SETUP.TXT on Setup Disk 1 or the Windows CDROM.


    I have tried every possible method to install Window 95 onto my laptop. The floppy disk emulator that comes with Parallels does not seem to work. I have tried every possible fdd suggested on the various forums and still nothing works.

    I have tried following the method as suggested in the manual that accompanies the install disk of Parallels. I have updated the software and still no joy. I am getting so frustrated trying to get this to work.

    I have created .img files of the win95 install disk and that did not work. I had the very bright idea of copying all the files from the win95 install disk to the virtual harddrive of win95 and no joy

    When Win95 starts it checks the disk and starts the install process and stops with the error message above

    Am I doing something wrong?

    I would really love to be able to fix this problem and be able to help others that afre having the same problem, to me it just seems so overly complicated to have to do something, other than that problem I have not problems with the software.

    I was able to solve my UBUNTU install problem, took a while but once I solved it all went well, same with WinXP I installed and was able to load and play C&C Red Alert2 with no problems.

    Would it be to much to ask if you could assist me in someway with a workaround solution to solving this problem

    Many Thanks for a a great software solution

    Justin Howard justin.howard@absamail.co.za
    South Africa
     
  10. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Hello justinhoward,

    Did you see this article?

    Best regards,
    Xenos
     
  11. justinhoward

    justinhoward

    Messages:
    4
    Hi Xenos

    Yees I did read the article. As my per my previous post, I have tried everything, formatting, fdisking. Reducing the size of the harddrive to 512Mb. Using every type of .fdd I could find. The setup crashes at the point just after accepting the license agreement.

    What is a puzzle to me is why the .fdd supplied does not work? Would it not be possible for Parallels to supply as standard a working .fdd?

    If I could get the various operating systems to work I would be very willing to add to my wiki all the solutions that I have used. I am so disappointed that although the book says win95 works under Parallels, I cannot get it to work. As per my first posting I got Ubuntu 7.10 and Win XP Home to work under Parallels without a problem.

    Why is it so difficult to get a "simpler" operating system to work?

    Thanks
     
  12. spectre

    spectre Parallels Team

    Messages:
    279
    justinhoward,

    Unfortunately we cannot supply any bootable MS-DOS floppy images with Parallels as it's the 3rd party intellectual property and I don't think Microsoft will be happy if we ship their MS-DOS with our commercial software :)
    We have an article here describing how you can create .fdd image from your own bootable floppy, please check it here - http://kb.parallels.com/entry/27/485/0/
    Also, please make sure you have partitioned and formatted the VM hard drive with "fdisk" before starting Windows installation.
     
  13. jbh001

    jbh001

    Messages:
    87
    Error SU-0013

    You don't mention which version of Parallels you are using (or I missed it). Some have had success with completely uninstalling Parallels, installing a previous build (like 4128 or 3188), creating a brand new VM, and then "upgrading" Parallels to the latest build after successfully getting the VM up and running.

    With this method, you need to remember to reboot your Mac each time
    1. After removing/uninstalling Parallels,
    2. After installing/upgrading Parallels prior to creating or accessing a VM.
    This is for safety reasons as some components of Parallels require a reboot to be complete removed or activated within the Mac OS.

    With all the remedies you said you have tried, I would begin to suspect some corruption of the Mac OS somewhere and would be tempted to do a clean install of the Mac OS.

    I just checked and didn't find a boot disk for Windows 95 at http://www.bootdisk.com/bootdisk.htm, in the Non-Windows Based Image Files W/ImageApp section. But you might be able to get this to work (if you haven't tried it already) as described here in step 1.1 and step 11.

    I seem to remember that Windows 95 doesn't support FAT32 disks nor any disks larger than 2GB. So when partitioning and formatting the your VM's hard disk, I would NOT enable large disk support since I think that means a FAT32 filesystem instead of a FAT16 filesystem.

    I also found this info regarding the error you described that you might be able to glean something usable from: http://support.microsoft.com/?kbid=188166

    I also found this related information:
    Then again maybe you have already tried all of this.

    If you can get it working, let us know so the rest of us can benefit from your experience.
     
    Last edited: Nov 21, 2007
  14. justinhoward

    justinhoward

    Messages:
    4
    Hi All

    A short reportback, got Win95 win2000 and xp loaded and working on my macbook pro. Only problem I have is getting win95 to see the internet, it would be nice if I could get win95 to connect via the ethernet cable as my Mac is connected to the internet via my win xp desktop machine. is there any settings I have to change?

    Thanks
     
  15. Xenos

    Xenos Parallels Team

    Messages:
    1,595
    Hello justinhoward,

    Could you clarify, what you mean by "Mac is connected to the internet via my win xp desktop machine"?

    Please make sure that the virtual machine network adapter is enabled:

    1. Launch Parallels Desktop for Mac
    2. Click the Network Adapter link in the main configuration window to open its settings.
    3. Make sure that the Enabled and Connect cable at startup options are selected in the Device Status area.
    4. Under the Emulation section select the Bridged Ethernet option and choose Default Adapter or any other Mac network connection interface that is connected to the network.
    5. Click OK to close Configuration Editor.

    Best regards,
    Xenos
     
  16. jbh001

    jbh001

    Messages:
    87
    It's been a while since I've done anything with Windows 95. Does it have an Internet Connection Wizard like Windows 98 does that allows you to designate that you are connecting through a LAN?
     
  17. ronmolenda

    ronmolenda

    Messages:
    5
    Worked on Windows 98SE, thanks!
     
  18. jbh001

    jbh001

    Messages:
    87
    Making a USB flash drive visible to Windows.

    I've given up on trying to get Windows 98SE trying to recognize my USB flash drive.

    If you don't want to copy the contents of your flash drive to a folder within your home directory on the Mac (which is what I originally did), there is a way to hack the Mac OS to let Windows see the USB flash drive attached to your Mac.

    But a simpler solution is to use the freeware program SharePoints to do this hacking for you.

    With SharePoints, you give your flash drive a unique name, and then enable SMB so that Windows can see it. From Windows, you should then be able to read and write to the flash drive just as though it were any other drive on the Windows network. I thought the process was rather intuitive, but if you need more detail to make it work, let me know.

    In my case, after sharing the flash drive on the Mac via SharePoints, I can point Windows to my Mac (e.g. \\jbhmacmini\) then click on the now-visible flash drive, and even drag a shortcut for it to my Windows desktop for easier navigation.

    I now have two network links from my within my Parallels VM back to my Mac:
    \\jbhmacmini\jbh\Documents
    and
    \\jbhmacmini\FLASHJBH01
     
    Last edited: Jan 21, 2008
  19. Mach

    Mach

    Messages:
    1
    I cant get past this point T_T

    Ive spent about 7 hours today trying to get win98 to work. Anyway, heres a screenshot of where i am now. http://i24.photobucket.com/albums/c32/Etai/stuck.jpg

    after a few reboots and ejects it still refuses to recognize the cd at this point

    I'm using a mac version 10.4.11 leopard and parallels 3.0
     
  20. jbh001

    jbh001

    Messages:
    87
    It looks like Windows is trying to install drivers and doesn't know where to find them.

    You might want to try making an image of your Windows install CD. You can then point Parallels' CD/DVD Device at your CD image instead of the physical CD/DVD drive. When Windows is looking for drivers, you would then point it to D:\WIN98 (or whatever the drive letter is for your CD/DVD drive within the VM).

    Also copying the Windows installation files to the virtual C: drive is another way around this (see step 13.8 or step 13.9). When Windows is looking for drivers, you would then point it to C:\WIN98
     
    Last edited: Feb 4, 2008

Share This Page