Internal build 1908 for Mac Pro and iMac Core 2 Duo - Mac RAM is unlimited

Discussion in 'Parallels Desktop for Mac' started by STim, Sep 21, 2006.

  1. dnanian

    dnanian

    Messages:
    42
    Alas, I'm having this problem well before any Parallels Tools are involved: I can't even get the CD to boot XP or Vista, and now I can't start any VMs at all.

    I'm glad it's working for you, though!
     
  2. dnanian

    dnanian

    Messages:
    42
    OK. Recognize that there are two problems here: first, that after install I wasn't able to start any VMs without a pretty-soon-after-start crash. (This generated various logs which I posted to this thread, above.)

    The second issue -- now the dominant one -- is that I can't get any VM to start, regardless of VT-x setting, memory limit, or anything else, without causing my cursor to stop moving and requiring a hard power off shutdown.
     
  3. dnanian

    dnanian

    Messages:
    42
    Done, Max. BugNumber is [Parallels #38565].
     
  4. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    Thank you dnanian,

    Yes, I understand that. First issue is known and a fix is already awailable internally.
    But we're really interested in understanding of the second problem (Hang on startup - our testing labs do not reproduce this one).

    What are your memory settings (VM mem - Overall mem - Host mem) ?
    Maybe it just goes to "hard swap" as the result of too large memory allocation ?

    [edit] I will follow up you with your BugID - no need to trash this post

    Regards,
    Max.
     
  5. dnanian

    dnanian

    Messages:
    42
    OK, Max -- to answer: I have 4GB of memory, originally didn't limit the Parallels memory at all, and allocated 512MB to the host (though I tried many different values, since another user indicated other settings worked for him).

    I'm certain it's not hard swapping, because I can see there's no significant disk access.
     
  6. mlh78750

    mlh78750

    Messages:
    4
    Turns out that after I reinstalled Cisco's VPN client the iMac would go into a reboot/crash cycle over and over. Had to go in safe mode and removed the cisco vpn client. Note, that the cisco vpn client worked before I installed parallels.

    iMac 24" Core 2 Duo with 1G of ram. The vpn client is version 4.9.00.0050-universal from cisco systems.
     
  7. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    Hello mlh78750,

    this problem was already investigated once,
    you can try to install this client even without Parallels - it will crash.
    it seems to be a kinda problem in Cisco's VPN.

    Regards,
    Max.
     
  8. David Watson

    David Watson

    Messages:
    15
    Works great!

    Installed 1908, removed my nvram boot-args, rebooted, slept my machine, and started Parallels - everything's great. Even got VT-X working this time.

    It's nice to be able to use all 5GB RAM. My coworkers are all jealous. :)
     
  9. controller

    controller

    Messages:
    20
    Finally - works for me!

    I have a Mac Pro 2.66 with 4GB of RAM. The 1st build I was ever able to get running was the 1896.2?) build, and I just tried this new 1908 build.

    I reverted back to all my original RAM using the last build, rebooted, installed this new 1908 build, rebooted, and launched Parallels. I confirmed that all my 4GB was available. I set Parallels to use 1500, as my VM is only using 700.

    I slept the machine, woke it back up, and launched my VM.

    The VM is still running fine as I type this in Safari... I ran MS money and IE in the VM, and I also read and wrote to a USB Flash Key. I tested networking as well, with no issues.

    I will leave the VM running for a while and test it further to see if I can get it to act funny or Kernel Panic.

    But so far, so good. Parallels, I think you may have fixed the PAE problem! I am delighted by this as with my x1900 ATI card and 23" Apple Cinema Display, I -can't- run Boot Camp.
     
  10. patrickmast

    patrickmast

    Messages:
    48
    I got this panic:
    Description: Panic (system crashes) log
    Size: 10.71 KB
    Last Modified: 22/09/06 18:51
    Location: /Library/Logs/panic.log
    Recent Contents: ...
    0x25a23948 : 0x1a407f (0x3cf788 0x0 0xe 0x3cefb8)
    0x25a23a58 : 0x19ae94 (0x25a23a70 0x0 0x3 0x7029)
    0x25a23b58 : 0x3d5dabfe (0x3ff3000 0x4e2fc 0x0 0x0)
    0x25a23b78 : 0x3d5dac5c (0x3ff3000 0x4e2fc 0x780 0x3ff3000)
    0x25a23bb8 : 0x3d5d51c2 (0x3ff3000 0x41f0000 0x2f9ff080 0x1b7d080)
    0x25a23c48 : 0x3d5c4594 (0x41f0000 0x50bce00 0x25a23c78 0x6)
    0x25a23cf8 : 0x3aeeed (0x41f0000 0x1 0x25a23d2c 0x25a23d28)
    0x25a23d38 : 0x3b23a9 (0x41f0000 0x1 0x3f471b0 0x1)
    0x25a23d68 : 0x189f03 (0x41f0000 0x1 0x3f471b0 0x4d359c0)
    0x25a23db8 : 0x12b498 (0x4d3598c 0x4e006a0 0x25a23df8 0x11e03b)
    0x25a23df8 : 0x124af1 (0x4d35900 0x3f134f8 0x4b4c064 0x0)
    0x25a23f08 : 0x195b6b (0x25a23f44 0x0 0x0 0x0)
    0x25a23fc8 : 0x19b30e (0x4a57060 0x0 0x19e0b5 0x4a4cdcc) No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xbffee888
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.GeForce(4.3.8)@0x3d5b3000
    dependency: com.apple.iokit.IOPCIFamily(2.1)@0x35abb000
    dependency: com.apple.iokit.IOGraphicsFamily(1.4.4)@0x3cbbb000
    dependency: com.apple.iokit.IONDRVSupport(1.4.4)@0x3cbd6000
    dependency: com.apple.NVDAResman(4.3.8)@0x466ba000
     
  11. controller

    controller

    Messages:
    20
    I haven't been able to get it to KP, but after I installed VM Tools I couldn't relaunch the VM without a crash. I didn't get anywhere... it was an instant crash as soon as I hit the "play" button. (Not a KP, just a Parallels crash that prompted me to send an email to Parallels).

    I quit and re-ran Parallels and all was fine again.

    It is still running ok. This is coming from a person who could - never- get Parallels to work.. on two different Mac Pros with 4GB.
     
    Last edited: Sep 22, 2006
  12. andre

    andre

    Messages:
    3
    Crash during Windows XP installation

    Latest beta build:
    Mac Pro
    5Gb
    1.5Gb allocated to Windows XP
    Crash log:
    ----------------- Activation Data ----------------
    Status: Valid
    User Name: Andre Simha
    Company Name:
    Product ID: 6-2147483686-4
    Validity period: Not limited
    Product Name: Parallels® Desktop for Mac
    Product Version: Build 1908 Release Candidate 2 (21 septembre 2006)
    -------------- End of Activation Data ------------
    --------------- Host PC information ------------
    ---Primary OS version:
    Darwin Kernel Version 8.7.2: Tue Jul 25 23:09:54 PDT 2006; root:xnu-792.10.96.obj~3/RELEASE_I386---End of Primary OS version
    ---Processor(s) info:
    MacPro1,1
    Number of CPU: 4
    ---End of Processor(s) info
    ---Memory info:
    User memory: 1682911232
    ---End of Memory info
    Home directory: /Users/asimha
    Display:
    Session: local
    Vendor:
    Memory size: 5120
    ----------- End of Host PC information ---------
    ------------ Guest system configuration ------------
    Current configuration (dead0b0f):
    OS type: Windows XP (135)
    Boot: c
    Memory: 1500 Mb
    Memory block size: 2^10
    Overall memory limit: 4392
    Monitor base: 0xec000000
    Memory working set : current=0x1400, maximum=0x5dc00
    Monitor host speed: 2659
    Timer resolution: 1
    Refresh rate: 30
    Use opt cmos: 1
    Time schema: 1
    Timer adjusting schema: 0
    Time period scale: 10000
    Minamal timer tsc ticks: 500000
    Halt tsc ticks ignore: 1
    Portion slow timer: 4
    Portion plan timer: 1
    Acceleration level: 2
    Smart application acceleration: 1
    Smart kernel acceleration: enable=1, state=777
    Smart kernel mode #2: 1
    Fast stub parameter: 0xffffffff
    Fast system call: 0
    Fast system call #2: 1
    Multi frame parameter: 4
    Hack parameter: 4
    Bit D remap: 1
    Ignore interrupts parameter: 0
    Minimal async time: 0
    Enable write-back disk cache: 1
    Strong checks: 0
    Full LDT map: 1
    VM was resumed: 0
    PC speaker: 1
    Screen resolution: 640x400x4 (stretch: 1x1)
    Vesa mode: 0x0
    FDD0: type=12, insert=0, path=/Library/Parallels/Tools/vmtools.fdd
    IDE0: HDD, type=1DE, cyl=24381, head=16, spt=63, path=/Users/asimha/Library/Parallels/winxp.1/winxp.1.hdd
    IDE1: CD-ROM, type=CD, insert=1 path=SONY DVD RW DW-D150A
    Network: type=RTL8029(AS), mem=0, port=0x300, irq=3 mac=0010c3870748
    Sound: 1
    PCI: devices=0x7
    -------- End of guest system configuration ---------
    ------------------- Print buffer -------------------
    [Time elapsed from VM start : 1.716 second(s)]
    E054.01.001
    [Time elapsed from VM start : 1.716 second(s)]
    E054.01.001
    [Time elapsed from VM start : 1.716 second(s)]
    E054.01.001
    [Time elapsed from VM start : 1.716 second(s)]
    E054.01.001
    [Time elapsed from VM start : 1.716 second(s)]
    E054.01.001
    [Time elapsed from VM start : 1.716 second(s)]
    E054.01.001
    E048.03.022(6,0x0,0x6294ea12,0x62918000)

    <Stat>
    0000014D,0000014D,00044326,00044326,00000289,00000289
    </Stat>

    <State>
    64058A00,00000000,00000000,22D30000,00000000,64058A00,657C5F28,6294EA12,FF30,FF38,FF38,8003F430,00002622
    </State>

    <Stack start=0x62918000 size=0x17c5000 esp=0x657c5e68>
    :629205d2(0085d2) :629b6b80(09eb80) :00000006 :00000000 :6294ea12(036a12) :62918000(000000)
    :64058a00(1740a00) :00000000 :00000000 :640d9920(17c1920) :657c5e9c :629af0ac(0970ac)
    :629b942c(0a142c) :657c5ec8 :00000000 :657c5f28 :6292d559(015559) :657c5eb4
    :dead00e1 :637bfea4(ea7ea4) :00000000 :0000ff38 :0000ff38 :64058a00(1740a00)
    :00000000 :657c5f28 :657c5ee4 :00000000 :22d30000 :00000000
    :64058a00(1740a00) :00000000 :00000006 :40000000 :00000000 :00000000
    :6294ea12(036a12) :0000ff30 :00010046 :8003fc00 :00000000 :80559320
    :00000001 :8003fc00 :22d30000 :00000000 :64058a00(1740a00) :657c5f18
    :657c5f44 :6294f59f(03759f) :8003fc00 :00000000 :80559320 :657c5f90
    :657c5f90 :657c5f90 :8003fc00 :806b3844 :80559320 :806b3844
    :80559320 :000006b2 :00000001 :65ac7000 :00123d07 :00000000
    :00120008 :000806b2 :00000000 :806b2fe1 :8003f430 :00000000
    :8001003b :8055086c :8055086c :6292d5a5(0155a5) :0000ff8b :00000030
    :00000023 :00000023 :8003fc00 :806b3844 :8055086c :657c5fc8
    :80559320 :00000001 :5a5a5a5a :8001003d :00000000 :00000001
    :40000000 :00000000 :00000000 :806b2fe3 :0000ff63 :00000282
    :8055086c :0000ffc3 :00000000 :00000000 :00000000 :00000000
    </Stack>

    <Internal variables>
    Current monitor base=0xec000000
    bAnalizeCode=0x0
    uSegRegModelNo=0x0
    iDTIndex=0x0
    Primary OS paging mode=2
    </Internal variables>

    <Relocation info>
    > Current monitor base = 0xec000000
    > Total relocations count = 0
    > Monitor bases history
    </Relocation info>
    ---------------- End of print buffer ---------------
    -------------- Guest processor state ---------------
    Inhibit Mask=0

    CS=0008 [0000FFFF 00CF9B00] V=1
    SS=0010 [0000FFFF 00CF9300] V=1
    DS=0023 [0000FFFF 00CFF300] V=1
    ES=0023 [0000FFFF 00CFF300] V=1
    FS=0030 [F0000001 FFC093DF] V=1
    GS=0000 [0000FFFF 00009300] V=1

    EAX=8001003D EBX=80559320 ECX=5A5A5A5A EDX=00000001
    ESI=806B3844 EDI=8003FC00 EBP=8055086C ESP=8055086C
    EIP=806B2FE3 EFLAGS=00000082

    LDTR=0000 [00000000 00000000] V=0
    TR=0028 [200020AB 80008B04] V=1
    GDTR=8003F000(000003FF)
    IDTR=8003F400(000007FF)

    CR0=8001003D
    CR1=00000000
    CR2=00000000
    CR3=00039000
    CR4=00000000

    0008.806B2FE3 58 pop eax

    0010.8055086C 0000 5A5A 08BC 8055 9D90 806A FC00 8003 3844 806B
    ----------- End of guest processor state -----------
     
  13. controller

    controller

    Messages:
    20
    NOTE: I didn't have to sleep/restart with the new Mac Pro EFI firmware. I rebooted and launched Parallels and it just worked.

    Still having no problems, and I stressed the machine a lot. Good work so far, though KPs need to be addressed this is definitely progress in a major way for me.
     
  14. MartyMcr

    MartyMcr

    Messages:
    101
    Build 1908

    Runs fine on an iMac 20'" 1.5GB machine. Runs Vista RC1 well too.
     
  15. spullara

    spullara

    Messages:
    29
    Mac Pro just hangs

    Right after the BIOS post screen the system hangs and nothing else happens until I use the power button to reboot it. This was a fresh install of 1908. I have the new firmware installed from Apple. There is very little else on the system. The image is from a MacBook Pro.

    Sam
     
  16. brettev

    brettev

    Messages:
    2
    xp x64 or vista64 with >1500 mb ram?

    Any chance of an RC that will let more than 1500 mb be allocated to the vm? I have 8 GB and would like over 4 GB(6 or 7) to be allocated to a windows vm.
     
  17. BlueSkyISdotCOM

    BlueSkyISdotCOM Bit Poster

    Messages:
    68
    Mac Pro 2.66 Ghz, 3 GB RAM. No problems so far.

    Uninstalled Parallels, set nvram args to "", rebooted Mac, installed Parallels, booted existing Win XP SP2 VM (got the VT-X message), immediately installed Parallels tools. So far so good after several test VM reboots and Parallels restarts. (VT-X came on after a sleep and VM restart.)
     
  18. genesteinberg

    genesteinberg

    Messages:
    2

    I know I'm missing something, folks but I cannot find that link to your internal build, so I can try it on one of my Intel-based Macs.

    Can someone point me to it?

    Peace,
    Gene
     
  19. artpease

    artpease

    Messages:
    9
    Click on the word "here" at the end of first sentence, second paragraph of Tim Surgent's original message!!!!
     
  20. genesteinberg

    genesteinberg

    Messages:
    2

    Thanks. I couldn't see the link when I first checked.

    So far, so good.

    Peace,
    Gene
     

Share This Page