Internal build 1910 for Mac Pro and iMac Core 2 Duo

Discussion in 'Parallels Desktop for Mac' started by STim, Sep 23, 2006.

  1. STim

    STim Bit poster

    Hello everyone,

    We are continuing our efforts to deliver a Parallels Desktop for Mac version that fully supports Mac Pro and iMac Core 2 Duo.

    There's an updated internal build that is available for early testing which can be downloaded from here.
    Please don't forget to backup any sensitive data on your Mac before proceeding to evaluation.

    This version introduces a number of important fixes:
    * VM crash on restart on huge memory MacPros in VT-x mode.
    * Several VMs simultaneous work.
    * Win98 guest 100% CPU usage
    * WinNT not being able to start fix
    * Several other fixes

    We're still extremely interested in your feedback about this build and any issues you might face.

    Best regards,
  2. awilliamsny

    awilliamsny Bit poster

    Sweet! Mac Pro here, 3ghz, 4gb RAM. Was running 1848, installed 1910 over it, and it works beautifully. No KPs, tools work, nicely done, ||s :)
  3. thorby

    thorby Member

    Quick Start Guide broken

    In the 1910 .dmg the Parallels Desktop for Mac Quick Start Guide.pdf file produces an error message when you try to open it. says "File Error. Couldn't open the file"

    Adobe Acrobat Reader 7 says "There was an error opening this document. The file is damaged and could not be repaired."

    The full User Guide.pdf opens correctly. Also, the Quick Start .pdf from build 1908 opens correctly.
    Last edited: Sep 23, 2006
  4. pastrychef

    pastrychef Member

    So far, so good!!!

    One question, though... Do I need to re-install Parallels Tools after Windows boots up?

    Thanks for the great work!!!
  5. pastrychef

    pastrychef Member

    By the way, DVD Shrink seems to be working now, too! :)

    Ooops... Spoke too soon... Worked with one disc and not the other...
  6. WickDC

    WickDC Bit poster

    Upgraded from 1898 (working fine except for the memory reduction). Reinstalled Parallel Tools fine in XP Pro, no problems at all except the Quick Start Guide PDF has an error as mentioned above. Memory is back up to 2GB from 1.95GB with 1898.

    Mac Pro 3Ghz, 2GB, AP+BT
  7. thorby

    thorby Member

    "poof" - no improvement from 1908

    I did the uninstall - install 1910 thing and launched the WinXP VM I described in this post.

    Just as before the VM starts, shows the initial Win splash screen, expands to the desired window resolution but before it can display anything else, it vanishes and we are back to the property display.

    As before no message or diagnostic, and nothing in the os x console window.

    This is the last time I'm gonna offer: I'd be happy to download a trace-enabled version or do any other kind of debugging you want that would get some traction on this problem which MAKES PARALLELS USELESS TO ME. Sorry, patience running a little thin there... or if you want I can quote the .pvs file here, or whatever would help. I have the developer tools installed...

    let me just add, the only thing I can think of that would make my setup any different from typical is, both the .pvs file and the .hdd virtual disk are on a different volume (on a different physical drive) from the volume that contains /Applications and /Users. So not in the usual default location in ~/Documents.
    Last edited: Sep 23, 2006
  8. controller

    controller Member

    I am having no problems with 1910 either on my Mac Pro 2.66 x1900 w/4GB of RAM (all RAM active.)

    I installed right over 1908.

    I even ran Vista RC1 57xx and XP at the same time with no issues.

    My PVS file is on my main drive, but my HDDs are on another drive.

    I have yet to see the crashes when restarting VMs that I saw before, but it is still too early to tell. Nice work so far!

    One bug: Running a VM sets my Mac's volume pretty high. I have to manually turn it down.
  9. froejoe

    froejoe Junior Member

    Still no go on VT-x

    Did an uninstall, restart, and install. Still running in software virtualization mode. Still need to put machine to sleep first to get VT-x.

    Mac Pro 3GHz
  10. kgregc

    kgregc Member

    Thorby...before you throw in the towel...why not make a "usual default location" and see if it works? That could eliminate at least one possible problem area, and give the techs a fairer chance to help you.
  11. spullara

    spullara Member

    Mac Pro still just hangs on startup

    I installed 1910 over 1908. Started Parallels. Started a Windows XP VM that I had from my MacBook Pro install. I get an immediate beachball and the everything stops being reponsive.
  12. kingfish

    kingfish Junior Member

    1910 works fine on MacPro 2 x 3 Ghz, 2 GB Ram

    Upgraded over 1908; no problems.
  13. dnanian

    dnanian Member

    "spullara": try opening Activity Monitor, sort by "CPU", and switch the bottom to disk activity.

    When everything stops being responsive, does Activity Monitor continue to work? What does the Disk I/O part indicate?
  14. SiskoKid

    SiskoKid Member

    This version worked a lot more than the previous versions, but it ends up crashing my Mac Pro yet again making it unable to respond, so I have to force reboot. If I try to reopen the VM, it automatically crashes my system. If I try to install a new Windows XP VM, it automatically crashes my system. Once the software becomes unstable, it's completely unusable, so I don't know what to do. I'm getting tired of installing Windows all the time. Any suggestions before I give up?
  15. jbmelby

    jbmelby Member



    It worked for me.

    Mac Pro 2.66, 3 GB RAM
  16. dnanian

    dnanian Member

    Hey, SiskoKid, see what I sent to "spullara": could you test that way, too?
  17. SiskoKid

    SiskoKid Member

    I'll do that right away. Another weird thing with the new build is whenever I open Parallels for the first time after a re-installation, it opens Preview and says could not open file. Preview being that software you use to look at picture files. It's bizarre, and it happens every time after a clean re-install of the 1910 build only. I'm going through the re-installation process of Windows right now, so I'll tell you what Activity Monitor says in hopefully about 45 minutes. Wish me luck :D
  18. BlueSkyISdotCOM

    BlueSkyISdotCOM Member

    YES you do.

    Mac Pro 2.66 Ghz 3 GB RAM. So far, so good. I didn't have any problems with 1908, except for the disabled VT-X. I haven't seen that message yet, so maybe that is fixed too.

    My method:
    1. Download Parallels
    2. Use downloaded uninstaller to uninstall previous version
    3. Install new version
    4. Start new version (got the warning to reboot my mac, which I did and returned to this step)
    5. Start existing Win XP SP2 VM
    6. Immediately install Parallels Tools and reboot VM.
  19. kgregc

    kgregc Member

    Works great, just like 1884, 1892.6 and 1908 on my iMac. The only one I had problems with was 1848.

    1Gb RAM
    Core 2 Duo.
    Last edited: Sep 23, 2006
  20. SiskoKid

    SiskoKid Member

    Ok, I didn't do all the necessary steps because I was in a hurry. By that I mean, I didn't uninstall, restart, install, restart etc. So I used it again and it crashed but this is what Activity Monitor said:

    Parallels not responding - CPU % 2.20 - #Threads 16 - Real Memory 75.04MB - Virtual Memory 2.25GB - Kind Intel

    Read In: 47151
    Read Out: 18075
    Data Read: 828.82 MB
    Data Written: 276.63MB

    41 IO/sec

    I'm gonna go through the whole process of uninstalling, but does that tell you guys anything so far? BRB in a few.

Share This Page