Internal build 1918 for Mac Pro and iMac Core 2 Duo

Discussion in 'Parallels Desktop for Mac' started by STim, Sep 27, 2006.

  1. STim

    STim Super Moderator

    Hello everyone,

    We are on the final stage of our efforts to deliver a Parallels Desktop for Mac version that fully supports Mac Pro and iMac Core 2 Duo.

    There's an updated internal build that is available for early testing which can be downloaded from here.
    Please don't forget to backup any sensitive data on your Mac before proceeding to evaluation.

    This version fixes MacPro and iMac Core 2 Duo hangups on VM start as well as some other less critical problems.

    We're still extremely interested in your feedback about this build and any issues you might face.

    Best regards,
    Last edited: Sep 27, 2006
  2. fmantek


    Just installed. Looking good so far...

    Ubuntu 6.06i starts and works fine. When it shuts down it never finishes. Last message is "Will now halt", but Paralells never realizes that Ubuntu is now done.... So the property page does not show up on it's own, i have to halt the VM myself.

    Windows XP, running VS 2005, works fine, including ActiveSync.

    I did NOT have to sleep/awake again to get into VT-X mode, this worked fine after one reboot (i needed to reboot as i had been running 1910 before).

    Network access and all is fine. Missing the audio hardware acceleration for DX 10 though :)

    Initial impressions: did you guys change memory management a bit? I used to run close to 5GB real memory use running 2 VMs at once, I can now run Ubuntu and XP at the same time and still have over 1 GB left...

  3. trlblzr


    <Brick>LOUD NOISES!!!</Brick>

    Hey, just downloaded and installed 1918 and so far so good! Only one thing... during startup of my XP VM, the volume on my Mac Pro gets kicked up to MAX twice in the process... once before XP starts and once before the XP happy sound plays upon login. Ideas?


  4. tecwerks


    Same here with the volume. Not a show stopper though. Just makes you jump out of your seat.
  5. jcbeckman


    Same experience here - 1918 now seems to load fine. I have the volume problem and need to sleep to get acceleration, but at least now it runs!

    3 Ghz Mac Pro, 2 GB RAM, ATI X1900 graphics, latest firmware installed.
  6. Skeuomorph


    This build is working for me (priors didn't)

    Mac Pro with 3 GB RAM and two video screens, showing OS X on the 30" Cinema Display and Windows XP full-screen on the Samsung SyncMaster 215TW (unusual resolution of 1680x1050).

    Still had the "put your Mac to sleep" message at VM boot. Did that, and didn't get message next time. Installed Parallels Tools, cursor moves seamlessly between VM (full screen) on secondary screen and host OS on primary.

    No problem with the audio level. Played various MSN videos ( without issue, volume control worked independantly of Mac OS X volume.

    Shared Folders works great.

    Mapping of ClearType between full-screen VM and screen isn't pixel accurate, so can't use it, have to use normal smoothing which doesn't smooth text in browser but does smooth the GUI (such as the Start button).

    Extremely happy to notice that the host OS (Mac OS X) is as responsive with the VM running as without it, unlike the prior build with the 2GB memory hack, which made OS X unresponsive even when the VM was NOT running.

    I suppose it's a good thing this worked today. I'd bought the software with the Mac Pro a month ago but didn't open the box in case it had to be returned, and my trial key expires tomorrow morning.

    Definitely appreciate seeing this product work on my Mac.

    Machine Name: Mac Pro
    Machine Model: MacPro1,1
    Processor Name: Dual-Core Intel Xeon
    Processor Speed: 2.66 GHz
    Number Of Processors: 2
    Total Number Of Cores: 4
    L2 Cache (per processor): 4 MB
    Memory: 3 GB
    Bus Speed: 1.33 GHz
    Boot ROM Version: MP11.005C.B01
    SMC Version: 1.7f6

    System Version: Mac OS X 10.4.7 (8K1079)
    Kernel Version: Darwin 8.7.2
  7. jakeller


    In this build I can't run with the memory set to 1500MB. I get an "unable to allocate virtual memory" error, which didn't happen on previous builds. If I lower the memory to 1024MB or even 1280MB it boots fine. I have hundreds of gigs of HD space and 4GB of RAM in my Mac Pro.

    And for what it's worth, I have the volume change issue as well.

  8. philwells


    1918 seems fine w/XP on an iMac 17" 2GHz w/1GHz. A couple general comments if I may:

    It would be nice if we could tell which bld we're on from inside the Property PAge windo. The only way I could be sure I was running 1918 was by looking in Info.plist - THEN I realized that the menus were missing! I had the Prop Page on the big screen and the menus were still on the smaller screen since that's the "boot" screen. A very tiny issue but there it is.

    I'm running it dual screen and it's beautiful. I have to get my brain around the fact that I'm running XP on a Mac - I keep looking for the "PC" mouse. I'm even running some business specific software that uses MAPI and RPCs and it's perfect.

    Minor suggestion: Please make it so that if we're dragging something and we accidentally drag it off the XP screen the cursor just stops. As is, the cursor continues to the Mac screen and loses the dragged item and returns to a place on the XP screen.

    I would not think that it would be possible to get a window or icon "lost" behind a Full Screened VM (as opposed to behind a windowed VM that happens to be the full size of the screen) but it is. Consider making it so that when we launch a VM fullscreen, it completely takes over that monitor - which keeps with the VM analogy because you cant hide something behind the DESKTOP on a regular XP machine

    Is it possible to tell the VMs to "boot" with Num Lock on?

    XP auto detected my 1600x1050 screen. Vista did not. Maybe that's Vista and not your VM.

    It would be nice if Parallels Tools showed up in the All Programs list in Windows. I was disappointed that the Parallels Shared Directory and the seamless mouse transitions aren't available for Vista yet but, hey, it's still a beta on your end and MS's so I'll have to be patient. Other than that, Vista performed fine for me with no problems that I'm aware of.

    Keep up the great work. This is SO COOL and very empowering to have the best of both worlds in one place; I could do without the spinning cubes, though. After once or twice the wow factor goes away and it becomes a little nauseating. Or is this Apple's doing?

  9. ___


    Finally didn't need to sleep/wakeup the Mac Pro before using parallels so that was cool. XP still can not find my usb modem.

    Parallels displays this message "USB device you are trying to connect to the virtual machine is being used by another process..." error message. The modem is the zoom 2986/2985 if that matters.

    I have tried removing all the other usb devices except keyboard and mouse of course with no difference.
  10. thorby


    1918 - old poof and a new one :-(

    Downloaded 1918, used its uninstaller; installed it; rebooted macpro. Fired up existing Ubuntu VM, it ran but had no net access. WTHeck? Shut it down, did the sleep-wake thing, and restarted the Ubuntu VM. Holy crap! that is fast! VT-x gooooood! And it had networking. Ran it through software updates and it looked good.

    So all was wonderful -- until I told Ubuntu to shut down. Then during the Ubuntu shutdown sequence, the VM window vanished much too early, long before "will now halt" appears.


    Started it again: it gets through three lines of the startup sequence and poof no VM window. So... what was a working & usable linux VM has joined my WinXP VM on the useless pile.

    Started up the WinXP that had begun poofing. Yup, same deal. Changes resolution of the monitor window and poof back to properties. Just for drill, copied the winxp .hdd and .pvs files to be on the same logical volume as /Applications and tried again. Same thing, poofs at the same point.

    Look, I've been in the software game since before dirt was invented and this is not a problem inside the VM. If windows or linux had a problem, at least one of them would show a message or they would crash in some way that was visible in the VM window -- the VM window wouldn't just vanish. (And anyway, how could such dissimilar OSs suddenly develop the identical failure?)

    The VM poofs because Parallels thinks the VM is gone. So I ask: under what conditions does Parallels (a) remove the toolbar at the bottom of the VM window, which is the first thing to vanish, and then (b) discard the Aqua resources of the VM window and redisplay the Properties window?

    That condition is being falsely triggered for these VMs. Could it be something in the emulated BIOS?
  11. drjamesh


    Naturally Speaking 9.0 now starts after going into the sleep mode and then waking up. Microphone is not recognized. Selected in preferences in the mac OS.

    Machine Name: Mac Pro
    Machine Model: MacPro1,1
    Processor Name: Dual-Core Intel Xeon
    Processor Speed: 2.66 GHz
    Number Of Processors: 2
    Total Number Of Cores: 4
    L2 Cache (per processor): 4 MB
    Memory: 2 GB
    Bus Speed: 1.33 GHz
    Boot ROM Version: MP11.005C.B01
  12. SiskoKid



    I hope I'm not speaking too soon, but I am posting from Windows through Parallels on my Mac Pro!

    It doesn't freeze up or anything. I LOVE this software!

    I will probably be purchasing it very soon. I'll be testing this out for a couple days to see if it keeps its stability.

    Thanks! So far so good, so keep your fingers crossed!

    By the way, my issue before was that starting Parallels would lock up my system completely, and so far, it doesn't even stutter. So I'm very happy. I'll keep you guys updated as I test things out and see what's going on.

    The volume issue is definitely there like others have mentioned. But I'll be lookin for other things to iron out. Thanks again!
  13. froejoe


    Still need to do the sleep trick.



    Mac Pro 3.0 GHz
  14. sydbarrett74


    I still can't get VT-x to persist through reboots (Apple's fault, not yours), but I've noticed more stability and speed than build 1910. I've only been using Parallels for about a month and notice a huge improvement in functionality and utility between the build I first downloaded and 1918 -- keep up the good work!
  15. viewpoint



    So i've got this new 24" iMac w/ 2.33 ghz Core 2 Duo, 2gb 667 DDR2 SDRAM, and OSX version 10.4.7. I just bought parallels desktop for Mac Build 1848.2.

    I just installed Parallels and I am following along in the Quick Start Guide, and I get to page five, where I insert the WinXP disc and the click "PowerOn" button for the VM...and the Mac crashes. Same thing every time. I followed the instructions exactly. What did I do wrong?
  16. jsouba


    build 1918

    I just finished loading 1918 after 4 days of trying to get 1848 to work. It took off on the first attempt and I loaded windows xp without a hitch. I am having problems with it recognizing a USB device I have connected. It shows that it is connected but when I go to load the software with the drivers it says it can't find the USB device. Other than that it is working great. Any suggestions on the USB?

    Thanks for making the improvements. This is my first Mac (iMac 20" duo core) and I am already blown away by it's speed and ease. . .
  17. jsouba


    go download the 1918 build. I had the same problems but as soon as I loaded this it took off. . .
  18. alexbet


    I still need to do the sleep trick when I first boot the computer in the morning. After I do that the first time, it works fine until I restart the computer. When I restart the computer, I have to do the sleep trick again. :S
  19. controller


    Great job!

    I loaded this build onto my 2.66 Mac Pro w/4GB of RAM. I installed over 1910 and rebooted afterwards. [I suggest Parallels makes restarting mandatory as Parallels seems to load some "at boot" programs. Changing versions can cause issues, perhaps?]


    I ran an existing VM (WinXP Pro) as well as a Vista VM.

    The Vista VM did raise my volume, but now the XP VM does not.

    I do need to put my machine to sleep once to get VT-x to work, though on rare occasions with this and other previous builds it would be sometimes unneccessary on a fresh reboot.

    I have Parallels set to use 1500 RAM, and 760MB in Windows itself.

    I am able to use USB flash keys fine. Sound works fine. I have all 4GB RAM available and I have been able to multitask many programs, including 3D games, while Parallels runs without a problem.

    I have seen no crashes in 30 mins of heavy use. 1910 was working ok for me, but seemed a little wonky for some people (I even got some crashes, but not KPs). No KPs, no crashes here and runs very smooth.

    Based on what we're seeing here we may be close to release of another RC... =)

    GREAT job, Parallels getting this to work on the Mac Pro without RAM limitations!
  20. pastrychef


    So far, 1918 has been running great on my Mac Pro 3GHz with 5GB RAM and X1900.

    I have a WinXP VM with 1.5GB. It seems to be handling CD/DVDs better. I still need to use the Sleep trick.

Share This Page