Invisible mouse pointer in old Windows game...

Discussion in 'Windows Guest OS Discussion' started by andy_herbert, Aug 14, 2010.

  1. andy_herbert

    andy_herbert

    Messages:
    4
    … namely Age of Empires I and II, which is a shame.

    It's possible to move the mouse and see various UI feedback effects on the screen, but the visual component of the mouse pointer is completely gone when the game starts and changes to a non-desktop resolution of 800x600, 1024x768, or 1280x1024. Any chance of having an option within Parallels 5 to preserve the visibility of the Mac pointer to circumvent this problem, although I'm not sure if it's just limited to the first two games in the Age of Empires series.
     
  2. jclermont

    jclermont

    Messages:
    6
    Second!!

    I'm having this same issue. Just bought the Age of Empires Collector's Edition and the mouse pointer is invisible inside of the game. A workaround of any kind would be most helpful.
     
  3. Shaddam IV

    Shaddam IV

    Messages:
    626
    Turn off SmartMouse (after you've shut down the VM). This will keep your mouse within the VM and you'll see the mouse pointer. However, there will be no mouse integration: To get the Mac mouse back, you need to hit the ctrl and alt keys simultaneously.
     
  4. andy_herbert

    andy_herbert

    Messages:
    4
    Thanks Shaddam IV, for the reply.

    Unfortunately turning off smart mouse option doesn't solve the problem, the pointer is still not visible within the game.
     
  5. CarlaR

    CarlaR

    Messages:
    1
    Hi
    I'm running Age of Empires 2 gold edition and just recently got my mouse to appear. I noticed that the typing cursor would show, but not the stylized age of empires one. So, the stylized one is the problem!
    On your windows desktop, right click on the shortcut for age of empires 2.
    Go to Properties.
    Select the Shortcut tab
    Beside "Target" there's a field that says "C:\Program Files\Microsoft Games\Age of Empires II\EMPIRES2.EXE" or wherever it is that you've installed. After the quotation mark, leave a space and type "normalmouse" (no quotations).
    Hit apply
    Hit OK
    Voila! You've just altered the command line to get rid of the invisible stylized mouse.
    This works on the Conquerors expansion as well.
     
  6. andy_herbert

    andy_herbert

    Messages:
    4
    Thanks CarlaR!
     
  7. StephaneZ

    StephaneZ

    Messages:
    2
    Thanks - Great tip!

    Thanks - Great tip!
     
  8. StephaneZ

    StephaneZ

    Messages:
    2
    This Works but it doesn't help the fact that you loose special pointers such as garrision, conversion, attack, etc. :)
     
  9. jwt4th

    jwt4th

    Messages:
    3
    Multiplayer with GameRanger

    Multiplayer with GameRanger opens up the game without the "normalmouse" edit on the shortcut. Anyway around this?
     
  10. Smitty25

    Smitty25 Bit Poster

    Messages:
    4
    Company of Heroes... it works for the most part, but the mini map is broken. When you click on the mini map to change your focus to that area of the map, the entire view jumps to the lower left hand.

    test case:
    -click anywhere on the mini map you want to jump to (mini map is in the lower right hand corner)
    -instead of the mini map taking you to the map position you selected on the mini map, it moves you always to the lower bottom left hand corner of the map

    Unfortunately this makes the game very difficult to play because your constantly jumping between map positions during a game.
     

Share This Page