irql_not_less_or_equal After Automatic Snapshot

Discussion in 'Windows Guest OS Discussion' started by NathanJ, Mar 2, 2010.

  1. NathanJ

    NathanJ Bit Poster

    I've recently turned on SmartGuard and now, occasionally, a few minutes after creating the automatic snapshot I'll get a BSOD with the irql_not_less_or_equal error. This didn't happen before I turned on SmartGuard and didn't happen until it reached the snapshot limit and had to delete the oldest before creating. I've been running the VM with no problems for at least a month

    Here's my basic config:
    Version: Parallels Desktop 5 for Mac (ver 5.0.9310)
    Guest OS: Windows XP Pro (running Norton AV infrastructure version)
    Processors: 2
    Memory: 2048MB
    Virtual HD: on SCSI 0:0
    Video Mem: 256MB
    Video Accel: On

    Anyone have any ideas?
  2. I-che


  3. NathanJ

    NathanJ Bit Poster

    More Errors

    You know, I stumbled across changing to 1 CPU yesterday so I thought I'd give it a try. Instead I just got different memory related errors: pfn_list_corrupt and then memory_management. I turned off SmartGuard and the errors went away.

    This might help to track down the bug though. The memory_management BSOD occurred about 4 or 5 minutes after the snapshot. I restored from the snapshot and the restored VM worked perfectly. So whatever is happening is happening after the snapshot is created.

    Maybe some program on my VM doesn't like the hiccup between the SmartGuard prompt and then later between the snapshot delete and creation, but I've never had a problem with creating a non-SmartGuard snapshot nor have I gotten a BSOD suspending and resuming...

    You know, I have a couple of non-SmartGuard snapshots at the beginning of the snapshot list. Could this somehow be causing a problem?
  4. I-che


    Hi NathanJ,
    curious issue. If you'd like, we can investigate the issue closer, if you will create support ticket here. Make sure to include link to this forum thread to the ticket.
  5. dervish


    I'm having the same problem...

    Windows7 Ultimate - new install updated service packs
    on Leopard iMac Core2 Duo

    Crashes perhaps once per day, gets really slow before it crashes.

    Only two apps that I use are Excel and Bloomberg Professional


    After windows reboots, in the "fix it screen" it says that the bug was:


    Only other thing that I would mention is that the "slowness" prior to a crash is extreme with context menus (right click) in bloomberg.

    Problem exists if in Crystal or Full screen, although it does seem worse in Crystal

    Most recent Parallels Desktop of course
  6. serget



    I have the exact same problem and irql_not_less_or_equal error[/URL].

    Version: Parallels Desktop 5
    Guest OS: Windows XP Pro sp3
    Processors: 2
    Memory: 4g
    Video Mem: 512MB
    Video Accel: yes,of course:)

    I suspect it has something to do with the SCSI drivers.
  7. NathanJ

    NathanJ Bit Poster

    Other Source of Error

    Just thought I'd let everyone know what I discovered. I never did get automatic snapshots to work--sorry--but I did get some insight into another reason why this might happen on your computer. I'm using Parallels 6 now so maybe it will work now...

    Anyhow, at a later date, I upgraded my system memory from 4GB of good Apple-provided memory to 8GB of cheapo-brand memory. I started getting this same error. So if you recently upgraded you may need to return your memory (Crucial brand worked for me in the end) or if Parallels is your only heavy memory user, you may have a bad memory stick.

    By the way, to test my cheapo memory, I used Memtest OS X which actually did find errors where OSX's built-in memory tester didn't.
  8. PauloG


    Hi There,

    I'm receiving the same error message... It only works OK when I set the number of CPUs to 1.

    I'm trying to make it work and I'll post it up here if I find anything different.
  9. PauloG


    No progress... Installed XP Pro SP2 and if I set the number of CPUs to 3 it will crash it.
  10. PauloG


    It worked for me... this is how I did.

    Created a shell with 1 CPU only and 2GB memory

    Installed Windows XP - SP1
    Updated to SP2
    Updated to SP3
    Installed all the Microsoft patches

    Nows I can set number of CPUs to 1,2,3 or 4 and they all work fine.

    I am running RealFlight Simulator G5 on it and so far so good.

    My iMac
    intel i3 series with 12 GB memory

Share This Page