Is Parallels Tools working in recent Linux VMs? Screen Res in Mint 21 X.Org/Server 1.21?

Discussion in 'Linux Virtual Machine' started by JMP_5, Jan 18, 2023.

  1. JMP_5

    JMP_5 Bit poster

    Messages:
    7
    Before going further down the troubleshooting rabbit hole, thought to first ask here whether this is a general problem.
    Had been running Tools 16 in Linux Mint 20 under Parallels Desktop 13 (Mac OS 10.11, late 2013 iMac) without problem.
    After figuring out how to tune grub to boot Linux Mint 21 (based on Ubuntu 22.04 LTS) in the VM after installing, found that Tools 16 would not install - "Error: Xorg version 1.21 not supported" - but while Tools 17/18 do appear to install without reported error (using any of the install methods), they don't completely do the job.
    Most importantly, screen resolution is very limited, exactly as before Tools was installed, and as the live CD on installation (1400 x 1050 according to the system). Dynamic Resolution Tool does not work. Even being able to set a higher resolution manually (not dragging the lower right corner) would be fine. It does not seem to be using the Parallels Video drivers.
    Also Mouse Synchronization Tool does not work - mouse pointer is fenced-in unless released by CTRL-ALT.
    However, network, shares, mounts, printers, clipboard, etc., seem OK.
    Thanks for any comment.
    .
    === if of technical interest
    A few examples of reported information:
    in (not-working) Linux Mint 21.1, Parallels Tools 18
    System: Kernel: 5.15.0-52-generic x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: Cinnamon 5.4.12 tk: GTK 3.24.33 wm: Mutter dm: LightDM Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy
    Machine: Type: Desktop Mobo: Parallels model: Parallels Virtual Platform serial: <superuser required> BIOS: Parallels v: 13.3.2 (43368) date: 06/15/2018
    Graphics:
    Device-1: Parallels Accelerated Virtual Video Adapter driver: N/A bus-ID: 01:00.0 chip-ID: 1ab8:4005
    Device-2: PARALLELS FaceTime HD Camera (Built-in) type: USB driver: uvcvideo bus-ID: 1-1:2 chip-ID: 203a:fff9
    Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: vesa unloaded: fbdev,modesetting gpu: N/A display-ID: :0 screens: 1
    Screen-1: 0 s-res: 1400x1050 s-dpi: 93
    Monitor-1: default res: 1400x1050 size: N/A
    OpenGL: renderer: llvmpipe (LLVM 13.0.1 256 bits) v: 4.5 Mesa 22.0.5 direct render: Yes

    $ xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 800 x 600, current 1400 x 1050, maximum 1440 x 1050
    default connected primary 1400x1050+0+0 0mm x 0mm
    1400x1050 0.00*
    1440x900 0.00
    800x600 0.00
    1440x1050 0.00

    $ ls /lib/xorg/modules/drivers
    amdgpu_drv.so fbdev_drv.so modesetting_drv.so qxl_drv.so vesa_drv.so
    ati_drv.so intel_drv.so nouveau_drv.so radeon_drv.so vmware_drv.so
    ---

    in (working) Linux Mint 20.3, Parallels Tools 16
    System: Kernel: 5.4.0-136-generic x86_64 bits: 64 compiler: gcc v: 9.4.0
    Desktop: Cinnamon 5.2.7 wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una
    base: Ubuntu 20.04 focal
    Machine: Type: Desktop Mobo: Parallels model: Parallels Virtual Platform serial: <filter> BIOS: Parallels v: 13.3.2 (43368) date: 06/15/2018
    Graphics:
    Device-1: Parallels Accelerated Virtual Video Adapter driver: prl_vid v: 1.7.0 bus ID: 01:00.0 chip ID: 1ab8:4005
    Display: x11 server: X.Org 1.20.13 driver: none resolution: 1604x985~60Hz
    OpenGL: renderer: Parallels using NVIDIA GeForce GT 755M OpenGL Engine

    $ xrandr
    Screen 0: minimum 0 x 0, current 2010 x 1232, maximum 8192 x 8192
    Virtual1 connected primary 2010x1232+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    1024x768 59.95 +
    2010x1232 59.96*+
    2560x1440 59.97
    2008x1188 59.98
    1920x1200 59.95
    1844x1082 59.95
    1600x1200 59.95
    1680x1050 60.00
    1400x1050 60.00
    1280x1024 59.95
    1440x900 59.99
    1280x960 59.99
    1280x800 59.96
    800x600 59.96
    640x480 59.94
    Virtual2 disconnected (normal left inverted right x axis y axis)
    ...
    Virtual16 disconnected (normal left inverted right x axis y axis)

    $ ls /lib/xorg/modules/drivers
    amdgpu_drv.so modesetting_drv.so prlvidex_drv.so vmware_drv.so
    ati_drv.so nouveau_drv.so qxl_drv.so
    fbdev_drv.so prlvidel_drv.so radeon_drv.so
    intel_drv.so prlvideo_drv.so vesa_drv.so
     
  2. Trishna Oobeyram

    Trishna Oobeyram Staff Member

    Messages:
    265
    Hello JMP_5,

    Thank you for reporting this issue.
    Parallels Tools should work without any issue with the recent Linux VMs.
    However, let us inform you that in order for Parallels Tools to work as It should, the version of Parallels Desktop also should align.
    As per your description, you are trying to run Parallels Tools 16/17/18 on Parallels Desktop 13, and it is possible that certain features might not work as expected.
    Parallels Desktop 13 has reached the end of life, so we don't provide support for this version and don't guarantee it'll work properly: https://kb.parallels.com/123560
    As a suggestion, you can purchase an upgrade license key for a discounted version for the latest version of Parallels Desktop and check if it works there:
    https://www.parallels.com/products/desktop/buy/?upg

    Thank you!
     
  3. JMP_5

    JMP_5 Bit poster

    Messages:
    7
    Thank you. Posted here in the forums, because realize this is not a supported combination. No current Parallels desktop software would be compatible with the El Capitan host Mac OS. Since noticed somewhat similar problems with Tools have been reported - at least for not-officially-supported Linux distributions - thought to first check whether or not this this was a Tools/Ubuntu 22.04-based-linux situation.
    If others are running that guest OS with Tools permitting higher screen resolutions, will post a separate query in case a user here might have a useful comment or even workaround.
     
  4. parallelso

    parallelso Junior Member

    Messages:
    17
    Another has tried your hack of upgrading the guest tools and things appear to work for Debian 11 on macOs High Sierra with Parallels 14 host and Parallels 18 guest tools. If you are able to install a patched version of Sierra or High Sierra and it is stable, you should be able to use a later version of Parallals and have success.

    There may be a way to trick the guest tools, such as set the guest screen size during boot or before login, or in the graphics driver setting files or similar, before the guest tools are running, to make it appear that the custom screen size you want is a standard screen size to be used.
     
  5. JMP_5

    JMP_5 Bit poster

    Messages:
    7
    Thanks for the interesting additional info.
    According to the specs Parallels 13 is OK with High Sierra. Might be something to try even before accessing Parallels Desktop 14+ ...
    Have Debian 11 experiment below.
    Had posted on other Linux forums, and did not get a response for alternate ways to set the max display resolutions.
    Would like to know if the Debian poster has dynamic/higher screen resolution working as expected in that Debian install.

    If my experience helps anyone:
    Summary:
    Parallels Tools 16 installs and runs all obvious functions including video/dynamic screen resolution if the Linux distro is running X.Org Server 1.20. PT 16 will not install in presence of X.Org Server 1.21. For a more recent Linux with X.Org Server 1.21, PT 17/18 installs without indicating an error, but fails to implement proper video drivers, etc, for variable and higher resolution display settings.

    Detail (Parallels Desktop 13, Tools 16-18, Mac OS El Capitan):
    When Parallels Tools 16 would not install on Linux Mint 21 - "Error: Xorg version 1.21 not supported" - posted here wondering whether Tools 17/18 video/resolution worked with recent Mint/Ubuntu in any editions of Parallels desktop.
    Re: Debian: Since the exact relationship between Debian and Ubuntu is murky to me (Ubuntu is based on debian-unstable) just downloaded the current Debian 11 iso, and made a quick VM. It reads as version 11.7, bullseye like Mint 21, but is running X.Org Server 1.20 like Mint 20.
    Once again, after the complete install in Debian, the Parallels Tools 18 video drivers, etc, failed and resolution was limited to max 1400 x 1050.
    Tried Parallels 16, which had worked with Mint 20, but would not install on Mint 21. Debian 11 allowed it to install, and functions including Tools-video resolutions do work fine in Debian 11 (max res 8192x8192).
    PS Did not have to copy over the PT installer, just used the "Installing Parallels Tools in other versions of Linux guest OSs" instructions here to run it.
     
  6. JMP_5

    JMP_5 Bit poster

    Messages:
    7
    Mistyped Mint-Debian above, and can't edit posts here:
    $ cat /etc/debian_version
    in Linux Mint 21, returns bookworm (~ Debian 12)
    in Linux Mint 20, returns bullseye (~ Debian 11)
     
  7. parallelso

    parallelso Junior Member

    Messages:
    17
    I installed Debian 11.6 guest with Xfce desktop using Parallels 15 host and Parallels 18 tools. The tools install required manual install of some package dependancies but installed. After reboot, resizing the Parallels VM window does not update the Debian guest display size, it is stuck at the small install display size. However, one can manually set the Debian guest display size in the Xfce desktop display settings (and likely elsewhere), and the Parallels VM window will resize to accommodate. The Xfce display settings show many different screen sizes, up to 4096x2160. Below is partial output from the xrandr command showing maximum screen size 8192 x 8192. If you do not need to frequently resize the Parallels VM windows, this is a solution. I do not know how things are working under Parallels 13/14 host.

    $ xrandr
    Screen 0: minimum 320 x 200, current 1192 x 779, maximum 8192 x 8192
    Virtual-1 connected primary 1192x779+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    1192x779 59.98*+
    4096x2160 60.00 59.94
    2560x1600 59.99 59.97
    1920x1440 60.00
    ...
     
  8. HelloL1

    HelloL1 Bit poster

    Messages:
    1
     

    Attached Files:

  9. parallelso

    parallelso Junior Member

    Messages:
    17
    I wonder if this upgrading the guest tools is possible with other virtualization hosts such as VMware, VirtualBox, and other. This creates possibilities of extending the useful service life of legacy hardware and OSes.
     
  10. JMP_5

    JMP_5 Bit poster

    Messages:
    7
    Appreciate the information. It helps my understanding of the challenge.
    In the case of screen-res with PD13, looks like will have to find another method.
    Of course would expect it to be so, but before considering upgrading, would still like to find a post somewhere in which a current user confirms that PD18/PT18 work as expected with recent Linux distros which use X.Org Server 1.21+ (current Ubuntu/Mint, presumably later 2023 Debian 12 bookworm).
     

Share This Page