Issues for Mouse and Coherence after DskTp 15 install for Cento07, Kali 2018.4 and 2019.2

Discussion in 'Linux Guest OS Discussion' started by JohnP13, Aug 13, 2019.

  1. JohnP13

    JohnP13 Bit Poster

    Messages:
    25
    On my MacOS, with the new Parallels Desktop 15 update, I open Window 10 1903, and Ubuntu 18.04.02, as well as Windows 7, and all goes well with the Toolbox update. However, not the case for CentOS7, Kali 2018.4 and Kali 2019.2, for all three OS's, I have a non-sync mouse, no coherence supported, and the screen is super big in the window and up close no matter how you adjust it. For CentOS7, I can't even get to the OS, it hangs at starting up the Gnome Display, and I'm unable to get to a command line or anything safe mode like. However for the two versions of Kali, they boot, and run. Anyone else having issues? What can I try to get these Linux OS's free and clear. I don't mind installing a new CentOS7, I think I have 7.5, and now 7.6 is out. Please let me know. Thanks
     
    d4Rk likes this.
  2. AlanM11

    AlanM11 Bit Poster

    Messages:
    1
    I have the same issue with Kali 2019.2 on Parallels 15. I have uninstalled the Parallels Tools from the command line to allow some functionality but disappointed as it worked well under Parallels 14.
     
  3. Shireo

    Shireo Bit Poster

    Messages:
    7
    +1 yes agree with @allanM11 was seamless on Parallels on 14 but definitely a no go on 15. Infect was working fine on 15 until the tools updated
     
  4. Shireo

    Shireo Bit Poster

    Messages:
    7
    *infact. not infect haha
     
  5. Shireo

    Shireo Bit Poster

    Messages:
    7
    morale of the story......don't upgrade my parallels 3 days before a major assessment is due :(
     
  6. Shireo

    Shireo Bit Poster

    Messages:
    7
    submitted technical report #319800288
     
  7. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    82
    Work around for Kali Linux - add kernel command line parameter: prl_tg.usedrm=0
    1. Open /etc/default/grub file and add prl_tg.usedrm=0 to GRUB_CMDLINE_LINUX_DEFAULT variable.
    2. Run update-grub to update grub configuration.
    3. Reboot
     
  8. JohnP13

    JohnP13 Bit Poster

    Messages:
    25
    The same exact and issue with Kali also exists or CentOS7, what would be the workaround?
     
  9. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    82
    Just checked CentOS 7.4 and 7.6 with PD15 - ok for me.
    So, i need a bit more info about issue with CentOS:
    1. Collect guest system logs:
    journalctl -b 0 > guest.log
    /var/log/Xorg.*
    /var/log/parallels*
    2. Move collected logs from guest to host system (for example with scp)
    3. Create problem report and attach files from (1)
    4. Post problem report ID here or
     
  10. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    82
    ps: If Parallels Tools was installed inside guest, your need just create problem report and post report ID here.
     
  11. JohnP13

    JohnP13 Bit Poster

    Messages:
    25
    Where am I to exec that command, Centos7, MacOS, if so what Dirs, as SU??
     
  12. JohnP13

    JohnP13 Bit Poster

    Messages:
    25
    Alright, I have a new ticket, #2640949, with Technical Report ID #319840154 that outlines this issue. I had opened a ticket on this yesterday, though it had no Tech Rpt ID, and that ticket number is: #2640949. Thank you for the help. IF I need to install a newer version of CentOS, that I will, I just would like to save this one, as I had spent a lot of hard work installing a lot of R related software on that VM, and would hate to lose it all.
     
  13. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    82
    Do this inside CentOS7. No need to be SU.

    According to this problem report, it looks like Parallels Tools was not updated correctly. Just try to reinstall Parallels Tools and reboot CentOS after this.
     
  14. Shireo

    Shireo Bit Poster

    Messages:
    7
    Ok I've just attempted to manually resinstall the tools on Kali with no success. I did have an error while trying to execute the install script, however this https://superuser.com/questions/1195551/installing-parallels-tools-in-kali-linux resolved my inability to install due to a mount problem. From there I could re-install manually from the cli, albeit not being able to see much due to the screen size and inability to re-size or see the mouse it so it was a lot of hit enter and hope its defaulting to the correct response, which it was. However the manual install process succeeded and reboot ensured, same problem persists.

    I had resubmitted a new technical report 319868838 as part of my open support ticket.

    It definitely looks as though the tools are not running , if I try and go full screen, I get the following error "Unable to switch to coherence - The Parallels mouse synchronixation service is not started. Reinstall Parallels Tools and try again"
     
  15. Shireo

    Shireo Bit Poster

    Messages:
    7
    Ok some more success....

    I have manually removed the tools via /user/lib/parallel-tools -r and rebooted, I now have mouse and screen back to semi normal state.

    Re-installed tools and back to original problem so have now removed parallel tools for the time being so at least kali is usable
     
  16. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    82
    To workaround issue with Kali Linux if Parallels Tools was installed you can use kernel command line parameter prl_tg.usedrm=0

    Also you can remove Parallels Tools, but in this case you will lose integration features (shared folders, shared printers, dynamic resolution, copy-paste)
     
  17. d4Rk

    d4Rk Bit Poster

    Messages:
    4
    Same issue here, Kali used to work just perfectly, and now after purchasing and installing Parallels 15, everything is fucked -.-

    The only thing that kinda worked for me, was to get rid of parallels tools.
    The correct command for that is btw: `sudo /usr/lib/parallels-tools/install -r` then reboot.
     
  18. JeffreyK2

    JeffreyK2 Bit Poster

    Messages:
    1
    I had the same issue on Kali and I was able to get it working by updating the kernel command line parameter that Alexander mentioned. I didn't have to uninstall/re-install parallels-tools. It was kind of a pain with the zoomed in screen and hidden mouse, but keyboard shortcuts are your friend.
    Here are my steps:
    1. Open terminal (command + type 'terminal' + enter)
    2. Run: gedit /etc/default/grub
    3. In gedit, update the line GRUB_CMDLINE_LINUX_DEFAULT to include prl_tg.usedrm=0. It should looks something like this:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet prl_tg.usedrm=0"​
    4. control + s to save
    5. control + q to quit gedit
    6. back in terminal run: update-grub
    7. then reboot
     
    Shireo and d4Rk like this.
  19. Shireo

    Shireo Bit Poster

    Messages:
    7
    worked a treat @jefferyK2 thanks for sharing the solution
     
  20. JohnP13

    JohnP13 Bit Poster

    Messages:
    25
    I just tried this on Kali 2019.2, and now it won't boot up, it freezes/hang and locks up right as I start the machine.
     

Share This Page